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Overview
The BlackBerry Enterprise Server Resource Kit is a suite of tools that you can use to help manage and monitor an MDM
domain. You can download the BlackBerry Enterprise Server Resource Kit from www.blackberry.com/support/downloads.

The BlackBerry Enterprise Server Resource Kit consists of the following tools:

• BlackBerry Enterprise Server User Administration Tool: a command-line tool that allows you to collect statistics and
manage user accounts and devices.

• BlackBerry Enterprise Transporter: an application that you can use to migrate user accounts from an MDM domain to a
different MDM domain.

• BlackBerry Analysis, Monitoring, and Troubleshooting Tools: various tools that you can use to collect and analyze user
data and log files.

This guide provides the configuration and use instructions for the BlackBerry Analysis, Monitoring, and Troubleshooting
Tools. For more information about the BlackBerry Enterprise Server User Administration Tool and the BlackBerry
Enterprise Transporter, visit www.blackberry.com/go/serverdocs to read the BlackBerry Enterprise Server User
Administration Tool Administration Guide and the BlackBerry Enterprise Transporter Installation and Administration Guide.

BlackBerry Analysis, Monitoring, and
Troubleshooting Tools
You can use the BlackBerry Analysis, Monitoring, and Troubleshooting Tools to streamline management tasks, monitor
events, collect statistics, and troubleshoot issues with the BlackBerry Enterprise Server components.

The following BlackBerry Analysis, Monitoring, and Troubleshooting Tools are available:

Tool Description

BlackBerry Directory Sync Tool
(DirectorySync.exe)

You can use this application to synchronize the membership of security
groups and distribution groups in Microsoft Active Directory with groups on a
BlackBerry Enterprise Server.

The tool can synchronize groups only if the user accounts in Microsoft Active
Directory have matching user accounts on the BlackBerry Enterprise Server.
If matching user accounts do not exist on the BlackBerry Enterprise Server,

1
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Tool Description

you can add the user accounts manually using the BlackBerry Administration
Service, or you can enable the provisioning feature so that the tool can add
user accounts during the synchronization process.

BlackBerry Application Reporting Tool
(HHAppReport.exe)

You can use this command-line tool to list the applications that are installed
on BlackBerry devices in an MDM domain. You can use this tool to audit the
MDM domain and evaluate the applications that are installed on devices.

BlackBerry IT Policy Import and Export
Tool (ITPolicyImportExport.exe)

You can use this command-line tool to export IT policy information from a
BlackBerry Configuration Database to a backup file. You can use the backup
file to import the information to a different BlackBerry Configuration
Database, making the IT policies available to a different MDM domain.

BlackBerry Message Receipt
Confirmation Tool
(MessageConfirmService.exe)

You can use this application to verify that the BlackBerry Enterprise Server is
successfully delivering messages to devices. At an interval that you specify,
the tool sends a message to the specified user accounts, monitors the status
of the message, and confirms that the devices received the message.

BlackBerry System Log Monitoring and
Reporting Tool (BESSysLog.exe)

You can use this application to monitor the BlackBerry Enterprise Server log
files for events generated by the BlackBerry Dispatcher and the BlackBerry
Messaging Agent. You can specify which components to monitor, the events
that you want to track, and the types of notifications and reports that you
want the tool to send to administrators.

BlackBerry Enterprise Server Log
Monitoring Tool (LogMonitor.exe)

You can use this command-line tool to monitor the information that is written
to the log files for BlackBerry Enterprise Server components. You can specify
actions that you want the tool to perform when it finds specific values, such
as events or text strings. For example, you can configure the tool to run a
custom batch file when it finds a specific event ID in the BlackBerry
Dispatcher log file.

BlackBerry System Requirements Tool
(BBCheckCmd.exe)

You can use this application to determine whether a computer can run a
BlackBerry Enterprise Server component successfully.

BlackBerry Domain Administration
History Reporting Tool (AdminHistory.exe)

You can use this command-line tool to read the ServerConfigHistory table in
the BlackBerry Configuration Database. The tool displays configuration
changes, such as newly added user accounts, in a .csv file. The tool records
the date and time of each change and the name of the administrator who
made the change.

The tool is designed for use only with BlackBerry Enterprise Server 4.1 SP7
and earlier.
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BlackBerry Enterprise Server Log Analysis Tool
The BlackBerry Enterprise Server Log Analysis Tool is an application that you can use to run various log analysis tools that
check the BlackBerry Enterprise Server log files and collect data about user accounts, message flow, server performance,
and historical statistics. You can configure and run the log analysis tools from the BlackBerry Enterprise Server Log
Analysis Tool, or you can run the tools individually using the command prompt.

Tool Description

BlackBerry Calendar Synchronization
Reporting Tool (CalSync.exe)

Collects data from the BlackBerry Messaging Agent (MAGT) log file about the
calendar synchronization process that you can enable using the BlackBerry
Enterprise Trait Tool.

BlackBerry Delayed Notifications
Monitoring Tool
(DelayedNotifications.exe)

Analyzes the BlackBerry Messaging Agent (MAGT) log file and detects when
the BlackBerry Enterprise Server is no longer receiving regular notifications
for new email messages and calendar items.

Designed for use in a Microsoft Exchange environment only.

BlackBerry Historical Statistics Tool
(HistoricalStats.exe)

Analyzes the BlackBerry Dispatcher (DISP) log file and the BlackBerry
Messaging Agent (MAGT) log file to provide statistics about daily use patterns
for each user account.

BlackBerry MAPI and CDO Error
Monitoring Tool (MapiCdoErrors.exe)

Analyzes the BlackBerry Messaging Agent (MAGT) log file to identify
common MAPI and CDO errors and custom events.

Designed for use in a Microsoft Exchange environment only.

BlackBerry MDS Services Data Monitoring
Tool (MDSPushvsPull.exe)

Analyzes the (MDAT) log file to determine whether the BlackBerry MDS
Connection Service processes more data from push applications or from
BlackBerry Browser requests.

BlackBerry Message Flow Reporting Tool
(Messageflow.exe)

Analyzes the BlackBerry Dispatcher (DISP), BlackBerry Messaging Agent
(MAGT), and BlackBerry Router (ROUT) log files to track the flow of
messages through the BlackBerry Enterprise Server to devices.

BlackBerry Thread Analyzer Tool
(NoResponseCheck.exe)

Analyzes all BlackBerry Enterprise Server log files (except for the MDAT and
instant messaging log files) to identify threads that are nonresponsive, and to
distinguish between true nonresponsive threads and slow threads.

BlackBerry Message Pending Delivery
Tool (Pending.exe)

Analyzes the BlackBerry Messaging Agent (MAGT) log file to track user
accounts that have a pending message count that is higher than a maximum
count that you specify.

BlackBerry Usage Monitoring Tool
(OutofCoverage.exe)

Analyzes the BlackBerry Dispatcher (DISP) log file to check for devices that
do not send or receive data in a specified period of time.

BlackBerry User Activity Reporting Tool
(AvailIndex.exe)

Analyzes the BlackBerry Messaging Agent (MAGT) log file to create a
snapshot report of user account activity over a period of days.
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Tool Description

Designed for use in a Microsoft Exchange environment only.

What's new in the BlackBerry Analysis,
Monitoring, and Troubleshooting Tools
Tool New feature

BlackBerry Directory Sync Tool You can now use the tool to provision new user accounts on the BlackBerry
Enterprise Server. When you enable provisioning, you map Microsoft Active
Directory groups to virtual provisioning groups. During the synchronization
process, the tool identifies the Microsoft Active Directory users that do not have
matching user accounts on the BlackBerry Enterprise Server, and adds the user
accounts as necessary.

The tool can add the user accounts to the BlackBerry Enterprise Server as
device-enabled user accounts, or as administrator accounts that are not device-
enabled.

If you enable deprovisioning, the tool identifies user accounts that are not
mapped to a virtual provisioning group and removes them from the BlackBerry
Enterprise Server. For more information about provisioning rules, see 
Synchronization and provisioning rules.

If you enable provisioning and deprovisioning, it is a best practice to add and
remove user accounts from the BlackBerry Enterprise Server using the tool only,
instead of adding and removing the user accounts manually using the
BlackBerry Administration Service. For more information, see Prerequisites and 
Synchronization and provisioning rules.

BlackBerry Domain Search BlackBerry Domain Search has been deprecated due to the release of
BlackBerry Mobile Fusion Studio. For more information about BlackBerry
Mobile Fusion Studio, visit www.blackberry.com/go/serverdocs to see the
BlackBerry Mobile Fusion Studio Installation Guide and the BlackBerry Mobile
Fusion Studio Administration Guide.
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Support for UTF-8 encoding
The BlackBerry Analysis, Monitoring, and Troubleshooting Tools support UTF-8 encoding for input files and for the
characters that you type in the command prompt. The tools are compatible with input files that you save using UTF-8
encoding.

The tools that use a command prompt support UTF-8 encoded characters that you type using keystroke commands, or
that you copy and paste from the character map in the command prompt.

Configuring the BlackBerry Enterprise
Server User Administration Tool and the
BlackBerry Analysis, Monitoring, and
Troubleshooting Tools to use UAC-
compliant file paths
If you install the BlackBerry Enterprise Server User Administration Tool or any of the BlackBerry Analysis, Monitoring, and
Troubleshooting Tools that use a command-line interface, when you run the setup application you can specify whether you
want the tool to use a UAC-compliant file path for configuration files, input files, output files, and log files. The setup
application creates a subfolder for the files in the application data folder for the current user. For example:

• Configuration files: <drive>:\Users\<user_name>\AppData\Local\VirtualStore\Program Files (x86)\Research In Motion
\BlackBerry Enterprise Server Resource Kit

• Log files, reports, input files and output files: <drive>:\Users\<user_name>\AppData\Roaming\Research In Motion\AMT
\ or <drive>:\Documents and Settings\<user_name>\Application Data\Research In Motion\AMT\

When you use the BlackBerry Enterprise Server User Administration Tool or any of the BlackBerry Analysis, Monitoring,
and Troubleshooting Tools that use a command-line interface, you can use the -uac or -no_uac subparameters when you
run a command to override the setting that you configured when you installed the tool. For example, if you configured the
BlackBerry Application Reporting Tool to use a UAC-compliant file path, you can use the -no_uac subparameter to write
output files and log files to a file path that is relative to the current working directory (for example, <drive>:\Program Files
\Research In Motion\BlackBerry Enterprise Server Resource Kit\BlackBerry AMT Tools) .
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BlackBerry Directory Sync Tool
The BlackBerry Directory Sync Tool is an application that you can use to synchronize the membership of security groups
and distribution groups in Microsoft Active Directory with groups on a BlackBerry Enterprise Server. After you map one-to-
one relationships between Microsoft Active Directory groups and BlackBerry Enterprise Server groups, you can start the
synchronization process manually, or you can use a task scheduling application to run the synchronization at a set interval.

When you run the synchronization process, it compares the Microsoft Active Directory group to the BlackBerry Enterprise
Server group that you mapped it to. If the tool finds any differences in group membership, it assigns user accounts to, or
removes user accounts from, the BlackBerry Enterprise Server group until the membership matches the Microsoft Active
Directory group. For more information about synchronization rules, see Synchronization and provisioning rules.

The tool can synchronize groups only if the user accounts in Microsoft Active Directory have matching user accounts on the
BlackBerry Enterprise Server. If matching user accounts do not exist on the BlackBerry Enterprise Server, you can add the
user accounts manually using the BlackBerry Administration Service, or you can enable the provisioning feature so that the
tool can add user accounts during the synchronization process.

When you enable provisioning, you map Microsoft Active Directory groups to virtual provisioning groups. During the
synchronization process, the tool identifies the Microsoft Active Directory users that do not have matching user accounts
on the BlackBerry Enterprise Server, and adds the user accounts as necessary. If you enable deprovisioning, the tool
identifies user accounts that are not mapped to a virtual provisioning group and removes them from the BlackBerry
Enterprise Server. For more information about provisioning rules, see Synchronization and provisioning rules.

If you enable provisioning and deprovisioning, it is a best practice to add and remove user accounts from the BlackBerry
Enterprise Server using the tool only, instead of adding and removing the user accounts manually using the BlackBerry
Administration Service. For more information, see Prerequisites and Synchronization and provisioning rules.

2
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Configure the BlackBerry Directory Sync
Tool

Configure the BlackBerry Directory Sync Tool to search
for groups in Microsoft Active Directory
1. On the computer that hosts the BlackBerry Directory Sync Tool, on the taskbar, click Start > All Programs >

BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Directory Sync Tool client.

2. In the Directory Group Search section, click Configure.

3. In the Server Discovery drop-down list, perform one of the following actions:

• If you want the tool to search for Microsoft Active Directory groups in the domain that you are currently logged in
to, click Automatic. The Windows account that you are currently using must have read permissions for Microsoft
Active Directory.

• If you want the tool to search for Microsoft Active Directory groups in a specific domain or server, click Manual.

4. If necessary, in the Domain or Server field, type the name of the domain or server that hosts Microsoft Active
Directory.

5. If necessary, in the Port field, type the port number that you want the tool to use to connect to Microsoft Active
Directory. The default port number is 389.

6. If you want the tool to limit the search to a specific DN, in the Search Path DN field, type the path of the DN (for
example, OU=Groups,DC=sample,DC=net).

7. In the Maximum Results field, type the maximum number of Microsoft Active Directory groups that you want the tool
to find and display.

8. In the Group search drop-down list, perform one of the following actions:

• If you want the tool to discover and list the Microsoft Active Directory groups automatically, click Automatic.

• If you want to search for Microsoft Active Directory groups manually using a search field, click Manual.

9. Click Save.

Related information
No Directory groups to display. Please check the configuration, 31
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Configure the BlackBerry Directory Sync Tool to search
for groups in an MDM domain
1. On the computer that hosts the BlackBerry Directory Sync Tool, on the taskbar, click Start > All Programs >

BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Directory Sync Tool client.

2. In the BlackBerry Group Search section, click Configure.

3. In the Administrator Credentials section, in the Authentication Type drop-down list, perform one of the following
actions:

• If the administrator account that you want the tool to use to access the BlackBerry Enterprise Server uses
Microsoft Active Directory authentication, click Active Directory.

• If the administrator account that you want the tool to use to access the BlackBerry Enterprise Server uses
BlackBerry native authentication, click Native.

4. In the Username field, type the user name of the BlackBerry Enterprise Server administrator account. The
administrator account must exist in and have the required permissions in every MDM domain that you want the tool
to connect to.

5. In the Password field, type the password of the BlackBerry Enterprise Server administrator account.

6. If necessary, in the Domain field, type the name of the Microsoft Active Directory domain.

7. In the Add BlackBerry Domain section, in the Label field, type a label for an MDM domain.

8. In the Hostname field, type the FQDN of the computer that hosts the BlackBerry Administration Service for the MDM
domain (for example, BAS-HOST1.test.rim.net).

9. If necessary, in the Port field, type the port number that you want the tool to use to connect to the BlackBerry
Administration Service. The default value for the BlackBerry Administration Service is 443 (BlackBerry Enterprise
Server) or 3443 (BlackBerry Enterprise Server Express).

10. Click Add.

11. Repeat steps 7 to 10 for each MDM domain that you want the tool to connect to.

12. Click Save.

Related information
No BlackBerry groups to display. Please check the configuration, 31
Exception retrieving BlackBerry groups, 32
Invalid URI: The hostname could not be parsed, 32
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Configure provisioning options
The tool can synchronize groups only if the user accounts in Microsoft Active Directory have matching user accounts on the
BlackBerry Enterprise Server. If matching user accounts do not exist on the BlackBerry Enterprise Server, you can add the
user accounts manually using the BlackBerry Administration Service, or you can enable the provisioning feature so that the
tool can add user accounts during the synchronization process.

1. On the computer that hosts the BlackBerry Directory Sync Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Directory Sync Tool.

2. In the BlackBerry Group Search section, click Configure.

3. In the Provisioning Options section, select Enable user provisioning with virtual provisioning mappings.

4. If you want the tool to manage the removal of user accounts from the BlackBerry Enterprise Server, select Enable
user de-provisioning when removed from provisioning mappings. In the De-provisioning Warning dialogue box, click
Yes. In the De-provisioning action drop-down list, perform one of the following actions:

• If you want the tool to remove user accounts from the BlackBerry Enterprise Server if they do not exist in Microsoft
Active Directory groups that are mapped to virtual provisioning groups, click Delete users.

• If you want the tool to identify in the report and the log file the user accounts that should be deleted, and you do
not want the tool to delete the user accounts, click Log only. Use the information in the report or log file to remove
the user accounts using the BlackBerry Administration Service.

5. Click Save.

After you finish: Configure mappings between Microsoft Active Directory groups and virtual provisioning groups.

Related information
Map groups in Microsoft Active Directory to virtual provisioning groups, 23
Synchronization and provisioning rules, 19

Configure reporting preferences
1. On the computer that hosts the BlackBerry Directory Sync Tool, on the taskbar, click Start > All Programs >

BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Directory Sync Tool client.

2. Click Edit > Preferences.

3. If you want to hide "User not found" warning messages in the report when the tool tries to assign user accounts to
groups, select the Suppress "User not found" warnings when assigning users to groups check box.

4. Click Save.
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Related information
Interpreting the reports that the BlackBerry Directory Sync Tool creates, 27

Change the performance and configuration settings for
the BlackBerry Directory Sync Tool
The BlackBerry Directory Sync Tool retrieves information from Microsoft Active Directory by reading standard property
names for group names, email addresses, and user display names. If your organization uses property names that are not
standard, you can edit the configuration file to specify the property names.

You can change the performance settings for the BlackBerry Directory Sync Tool if you want to change how the tool
completes the provisioning and synchronization process. It is a best practice to use the default performance settings for
the tool. Changing the settings might have a performance impact on your organization's BlackBerry Mobile Fusion
environment.

1. On the computer that hosts the BlackBerry Directory Sync Tool, navigate to <drive>:\Program Files\Research In
Motion\BlackBerry Enterprise Server Resource Kit\BlackBerry AMT Tools .

2. In a text editor, open the DirectorySync.exe.config file.
If your computer's operating system uses UAC and does not permit you to modify the configuration file at this
location, open the virtualized copy of the DirectorySync.exe.config file in the application data folder for the current
user (for example, <drive>\Users\<user_name>\AppData\Local\VirtualStore\Program Files (x86)\Research In Motion
\BlackBerry Enterprise Server Resource Kit).

3. If your organization uses a property name for group names in Microsoft Active Directory that is not standard, in the
<appSettings> section, type <add key="groupNameProperty" value="<group_property_name>"/>, where
<group_property_name> is the required property name. The default value is "name".

4. If your organization uses a property name for email addresses in Microsoft Active Directory that is not standard, in the
<appSettings> section, type <add key="emailAddressProperty" value="<email_property_name>"/>, where
<email_property_name> is the required property name. The default value is "mail".

5. If your organization uses a property name for user display names in Microsoft Active Directory that is not standard, in
the <appSettings> section, type <add key="displayNameProperty" value="<display_property_name>"/>, where
<display_property_name> is the required property name. The default value is "displayName".

6. To specify the maximum number of changes that you want the tool to synchronize to a group each time you run the
tool, in the <appSettings> section, type <add key="maxNumberOfChanges" value="<max_changes>"/>, where
<max_changes> is a value greater than zero. The default value is 0 (no limit). When you start the synchronization
process, the tool counts the number of changes to be made to a group; if the number of changes exceeds the value
that you specified, the tool does not make any changes to the group.

7. To specify the maximum size of a BlackBerry Enterprise Server group that the tool can synchronize changes to, in the
<appSettings> section, change the value of <add key="maxNumberOfUsersInBasGroup"
value="<max_users_group>"/>, where <max_users_group> is the maximum number of user accounts in a group.
The tool does not synchronize changes to BlackBerry Enterprise Server groups with more user accounts than the
value that you specify. The default value is 2000.
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8. To specify how long you want the tool to wait before synchronizing each change (for example, assigning a user
account to a group), in the <appSettings> section, change the value of <add key="changeDelay"
value="<change_delay>"/>, where <change_delay> is a value greater than zero, in seconds. The default value is 1
second.

9. To specify the maximum level of nested groups that the tool can synchronize, in the <appSettings> section, type
<add key="maxNestingLevel" value="<max_nesting_level>"/>, where <max_nesting_level> is a value of 0 or
greater. The default value is -1 (no limit).

10. To specify the maximum number of errors that can occur before the tool stops performing actions in an MDM
domain, in the <appSettings> section, type <add key="maxNumberOfErrors" value="<max_errors>"/>, where
<max_errors> is a value of 0 (no limit) or greater. The default value is 5.

11. To specify the minimum number of assignments before the tool caches all of the users in an MDM domain instead of
searching for the users individually, in the <appSettings> section, type <add key="bbUserCacheThreshold"
value="<threshold>"/>, where <threshold> is a value of 0 (no cache) or greater. The default value is 100. If you want
the tool to perform a large number of synchronization tasks, caching might improve the tool's performance.

12. To change the level of logging information written to the BlackBerry Directory Sync Tool console, in the
<appSettings> section, type <add key="consoleLogLevel" value="<log_level>"/>, where <log_level> is a value
between 0 (no logging) and 5 (trace log level).

13. To change the level of logging information written to the BlackBerry Directory Sync Tool log files, in the
<appSettings> section, type <add key="fileLogLevel" value="<log_level>"/>, where <log_level> is a value between
0 (no logging) and 5 (trace log level).

14. Save and close the DirectorySync.exe.config file.

Example appSettings section

<appSettings>
    <add key="groupNameProperty" value="GroupExample"/>
    <add key="emailAddressProperty" value="EmailExample"/>
    <add key="displayNameProperty" value="DisplayNameExample"/>
    <add key="maxNumberOfChanges" value="1000"/>
    <add key="maxNumberOfUsersInBasGroup" value="1000"/>
    <add key="changeDelay" value="2"/>
    <add key="maxNestingLevel" value="5"/>
    <add key="maxNumberOfErrors" value="10"/>
    <add key="bbUserCacheThreshold" value="150"/>
    <add key="consoleLogLevel" value="5"/>
    <add key="fileLogLevel" value="5"/>
</appSettings>
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Configure the BlackBerry Directory Sync Tool to skip
certificate validation
When the BlackBerry Directory Sync Tool connects to the BlackBerry Administration Service, it verifies that the FQDN that
you configured the tool to use matches the SSL certificate of the BlackBerry Administration Service. You can configure the
tool to skip this verification process for specific servers.

1. On the computer that hosts the BlackBerry Directory Sync Tool, navigate to <drive>:\Program Files (x86)\Research In
Motion\BlackBerry Enterprise Server Resource Kit\BlackBerry Directory Sync Tool.

2. In a text editor, open the DirectorySync.exe.config file.
If your computer's operating system uses UAC and does not permit you to modify the configuration file at this
location, open the virtualized copy of the DirectorySync.exe.config file in the application data folder for the current
user (for example, <drive>\Users\<user_name>\AppData\Local\VirtualStore\Program Files (x86)\Research In Motion
\BlackBerry Enterprise Server Resource Kit).

3. In the <appSettings> section, type the following: <add key="certValidationExcludedHosts" value="<server>"/>,
where <server> is the FQDN or IP address of the computer that hosts the BlackBerry Administration Service. If you
want to specify multiple computers, separate each FQDN or IP address using a comma ( , ) or semi-colon ( ; ).
Example: <add key="certValidationExcludedHosts" value="server1.testnet.company.net;192.0.2.124"/>

4. Save and close the DirectorySync.exe.config file.

After you finish: Restart the BlackBerry Directory Sync Tool.

Prerequisites
• The user accounts that you want to synchronize from Microsoft Active Directory groups must have matching user

accounts on the BlackBerry Enterprise Server. If matching user accounts do not exist on the BlackBerry Enterprise
Server, add the user accounts manually, or enable provisioning so that the tool can add the user accounts to the
BlackBerry Enterprise Server during the synchronization process. For more information about the provisioning feature,
see Configure provisioning options.

• The Windows account that you use to run the tool must have read permissions for Microsoft Active Directory.

• The administrator account that you configure the tool to use must exist in every MDM domain that you want the tool to
connect to. In a BlackBerry Enterprise Server or BlackBerry Enterprise Server Express environment, the administrator
account must have a role with permissions to view and edit groups, and to create and delete user accounts.

• By default, the tool cannot synchronize changes to BlackBerry Enterprise Server groups that have more than 2000
members. If you want to synchronize changes to BlackBerry Enterprise Server groups that have more than 2000
members, change the maximum group size limit in the configuration file (DirectorySync.exe.Config). For more
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information about changing the configuration file, see Change the performance and configuration settings for the
BlackBerry Directory Synchronization Tool.

• If your organization uses property names for group names, email addresses, or display names that are not standard,
add the property names to the configuration file (DirectorySync.exe.Config) so that the tool can retrieve information
from Microsoft Active Directory. For more information about adding property names, see Change the performance and
configuration settings for the BlackBerry Directory Synchronization Tool.

• If any of the Microsoft Active Directory groups that you want to synchronize have nested subgroups, decide if you want
to synchronize the membership of the subgroups as well.

• If you enable provisioning and deprovisioning, it is a best practice to add and remove user accounts from the
BlackBerry Enterprise Server using the tool only, instead of adding and removing the user accounts manually using the
BlackBerry Administration Service. If you enable deprovisioning and configure the tool to be able to remove user
accounts, the tool requires that every user account on the BlackBerry Enterprise Server exists in a Microsoft Active
Directory group that is mapped to a virtual provisioning group. If you enable deprovisioning and do not configure and
maintain provisioning mappings, the tool could remove user accounts from the BlackBerry Enterprise Server
unexpectedly.

• It is a best practice to run the tool during low-usage periods. Depending on the number of changes that must be
synchronized, the tool might have a performance impact on your organization's environment.

• It is a best practice to always preview the provisioning and synchronization process so that you can verify that the
changes will occur as expected.

Related information
Change the performance and configuration settings for the BlackBerry Directory Sync Tool, 16

Synchronization and provisioning rules
Synchronization rules
Rule Description

One-way synchronization The tool synchronizes changes from Microsoft Active Directory groups to
BlackBerry Enterprise Server groups. Changes made to BlackBerry Enterprise
Server groups using the BlackBerry Administration Service do not affect the
membership of Microsoft Active Directory groups.

Does not manage user accounts that
are not integrated with Microsoft Active
Directory

The tool does not manage user accounts that have no Microsoft Active Directory
identifiers, for example, default system accounts like system administrator.

The tool can only manage user accounts that are associated with Microsoft
Active Directory user accounts (user accounts that were added to the
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Rule Description

BlackBerry Enterprise Server by importing user information from Microsoft
Active Directory).

Does not add groups The tool does not create new groups on the BlackBerry Enterprise Server.

One-to-one mappings The tool supports one-to-one mappings of Microsoft Active Directory groups to
BlackBerry Enterprise Server groups. You can configure as many one-to-one
mappings as required.

For example, if you want to map both Group A and Group B in Microsoft Active
Directory to Group 1 on the BlackBerry Enterprise Server, you can configure two
mappings: Group A to Group 1 and Group B to Group 1.

Nested subgroups You can configure the tool to synchronize nested groups in Microsoft Active
Directory with BlackBerry Enterprise Server groups. The tool does not create
new subgroups on the BlackBerry Enterprise Server.

For example, Group A in Microsoft Active Directory has a nested subgroup
called Group B. You create Group 1 with no members on the BlackBerry
Enterprise Server. You map Group A to Group 1 and you permit the tool to
synchronize nested groups. When you run the tool, the user accounts in Group A
and the nested Group B are assigned to Group 1.

Synchronization outcomes When you map a Microsoft Active Directory group to a BlackBerry Enterprise
Server group and run the synchronization process, the following occurs:

• If a user account exists in the Microsoft Active Directory group but not in the
BlackBerry Enterprise Server group, the tool adds the user account to the
BlackBerry Enterprise Server group.

• If a user account does not exist in the Microsoft Active Directory group but
does exist in the BlackBerry Enterprise Server group, the tool removes the
user account from the BlackBerry Enterprise Server group.

Force synchronization option If the tool cannot find the Microsoft Active Directory group, or the group is no
longer valid, one of the following occurs:

• If Force Synchronization is selected, the user accounts are removed from
the BlackBerry Enterprise Server group.

• If Force Synchronization is not selected, the user accounts are not removed
from the BlackBerry Enterprise Server group. Details are written to the report
and log file.

If you select this option, always preview the provisioning and synchronization
process so that you can verify that the changes will occur as expected.
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Rule Description

Provisioning resolves before
synchronization

If you configured mappings of Microsoft Active Directory groups to virtual
provisioning groups and mappings of Microsoft Active Directory groups to
BlackBerry Enterprise Server groups, the synchronization process resolves the
provisioning tasks first (adding or removing user accounts), then performs the
synchronization tasks.

Rules when the provisioning feature is disabled
Rule Description

Does not add user accounts If the tool identifies a Microsoft Active Directory user account that does not have
a matching user account on the BlackBerry Enterprise Server, the tool does not
add the user to the BlackBerry Enterprise Server, and cannot synchronize the
user account to a BlackBerry Enterprise Server group. The tool writes details to
the report and log file.

Rules when the provisioning feature is enabled
Rule Description

Adds user accounts You map a Microsoft Active Directory group to a virtual provisioning group and
start the synchronization process. If the tool identifies a Microsoft Active
Directory user account that does not have a matching user account on the
BlackBerry Enterprise Server, the tool adds the required user account to the
BlackBerry Enterprise Server.

If the Microsoft Active Directory group is mapped to the Provision User as
Device Enabled virtual provisioning group, the tool adds a device-enabled user
account. If the Microsoft Active Directory group is mapped to the Provision User
virtual provisioning group, the tool adds an administrator account that is not
device-enabled.

When the tool adds a device-enabled user account to the BlackBerry Enterprise
Server, the BlackBerry Enterprise Server does not send an activation email to
users. You must send the activation information to users.

Does not assign roles When the tool adds an administrator account that is not device-enabled to the
BlackBerry Enterprise Server, it does not assign an administrative role to the
account.

It is a best practice to assign roles to administrator accounts by mapping the
accounts to BlackBerry Enterprise Server groups that are already associated
with roles. You can also assign roles to administrator accounts using the
BlackBerry Administration Service.
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Rule Description

Deprovisioning If you enable deprovisioning, every user account on the BlackBerry Enterprise
Server must have a matching user account in a Microsoft Active Directory group
that is mapped to one of the virtual provisioning groups. If the tool identifies a
user account that does not exist in a provisioning mapping, the tool removes the
user account from the BlackBerry Enterprise Server (if the De-provisioning
action is set to Delete users). The tool does not remove user accounts that are
not integrated with Microsoft Active Directory.

Deprovisioning options If the tool identifies a BlackBerry Enterprise Server user account that does not
exist in a provisioning mapping, one of the following occurs:

• If the De-provisioning action is set to Delete users, the user account is
removed from the BlackBerry Enterprise Server.

• If the De-provisioning action is set to Log only, the user account is not
removed from the BlackBerry Enterprise Server. Details are written to the
report and log file. You can use this list to remove the user accounts
manually.

Provisioning priority If a Microsoft Active Directory user account is mapped to both types of virtual
provisioning groups, and the user does not currently have a matching user
account on the BlackBerry Enterprise Server, the tool adds the user to the
BlackBerry Enterprise Server as a device-enabled user account.

Provisioning conflicts If you add an administrator account to the BlackBerry Enterprise Server that is
not device-enabled, and you later try to add the user to the BlackBerry
Enterprise Server again as a device-enabled user account, the tool does not
complete the task and writes details to the report and log file. You can remove
and add the user again using the BlackBerry Administration Service, or you can
configure mappings to remove the user account and add the user account
again.

If you add a device-enabled user account to the BlackBerry Enterprise Server,
and you later try to add the user to the BlackBerry Enterprise Server again as an
administrator account that is not device-enabled, the tool does not complete the
task and writes details to the report and log file. You can remove and add the
user again using the BlackBerry Administration Service, or you can configure
mappings to remove the user account and add the user account again.

Administration Guide BlackBerry Directory Sync Tool

22



Map groups in Microsoft Active Directory to
virtual provisioning groups
If you want to use the tool to add user accounts to the BlackBerry Enterprise Server, you must enable the provisioning
feature and then map Microsoft Active Directory groups to virtual provisioning groups. When you run the synchronization
process, the tool identifies the Microsoft Active Directory users that do not currently have user accounts on the BlackBerry
Enterprise Server and adds the required user accounts. This process does not add the user accounts to BlackBerry
Enterprise Server groups; you must create separate mappings to synchronize group membership.

Before you begin: Enable and configure the provisioning feature. Fore more information, see Configure provisioning
options.

1. On the computer that hosts the BlackBerry Directory Sync Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Directory Synch Tool client.

2. In the Directory Group Search section, perform one of the following actions:

• If you configured the directory group search to be manual, in the search field, type the name of a Microsoft Active
Directory group. Click the Search button.

• If you configured the directory group search to be automatic, in the filter field, type the name of a Microsoft Active
Directory group.

3. In the results list, select a group.

4. In the BlackBerry Group Search section, perform one of the following actions:

• If you want to add device-enabled user accounts to the BlackBerry Enterprise Server, select the appropriate
Provision User as Device Enabled virtual provisioning group.

• If you want to add administrator accounts that are not device-enabled to the BlackBerry Enterprise Server, select
the appropriate Provision User virtual provisioning group.

5. Click Create Group Mapping.

6. If you want the tool to check user accounts in nested subgroups in the Microsoft Active Directory group, in the Group
Mappings section, select the Nested check box. Note that the tool does not create groups or sub-groups on the
BlackBerry Enterprise Server.

7. Repeat steps 2 to 6 to create additional mappings.

8. Click Save.

After you finish:
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• If you want to disable a provisioning mapping temporarily, in the Group Mappings section, clear the appropriate
Enabled check box.

• To delete a mapping, in the Group Mappings section, click the appropriate Delete button.

• You can double-click the fields in the Group Mappings section to change the directory group path, the MDM domain
name, and the BlackBerry Enterprise Server group name. The tool does not validate the changes that you make, so
verify that the changes are accurate before you start the synchronization process.

• Map groups in Microsoft Active Directory to groups in an MDM domain.

• Preview the synchronization process. After you review the results of the preview and resolve any errors, you can start
the synchronization process.

Related information
Configure provisioning options, 15

Map groups in Microsoft Active Directory to
groups in an MDM domain
Before you begin:
• If necessary, create BlackBerry Enterprise Server groups that you want to synchronize with Microsoft Active Directory

groups.

• If necessary, add user accounts to the BlackBerry Enterprise Server. The tool can synchronize group membership only
if the user accounts in Microsoft Active Directory have matching user accounts on the BlackBerry Enterprise Server.
You can add the user accounts manually using the BlackBerry Administration Service, or you can enable the
provisioning feature so that the tool can add user accounts during the synchronization process.

1. On the computer that hosts the BlackBerry Directory Sync Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Directory Synch Tool client.

2. In the Directory Group Search section, perform one of the following actions:

• If you configured the directory group search to be manual, in the search field, type the name of a Microsoft Active
Directory group. Click the Search button.

• If you configured the directory group search to be automatic, in the filter field, type the name of a Microsoft Active
Directory group.

3. In the results list, select a group.

4. In the BlackBerry Group Search section, in the filter field, type the name of a BlackBerry Enterprise Server group.

5. In the results list, select a group.
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6. Click Create Group Mapping.

7. If a Microsoft Active Directory group contains nested groups that you want to synchronize, in the Group Mappings
section, select the Nested check box. Note that the tool does not create nested groups or sub-groups on the
BlackBerry Enterprise Server.

8. Repeat steps 2 to 7 to create additional mappings.

9. Click Save.

After you finish:
• If you want to prevent synchronization from occurring between a Microsoft Active Directory group and a BlackBerry

Enterprise Server group temporarily, in the Group Mappings section, clear the appropriate Enabled check box.

• To delete a mapping, in the Group Mappings section, click the appropriate Delete button.

• You can double-click the fields in the Group Mappings section to change the directory group path, the MDM domain
name, and the BlackBerry Enterprise Server group name. The tool does not validate the changes that you make, so
verify that the changes are accurate before you start the synchronization process.

• Preview the synchronization process. After you review the results of the preview and resolve any errors, you can start
the synchronization process.

Related information
Synchronization and provisioning rules, 19

Preview the synchronization process
Before you synchronize groups in Microsoft Active Directory with BlackBerry Enterprise Server groups, you can preview the
synchronization process to identify and resolve any potential issues.

Before you begin: Map groups in Microsoft Active Directory to groups in an MDM domain.

1. On the computer that hosts the BlackBerry Directory Sync Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Directory Synch Tool client.

2. Perform one of the following actions:

• If you want to remove all user accounts from a BlackBerry Enterprise Server group if the Microsoft Active Directory
group that it is mapped to does not exist in the directory, select the Force Synchronization check box.

• If you do not want to remove user accounts from a BlackBerry Enterprise Server group if the Microsoft Active
Directory group that it is mapped to does not exist in the directory, clear the Force Synchronization check box.
Details are written to the report and log file.

3. If you want to view the report after the preview completes, select the Show Report check box.

4. Click Preview.
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5. To review the report, click View > Report.

6. To review the log file, click File > Open Application Data Folder.

After you finish: After you resolve any issues, start the synchronization process.

Related information
Synchronization and provisioning rules, 19

Start the synchronization process
The amount of time that the BlackBerry Directory Sync Tool requires to complete the synchronization process varies
depending on the number of changes that the tool must complete. The amount of time that the tool requires to assign a
user account to a group or to remove a user account from a group is similar to the amount of time that it takes to perform
the same task using the BlackBerry Administration Service.

Note: It is a best practice to run the tool during low usage periods. Depending on the number of changes that must be
synchronized, the BlackBerry Directory Sync Tool might have a performance impact on your organization's environment.

Before you begin:
• If necessary, map groups in Microsoft Active Directory to virtual provisioning groups.

• Map groups in Microsoft Active Directory to groups in an MDM domain.

• Preview the synchronization process.

1. On the computer that hosts the BlackBerry Directory Sync Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Directory Synch Tool client.

2. Perform one of the following actions:

• If you want to remove all user accounts from a BlackBerry Enterprise Server group if the Microsoft Active Directory
group that it is mapped to does not exist in the directory, select the Force Synchronization check box.

• If you do not want to remove user accounts from a BlackBerry Enterprise Server group if the Microsoft Active
Directory group that it is mapped to does not exist in the directory, clear the Force Synchronization check box.
Details are written to the report and log file.

3. If you want to view the report after the preview completes, select the Show Report check box.

4. Click Execute.

5. To review the report, click View > Report.

6. To review the log file, click File > Open Application Data Folder.

After you finish:
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• If you enabled provisioning and the synchronization process added administrator accounts to the BlackBerry
Enterprise Server, use the BlackBerry Administration Service to assign administrative roles to the accounts.

• When the tool adds a device-enabled user account to the BlackBerry Enterprise Server, the BlackBerry Enterprise
Server does not send an activation email to users. You must send the activation information to users.

• You can use the Scheduled Tasks system tool in Windows, or any task scheduling application, to run the tool
automatically at a set interval. When you create the scheduled task to run the tool, specify the full path of the tool and
the -preview or -execute command. If the path includes spaces, enclose the path in quotation marks (for example, "C:
\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server Resource Kit\BlackBerry AMT Tools
\DirectorySync.exe" -execute). Configure the task to run using the same Windows account that you used to map
groups.

• If you change the membership of a BlackBerry Enterprise Server group using the BlackBerry Administration Service,
you must make the same changes to the Microsoft Active Directory group that is mapped to the BlackBerry Enterprise
Server group. If you do not make the same changes to the Microsoft Active Directory group, the changes that you made
might be reverted the next time you run the synchronization process.

Related information
Synchronization and provisioning rules, 19

Interpreting the reports that the BlackBerry
Directory Sync Tool creates
To view the reports that the tool creates, in the BlackBerry Directory Sync Tool, click View > Report. To view the log files
that the tool creates, click File > Open Application Data Folder.

Message Type Description

Assigning user [USER] found in directory
group to [GROUP NAME]

User [USER] successfully assigned to group
[GROUP NAME]

INFO The tool assigned a user account to a group.

Unassigning user [USER] not found in
directory group from [GROUP NAME]

User [USER] successfully unassigned from
group [GROUP NAME]

INFO The tool removed a user account from a group.

Creating user [USER] found in directory
group in [MDM DOMAIN]

INFO The tool added an administrator account that is not device-
enabled to the MDM domain.
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Message Type Description

User [USER] successfully created in [MDM
DOMAIN]

Creating device enabled user [USER] found
in directory group in [MDM DOMAIN]

User [USER] successfully created as device
enabled in [MDM DOMAIN]

INFO The tool added a device-enabled user account to the MDM
domain.

Deleting user [USER] not found in directory
group(s) from [MDM DOMAIN]

User [USER] successfully deleted from
[MDM DOMAIN]

INFO The tool deleted a user account from the MDM domain.

Maximum number of users [MAX NUM] has
been reached for BlackBerry group [MDM
DOMAIN NAME\GROUP NAME]

INFO The number of users in a group exceeded the maxiumum
size configured in the DirectorySync.exe.Config file
(maxNumberOfUsersInBasGroup). The tool does not
synchronize changes to groups that exceed this value. The
default value is 2000.

Verify that the size of the group does not exceed the
maximum size. If necessary, change the value of
maxNumberOfUsersInBasGroup.

User [USER] not found in [MDM DOMAIN
NAME]

WARNING The tool did not find the user account in the MDM domain.
Verify that the user account exists in the MDM domain.

If you want to hide "User not found" warning messages in
the report, in Edit > Preferences, select the "Suppress 'User
not found' warnings when assigning users to groups" check
box.

Multiple records found for user [USER] in
[MDM DOMAIN NAME]

WARNING The tool found multiple user records when searching for a
user account to assign to a group. The tool did not assign
the user account to the group.

User [USER] already exists as device
enabled

WARNING The tool tried to provision a user as an administrator
account that is not device-enabled, but the user already
exists in the MDM domain as a device-enabled user
account.

Delete the user account using the BlackBerry
Administration Service and try to add the user again as an
administrator account.
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Message Type Description

User [USER] already exists but is not device
enabled

WARNING The tool tried to provision a user as a device-enabled user
account, but the user already exists in the MDM domain as
an administrator account that is not device-enabled.

Delete the user account using the BlackBerry
Administration Service and try to add the user again as a
device-enabled user account.

Skipping all provisioning mappings for
[MDM DOMAIN NAME]. Provisioning option
is disabled.

WARNING Provisioning mappings were configured but the provisioning
feature was disabled.

If you want to provision user accounts, enable the
provisioning feature.

Skipping unidentifiable user [USER] WARNING The tool could not identify the user account in the MDM
domain as a Microsoft Active Directory user. The tool does
not manage user accounts that are not integrated with
Microsoft Active Directory.

Directory group [LDAP PATH] cannot be
found. Treating the missing group as empty.

WARNING The tool could not find a group in Microsoft Active Directory
and the Force Synchronization option was selected.

Verify that the group exists in Microsoft Active Directory.

Another copy of Directory Sync is already
running. Multiple instances cannot be run!

ERROR The tool did not run because another instance of the tool is
already running. You cannot run multiple instances of the
tool at the same time.

Failed to retrieve group members from
[MDM DOMAIN NAME\GROUP NAME]

ERROR The tool did not find a group in the MDM domain, or an error
occured when the tool tried to find the group.

Failed to retrieve all users from BlackBerry
domain [MDM DOMAIN NAME]

ERROR An error occurred when the tool tried to retrieve the list of all
users from the MDM domain.

Failed to get user details for
DisplayName=[DISPLAY NAME],
UID=[USER UID]

ERROR An error occurred when the tool tried to retrieve more
details for a user.

Failed to find user [USER] ERROR An error occurred when the tool searched for the user
account to assign to a group.

Failed to assign user [USER] to group [MDM
DOMAIN NAME\GROUP NAME]

ERROR An error occurred when the tool tried to assign the user
account to a group.

Failed to unassign user [USER] from group
[MDM DOMAIN NAME\GROUP NAME]

ERROR An error occurred when the tool tried to remove the user
account from a group.
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Message Type Description

Failed to create user [USER] in BlackBerry
domain [MDM DOMAIN NAME]

ERROR An error occurred when the tool tried to provision the user
account.

Failed to delete user [USER] from
BlackBerry domain [MDM DOMAIN NAME]

ERROR An error occurred when the tool tried to delete the user
account.

Failed to authenticate to any BlackBerry
domains

ERROR The administrator account that you configured the tool to
use is not authorized in any of the configured MDM
domains. Verify that the administrator account exists in and
has the required role or permissions in each MDM domain.

Failed to initialize BlackBerry domain [MDM
DOMAIN NAME]

ERROR An error occurred when the tool tried to set up an MDM
domain.

Failed to get directory group members ERROR An error occurred when the tool tried to retrieve group
members from Microsoft Active Directory.

Too many changes detected for [MDM
DOMAIN NAME or GROUP NAME].
Total=[NUM OF CHANGES], Max=[MAX
NUM OF CHANGES]

ERROR The number of changes to synchronize to a group exceeded
the maxiumum number configured in the
DirectorySync.exe.Config file (MaxNumberOfChanges). The
tool counts the number of changes; if the number exceeds
the value that you specified, the tool does not make any
changes to the group. The default value is 0 (no limit).

If necessary, change the value of MaxNumberOfChanges.

The server is not operational ERROR The tool cannot access the domain that hosts Microsoft
Active Directory.

Logon failure: unknown user name or bad
password

ERROR The tool cannot connect to an MDM domain using the login
information that you specified. Verify that the login
information is correct and verify that the administrator
account exists in the MDM domain.

Exception retrieving group member [AD
PATH]

ERROR The tool cannot find a user account in Microsoft Active
Directory. Verify that the Windows account that you are
using to run the tool has access to the Microsoft Active
Directory domain and has read permissions for Microsoft
Active Directory.

Related information
Configure reporting preferences, 15
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Troubleshooting

No Directory groups to display. Please check the
configuration
Description
This message appears when the BlackBerry Directory Sync Tool cannot connect to Microsoft Active Directory using the
information that you specified.

Possible solution
Perform any of the following actions:

• Verify that the directory settings that you specified are correct.

• Verify that the Search Path DN that you specified is a valid path. From left to right, the path should specify the general
organizational units (OU) to the specific domain components (DC) (for example, OU=Groups,DC=sample,DC=net).

• If you selected Automatic in the Server Discovery drop-down list, verify that the Windows account that you are currently
using has read permissions for Microsoft Active Directory.

No BlackBerry groups to display. Please check the
configuration
Description
This message appears when the BlackBerry Directory Sync Tool cannot connect to an MDM domain using the information
that you specified.

Possible solution
Perform any of the following actions:

• Verify that the login information that you specified for the administrator account is correct.

• Verify that the administrator account has permissions to view and edit groups.

• Verify that the information that you specified for an MDM domain is correct.
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• Verify that groups exist in the MDM domain.

• Verify that the BlackBerry Administration Service that you are trying to connect to is running.

• Verify that the administrator account exists in each MDM domain that you want the tool to connect to.

Exception retrieving BlackBerry groups
Description
This message appears if the Microsoft .NET Framework 3.5 (full package) is not installed on the computer that hosts the
BlackBerry Directory Sync Tool.

Possible solution
Install the Microsoft .NET Framework 3.5 (full package) on the computer that hosts the BlackBerry Directory Sync Tool.

Invalid URI: The hostname could not be parsed
Description
This message appears if the tool cannot process the hostname that you specified for an MDM domain.

Possible solution
In the Hostname field, verify that you typed the correct full path name of the computer that hosts the BlackBerry Enterprise
Server (for example, UDS-HOST1.company.com). Do not include http:// or https://.
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BlackBerry Application
Reporting Tool
The BlackBerry Application Reporting Tool is a command-line tool that you can use to list the applications that are installed
on BlackBerry devices in an MDM domain. You can use this tool to audit the MDM domain and evaluate the applications
that are installed on devices.

The tool creates an output file that is named HHAppReport_<yyyymmdd>_<hhmm>.csv, where <yyyymmdd> is the year,
month, and day, and <hhmm> is the hour and minute that the tool created the file.

Run the BlackBerry Application Reporting
Tool
1. On the computer that hosts the BlackBerry Application Reporting Tool, on the taskbar, click Start > All Programs >

BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Application Reporting Tool.

2. In the command prompt window, type HHAppReport and the following parameters:

Parameter Description

-db <database_name> This parameter specifies the name of the BlackBerry Configuration
Database.

-n <database_server> This parameter specifies the host name, computer name, or IP address of
the server that hosts the BlackBerry Configuration Database.

By default, the tool uses the name localhost.

3. Type any of the following optional parameters:

Parameter Description

-dbauth This parameter specifies that the tool must use Microsoft SQL Server
authentication. By default, the tool uses Windows authentication.

3
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Parameter Description

If you specify this parameter, you must also specify the -dbuser
<user_name> and -dbpass <password> parameters.

-dbuser <user_name> This parameter specifies the username that the tool uses for database
authentication. If you use this parameter, you must also specify the -
db_auth and dbpass <password> parameters.

-dbpass <password> This parameter specifies the password that the tool uses for database
authentication. If you use this parameter, you must also specify the -
db_auth and dbuser <user_name> parameters.

-o <file_name> This parameter specifies the name of the output file that the tool creates.

Example: Running the tool to find all applications in an MDM domain

HHAppReport -db BESMgmt -n server01

Example: Running the tool using Microsoft SQL Server authentication

HHAppReport -db BESMgmt -n server01 -dbauth -dbuser admin -dbpass password

Example: Running the tool and specifying an output file name

HHAppReport -db BESMgmt -n server01 -o myApplicationsReport20120418.csv

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type HHAppReport -? or HHAppReport -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Example: Output file for the BlackBerry
Application Reporting Tool

Application Title,Application Version
BussinessToday, 1.0.0.126
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FCEUXpb, 1.0.0.16
Score Mobile, 1.2.0.305
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BlackBerry IT Policy Import and
Export Tool
The BlackBerry IT Policy Import and Export Tool is a command-line tool that you can use to export IT policy information
from a BlackBerry Configuration Database to a backup file. You can use the backup file to import the information to a
different BlackBerry Configuration Database to make the IT policies available to a different MDM domain.

The tool supports exporting and importing IT policy information between any 5.0.x or later versions of the BlackBerry
Enterprise Server, or between 5.0.x versions of the BlackBerry Enterprise Server Express. The tool does not support
exporting from or importing to versions earlier than 5.0.

The source and destination BlackBerry Configuration Database must be associated with the same type of product. For
example, you cannot export IT policy information from the BlackBerry Configuration Database of a BlackBerry Enterprise
Server and import the IT policy information to the BlackBerry Configuration Database of a BlackBerry Enterprise Server
Express; each product supports a different set of IT policy rules.

The tool does not support importing IT policy information to a version of the BlackBerry Enterprise Server or BlackBerry
Enterprise Server Express that is earlier than the version you exported the IT policy information from.

The tool does not support exporting and importing IT policy information between different platforms of the BlackBerry
Enterprise Server. For example, you cannot export IT policy information from the BlackBerry Enterprise Server for Microsoft
Exchange and import the IT policy information to the BlackBerry Enterprise Server for IBM Lotus Domino.

Run the BlackBerry IT Policy Import and
Export Tool
Before you begin: Verify that the BlackBerry IT Policy Import and Export Tool can connect to the BlackBerry Configuration
Database.

1. On the computer that hosts the BlackBerry IT Policy Import and Export Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry IT Policy Import and Export Tool.

2. In the command prompt window, type ITPolicyImportExport -export or ITPolicyImportExport -import and the
following parameters:

4
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Parameter Description

-n <database_server> This parameter specifies the host name, computer name, or IP address of
the server that hosts the BlackBerry Configuration Database that you want to
export IT policies from or import IT policies into.

-db <database_name> This parameter specifies the name of the BlackBerry Configuration
Database that you want to export IT policies from or import IT policies into.

-file <file_name> This parameter specifies the name of the backup file that the tool creates, or
the name of the backup file that you want to use to import IT policy
information to a BlackBerry Configuration Database. By default, the tool
prompts you for this information.

3. Type any of the following parameters:

Parameter Description

-itpolicy <IT_policy_name> This parameter specifies the single IT policy that you want to export or
import. Type the IT policy name in quotation marks ("") if the name contains
a space or special characters.

-selectall This parameter exports or imports all available IT policies.

-renamed_itpolicy
<new_IT_policy_name>

This parameter changes the name of the IT policy that you specify using the
-itpolicy parameter during the export process or import process. Type the IT
policy name in quotation marks if the name contains a space or special
characters.

-dbauth This parameter specifies that the tool must use Microsoft SQL Server
authentication. By default, the tool uses Windows authentication.

If you specify this parameter, you must also specify the -dbuser
<user_name> and -dbpass <password> parameters.

Example: Exporting all IT policies using Windows authentication

ITPolicyImportExport -export -n server01 -db BESMgmt01 -selectall -file itpolicy.txt

Example: Importing all IT policies using Windows authentication

ITPolicyImportExport -import -n server02 -db BESMgmt02 -selectall -file itpolicy.txt

Example: Exporting all IT policies using Microsoft SQL Server authentication

ITPolicyImportExport -export -n server01 -db BESMgmt01 -dbauth -dbuser admin -dbpassword
password -selectall -file itpolicy.txt
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Example: Importing all IT policies using Microsoft SQL Server authentication

ITPolicyImportExport -import -n server02 -db BESMgmt02 -dbauth -dbuser admin -dbpassword
password -selectall -file itpolicy.txt

Example: Exporting a single IT policy using Windows authentication

ITPolicyImportExport -export -n server01 -db BESMgmt01 -itpolicy "executive IT policy" -file itpolicy.txt

Example: Importing a single IT policy using Windows authentication

ITPolicyImportExport -import -n server02 -db BESMgmt02 -itpolicy "executive IT policy" -file itpolicy.txt

Example: Exporting and renaming a single IT policy

ITPolicyImportExport -export -n server01 -db BESMgmt01 -itpolicy "executive IT policy" -
renamed_itpolicy "executive permission" -file itpolicy.txt

View the IT policies that are available on a
BlackBerry Enterprise Server or in a text file
You can use the BlackBerry IT Policy Import and Export Tool to view the IT policies that are available on a BlackBerry
Enterprise Server or in a .txt file. When you use the -list subparameter, the IT policies are not imported or exported.

Before you begin: Verify that the BlackBerry IT Policy Import and Export Tool can connect to the BlackBerry Configuration
Database.

1. On the computer that hosts the BlackBerry IT Policy Import and Export Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry IT Policy Import and Export Tool.

2. In the command prompt window, type ITPolicyImportExport -export or ITPolicyImportExport -import and the
following parameters:

Parameter Description

-n <database_server> This parameter specifies the host name, computer name, or IP address of
the server that hosts the BlackBerry Configuration Database.

-db <database_name> This parameter specifies the name of the BlackBerry Configuration
Database.

-list This parameter lists the IT policies that are available in a BlackBerry
Configuration Database or in a .txt file that you specify.
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Parameter Description

-file <file_name> This parameter specifies the name of the backup .txt file that contains IT
policy information. By default, the tool prompts you for this information.

Example: Viewing the IT policies that are available in a BlackBerry Configuration Database

ITPolicyImportExport -export -n server01 -db BESMgmt01 -list

Example: Viewing the IT policies that are available in an exported file

ITPolicyImportExport -import -n server01 -db BESMgmt01 -file itpolicy.txt -list

Parameters for the BlackBerry IT Policy
Import and Export Tool
The parameters that are listed in brackets are optional.

Parameter Description

-db <database_name> This parameter specifies the name of the BlackBerry Configuration Database
that you want to export IT policies from or import IT policies into.

[-dbauth] This parameter specifies that you want to use database authentication. By
default, the tool uses Windows authentication.

If you specify this parameter, you must also specify the -dbuser <user_name>
and -dbpass <password> parameters.

[-dbpass <password>] This parameter specifies the password for database authentication. If you use
this parameter, you must also specify the -db_auth and dbuser <user_name>
parameters.

[-dbuser <user_name>] This parameter specifies the user name for database authentication. If you use
this parameter, you must also specify the -db_auth and dbpass <password>
parameters.

-export This parameter specifies that you want to export IT policies.

-file <file_name> This parameter specifies the name of the backup file that the tool creates, or the
name of the backup file that you want to use to import IT policy information to a
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Parameter Description

BlackBerry Configuration Database. By default, the tool prompts you for this
information.

-import This parameter specifies that you want to import IT policies.

[-itpolicy <IT_policy_name>] This parameter specifies the single IT policy that you want to export or import.
Type the IT policy name in quotation marks ("") if the name contains a space or
special characters.

[-list] This parameter lists the IT policies that are available in a BlackBerry
Configuration Database or in a .txt file that you specify.

-n <database_server> This parameter specifies the host name, computer name, or IP address of the
server that hosts the BlackBerry Configuration Database that you want to export
IT policies from or import IT policies into.

[-renameditpolicy
<new_IT_policy_name>]

This parameter changes the name of the IT policy that you specify using the -
itpolicy parameter during the export process or import process. Type the IT
policy name in quotation marks if the name contains a space or special
characters.

If you use this parameter when you export an IT policy, the tool changes the
name of the IT policy when it exports the IT policy from the BlackBerry
Configuration Database to the backup file. The tool does not change the name of
the IT policy in the source BlackBerry Configuration Database. If you use the
parameter when you import an IT policy, the tool changes the name of the IT
policy when it imports the IT policy from the backup file to the destination
BlackBerry Configuration Database.

[-selectall] This parameter exports or imports all available IT policies.

[-?] or [-h] Each of these parameters provides more information about the tool. No other
parameters are required when you use one of these parameters.
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BlackBerry Message Receipt
Confirmation Tool
The BlackBerry Message Receipt Confirmation Tool is an application that you can use to verify that the BlackBerry
Enterprise Server is successfully delivering messages to devices. At an interval that you specify, the tool sends a message
to the specified user accounts, monitors the status of the message, and confirms that the devices received the message.
The tool runs as a Windows service.

Each time the tool starts, it clears the existing message delivery status values. The tool obtains the list of user accounts to
monitor and sends a message to the devices that are associated with the user accounts. The tool assigns a serial number to
each message and then increases the serial number by one each time it resends the message. When the tool reaches the
interval value that is specified in the Last Message Delivery Check field, it checks whether the messages were successfully
delivered and updates the Last Message Sent field, the Serial Number field, and the Deliveries list.

If the tool reaches the value that is specified in the Delivery Timeout Interval field, a timeout status message for the user
account displays in the Deliveries list, and the tool sends a delivery timeout notification message to the defined SMTP email
account to indicate that the message was not delivered.

To confirm the message delivery, the tool uses the following options in the message subject line:

<$Confirm,RemoveOnDelivery,SuppressSaveInSentItems>

Configure monitoring and notification
settings for the BlackBerry Message
Receipt Confirmation Tool
1. On the computer that hosts the BlackBerry Message Receipt Confirmation Tool, on the taskbar, click Start > All

Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Message Receipt Confirmation Tool client.

2. Click Configuration.

3. Perform the following tasks:

5
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Task Steps

Specify the subject of the message that the
tool sends to the BlackBerry device.

In the Subject of Message Send field, type a subject.

Specify how frequently the tool sends
messages.

In the Message Send Interval field, type a value using the following
format: hours:minutes (for example, 1:30 or 0:30).

Specify how frequently the tool checks the
administrator’s mailbox for a delivery
confirmation message.

In the Delivery Check Interval field, type a value, in minutes.

Specify how long the tool continues to check
for delivery confirmation messages before it
notifies you that the attempt to deliver the
message has timed out.

In the Delivery Timeout Interval field, type a value, in minutes.

Specify the email account that receives the
delivery timeout notification message from
the service.

In the Send Notifications To field, type an SMTP email address.

Specify the subject of the delivery timeout
notification message that the service sends
to the specified email account.

In the Subject of Notifications field, type a subject.

Specify the user accounts that you want to
monitor.

You can monitor up to five devices on different BlackBerry
Enterprise Server instances that use the same BlackBerry
Configuration Database.

1. In the BlackBerry Enterprise Servers list, click a BlackBerry
Enterprise Server.

2. Click each user account that you want to monitor.

3. Click Monitor.

4. Click OK.

Run the BlackBerry Message Receipt
Confirmation Tool
1. On the computer that hosts the BlackBerry Message Receipt Confirmation Tool, on the taskbar, click Start > All

Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Message Receipt Confirmation Tool client.
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2. In the BlackBerry Message Receipt Confirmation Tool window, verify that the messages were delivered, and verify
the delivery times.

Change where the log file is stored
When you start the BlackBerry Message Receipt Confirmation Tool for the first time, the tool creates a string value in the
Registry named DebugLogFile at HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry Message Receipt
Confirmation Tool\Configuration. This string value specifies the file path where the tool stores daily log files (this value is
blank until you run the tool for the first time).

If you chose to use a UAC-compliant file path when you installed the tool, by default, the tool stores log files in the
application data folder for the current user (for example, <drive>:\Documents and Settings\<user_name>\Application Data
\Research In Motion\AMT\). If you chose not to use a UAC-compliant file path, the tool stores log files to a file path that is
relative to the current working directory (for example, <drive>:\Program Files\Research In Motion\BlackBerry Enterprise
Server Resource Kit\BlackBerry AMT Tools). You can change the value of DebugLogFile if you want the tool to store log files
at a different location.

1. On the computer that hosts the BlackBerry Message Receipt Confirmation Tool, on the taskbar, click Start > Run.

2. Type regedit. Click OK.

3. In the left pane, navigate to HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry Message Receipt
Confirmation Tool\Configuration.

4. Right-click the DebugLogFile string value and click Modify.

5. In the Value Data field, type the full file path of the location where you want to store daily log files, including the file
name to use for the log files (for example, C:\Logs\MRCLog.txt).

6. Click OK.

Messages from the BlackBerry Message
Receipt Confirmation Tool
Type of message Example

Message sent to the BlackBerry device To: <user_account>

Subject: <$Confirm,RemoveOnDelivery,SuppressSaveInSentItems>
<subject_of_message_send>
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Type of message Example

Delivery timeout notification message
sent to the specified SMTP email
account

To: <send _notifications_to>

Subject: <subject_of_notifications>

Body: Could not confirm delivery to <user_account>

Status fields of a BlackBerry Message
Receipt Confirmation Tool output
Field Description

Service Start This field specifies the date and time that the BlackBerry Message Receipt
Confirmation Tool started running.

Last Message Send This field specifies the time of the last attempt to send a message to BlackBerry
devices.

Serial Number This field specifies the unique number that is assigned automatically to each
message that the tool sends.

Last Message Delivery Check This field specifies the last time that the tool checked for a successful delivery
notification message.

Deliveries This field specifies the list of user accounts and the status of the message
delivery to devices.

Example: Successful Status/Deliveries display sequences

<user_account> / Message Send Successful

<user_account> / Delivery Confirmed

or

<user_account> / Message Send Successful

<user_account> / Delivery Unconfirmed

<user_account> / Delivery Confirmed

Example: Unsuccessful Status/Deliveries display sequence - tool sends a
delivery failure notification message

<user_account> / Message Send Successful
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Field Description

<user_account> / Delivery Unconfirmed

<user_account> / Delivery Timeout

Example: Unsuccessful Status/Deliveries display - tool does not send a
delivery failure notification message

<user_account> / Message Send Error

The Message Send Error message indicates that the tool could not send a
message to the user account.

Stop monitoring message delivery to user
accounts
1. On the computer that hosts the BlackBerry Message Receipt Confirmation Tool, on the taskbar, click Start > All

Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Message Receipt Confirmation Tool client.

2. Click Configuration.

3. In the BlackBerry Enterprise Servers list, click a BlackBerry Enterprise Server.

4. Click the user accounts that you want to stop monitoring.

5. Click Remove.

6. Click OK.
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BlackBerry System Log
Monitoring and Reporting Tool
You can use the BlackBerry System Log Monitoring and Reporting Tool to monitor the BlackBerry Enterprise Server log files
for events generated by the BlackBerry Dispatcher and the BlackBerry Messaging Agent. You can specify which
components to monitor, the events that you want to track, and the types of notifications and reports that you want the tool
to send to administrators.

The tool runs as a Windows service.

Output files generated by the BlackBerry
System Log Monitoring and Reporting Tool
File name Location Description

bessyslog<yyyymmdd>.txt Logs folder The BlackBerry System Log Monitoring and
Reporting Tool service creates the Logs folder.

msgs_<host_name><yyyymmdd>.txt Folder that contains the
BESSysLog.exe file

The log file contains detailed information about all of
the messages that the BlackBerry Enterprise Server
processes.

The tool writes information to the file every 10
minutes. You cannot change this interval.

rescan_<host_name><yyyymmdd>.txt Folder that contains the
BESSysLog.exe file

The log file contains a summary of scan averages for
the past hour plus detailed information about any
scan that takes longer than 5 seconds. The tool
prints rescan information every hour.

bessyslogerror<yyyymmdd>.txt Folder that contains the
BESSysLog.exe file

The tool uses this log file to generate nightly reports.

bessyslogdebug<yyyymmdd>.txt Folder that contains the
BESSysLog.exe file

The tool uses this log file to generate nightly reports.

6
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Configuring the BlackBerry System Log
Monitoring and Reporting Tool

Specify the port numbers that the BlackBerry System
Log Monitoring and Reporting Tool monitors
The BlackBerry System Log Monitoring and Reporting Tool service receives messages on a socket. You must configure the
SysLogLevel and SysLogHost registry keys for the BlackBerry Enterprise Server to enable the BlackBerry Enterprise Server
services to write to this socket.

1. In the Registry Editor, browse to HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise
Server\Logging Info .

2. For each BlackBerry Enterprise Server service that you want to monitor, change the SysLogLevel and SysLogHost
registry keys for that service.

Key Steps

SysLogLevel 1. If the SysLogLevel registry key does not exist, create a DWORD value
named SysLogLevel.

2. Double-click the SysLogLevel registry key.

3. In the Value data field, type 3.

4. Click OK.

SysLogHost 1. Double-click the existing SysLogHost registry key. If the key does not
exist, create a String Value named SysLogHost. Double-click the key and
type the local host and port number of the computer that hosts the
BlackBerry Enterprise Server service, using the following format:
<localhost>:<port_number>. For example, localhost:4070.

2. In the Value data field, type the host name or IP address and port
number (514) of the computer where the BlackBerry System Log
Monitoring and Reporting Tool service runs, using one of the following
formats:

• <ip_address>:514

• <hostname>:514
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Key Steps

• <localhost>:4071,<localhost>:4070,<xx.xx.xx.xx>:514

3. Click OK.

Do not remove the original registry key information from the SysLogHost
registry key. Add the entries to the existing key, separating them using a
comma. Do not use space characters in the Value data field.

After you finish: Restart the BlackBerry Enterprise Server services that you changed.

Configure the SMTP settings for the account that sends
notification messages
1. On the computer that hosts the BlackBerry System Log Monitoring and Reporting Tool, on the taskbar, click Start >

All Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry System Log Monitoring and Reporting Tool client.

2. In the SMTP Host Name field, type the full computer name of the outgoing messaging server that delivers the
notification messages and nightly reports.

3. In the "From" Email Address field, type the SMTP email address of the SMTP account that sends notification
messages.

4. In the SMTP Account Name field, type the name of the SMTP account that sends notification messages.

5. Click OK.

Configure a user account to receive notification
messages
1. On the computer that hosts the BlackBerry System Log Monitoring and Reporting Tool, on the taskbar, click Start >

All Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry System Log Monitoring and Reporting Tool client.

2. In the Users section, click Add.

3. Type the information for the user account.

4. Specify whether the user account receives nightly reports.

5. Click Alerts.
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6. Select the check boxes for the alerts that you want to exclude from the notification messages that the user account
receives.

7. To add a custom alert, perform the following actions:

a. Click Add.

b. Type the Event ID and Description.

c. Click OK.

8. Click OK.

9. To specify the BlackBerry Enterprise Server instance that the user account receives notification messages for,
perform the following actions:

a. Click Servers.

b. Click Add.

c. Type the server name and a description.

d. Click OK.

Related information
Change the frequency of notification messages, 52
Remove a user account from the list of recipients of notification messages, 50
Notification messages, 53

Change filters and customized subject lines for a user
account
1. On the computer that hosts the BlackBerry System Log Monitoring and Reporting Tool, on the taskbar, click Start >

All Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry System Log Monitoring and Reporting Tool client.

2. In the Users list, click the user account.

3. Click Edit.

4. Perform any of the following tasks:

Task Steps

Create a customized subject line for
a notification message for the user
account.

1. Click Alerts.

2. Click Add.

3. Type a BlackBerry Enterprise Server service event ID and customized
description.
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Task Steps

Only event IDs that correspond to actual BlackBerry Enterprise Server
service event IDs trigger a notification message.

4. Click OK.

5. Select a range of events to exclude from the notification messages.

Delete a customized subject line for a
notification message for the user
account.

1. Click Alerts.

2. In the My Custom Alerts list, click a notification message.

3. Click Delete.

Create a filter to prevent a specific
BlackBerry Enterprise Server from
sending a specific event to the user
account.

1. Click Alerts.

2. Click Add.

3. Type -< event ID >.

Delete a filter that prevents the user
account from receiving notification
messages about a specific event.

1. Click Alerts.

2. In the list of notification messages, click a notification message.

3. Click Delete.

Create a filter to prevent a specific
BlackBerry Enterprise Server from
sending notification messages to the
user account.

1. Click Servers.

2. Click Add.

3. Type the BlackBerry Enterprise Server information as it appears in the
List of known BlackBerry Servers (default servers) list.

4. In the Description field, type remove.

Delete a filter that prevents a specific
BlackBerry Enterprise Server from
sending notification messages to the
user account.

1. Click Servers.

2. Click a BlackBerry Enterprise Server.

3. Click Delete.

5. Click OK.

Remove a user account from the list of recipients of
notification messages
1. On the computer that hosts the BlackBerry System Log Monitoring and Reporting Tool, on the taskbar, click Start >

All Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry System Log Monitoring and Reporting
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Tool > BlackBerry Analysis Monitoring and Reporting Tools > BlackBerry System Log Monitoring and Reporting
Tool client.

2. In the Users section, click the name of the user account that you want to remove from the list of recipients.

3. Click Remove.

4. Click Yes.

Change how the BlackBerry System Log Monitoring
and Reporting Tool starts
The BlackBerry System Log Monitoring and Reporting Tool runs as a Windows service. During the installation process, you
configure whether the startup type for the tool is automatic or manual.

After installation, you can change the startup type in the Windows Services.

1. On the computer that hosts the BlackBerry System Log Monitoring and Reporting Tool, in the Windows Services,
right-click BlackBerry Syslog. Click Properties.

2. On the General tab, in the Startup type list, click the required startup option.

3. In the Service status section, click Start.

Changing the frequency of notification messages
By default, the BlackBerry System Log Monitoring and Reporting Tool limits the number of notification messages that it
sends to user accounts in a specific period of time. You can adjust this functionality in the Windows registry using the
BlackBerry Syslog Server registry key.

The tool creates the following DWORD values after you run the tool for the first time:

• OneMinuteThreshold: default value is 5 notification messages

• FiveMinuteThreshold: default value is 10 notification messages

• FifteenMinuteThreshold: default value is 15 notification messages

• SixtyMinuteThreshold: default value is 30 notification messages

If the OneMinuteThreshold value is set to 2, the first notification message that the tool sends contains the notification
content. For example:

<7>Mar 03 15:10:23 brktest3 BlackBerry Dispatcher BES50_JI {0x18C8} 0243: (#50105) Dispatcher Database
connection dropped

The next notification message in the same minute contains the notification content and a message that the tool has
reached the threshold value. For example:
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<7>Mar 03 15:11:13 brktest3 BlackBerry Dispatcher BES50_JI {0x1B18} 0279: (#50108) Dispatcher Database
connection dropped

NOTE: The threshold for email alerts has been reached, subsequent alerts will be throttled.

The subsequent notification messages in the same minute are throttled, and the user account does not receive additional
notification messages until the threshold is reset (for example, after one minute or after the configured interval). The first
notification message that the tool sends after this period contains the notification content and a count of the number of
throttled messages. For example:

<7>Mar 03 15:11:12 brktest3 BlackBerry Dispatcher BES50_JI {0x1B18} 0232: (#50105) Dispatcher Database
connection dropped

NOTE: 4 alert(s) have been throttled since your last email alert.

Change the frequency of notification messages
Before you begin: The BlackBerry System Log Monitoring and Reporting Tool creates the values for the BlackBerry Syslog
Server registry key after you start the tool for the first time. If the registry keys do not display, in the Windows Services, stop
and restart the BlackBerry Syslog service.

1. On the computer that hosts the BlackBerry System Log Monitoring and Reporting Tool, click Start > Run.

2. Type regedit.

3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Syslog Server.

4. Right-click any of the following DWORD values that you want to change:

• OneMinuteThreshold

• FiveMinuteThreshold

• FifteenMinuteThreshold

• SixtyMinuteThreshold

5. Click Modify.

6. In the Value data field, type the new threshold value for notification messages.

Parameters for running the BlackBerry System Log
Monitoring and Reporting Tool from the command
prompt
The parameters listed in brackets are optional.
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Parameter Description

[-debug]

[-console]

These parameters specify that the BlackBerry System Log Monitoring and
Reporting Tool runs in the command prompt window.

[-b <Broadcast_Port>] This parameter specifies the port number that the BlackBerry System Log
Monitoring and Reporting Tool monitors for events from the BlackBerry
Enterprise Server component. You specify the port number during the
installation process for the tool. By default, the port number is 514.

Notification messages
The BlackBerry System Log Monitoring and Reporting Tool sends a notification message to all specified user accounts
when an event matches a configured alert and triggers the message.

A notification message contains the following information:

Item Description

Subject • Event ID number

• Host name of the BlackBerry Enterprise Server instance that triggered the alert

• Description of the event

Body Log entry from the BlackBerry Dispatcher instance or BlackBerry Messaging Agent
instance

Example: Notification message that the tool sends to a user account

To: jpalmer@test.rim.net

Subject: 50001 - SERVER1 - Starting BlackBerry Server...

Body: <7>Nov 11 10:54:30 SERVER1 BlackBerry messaging agent SERVER1 {0x10F4} 0000: (#50001)
Starting BlackBerry Server...

Nightly reports
The BlackBerry System Log Monitoring and Reporting Tool sends a nightly report that summarizes the messages that the
tool received from the BlackBerry Enterprise Server components that it monitored.

A nightly report contains the following information:
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Item Description

Host name Host name of the BlackBerry Enterprise Server component that triggered each
message

Service The BlackBerry Messaging Agent or BlackBerry Dispatcher

Event The event ID number

Occ. The number of occurrences of the event

Description The description of the event

Example: Nightly report that the tool sends to a user account

Messages Logged at Error, Warning and Other:
Host Name: SERVER1
Service: BlackBerry Dispatcher CN=SERVER1/OU=SERVERS/O=TEST
Event  Occ.  Description
-----  ----- --------------------
10000      1 CRITICAL ERROR in the BlackBerry Dispatcher
50000      1
50075      1 Starting BlackBerry Dispatcher %s - version %s
Service: BlackBerry Messaging Agent SERVER1
Event  Occ.  Description
-----  ----- --------------------
10398      1 Unable to open mail database for user %s (server=%s) (db=
%s)
20000      1
20089      1 Unable to open %s DB for %s
50001      2 Starting BlackBerry Server ...
50002      1 Shutting down BlackBerry ServerMessages
Messages Logged at Information, Debug and Trace Level:
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BlackBerry Enterprise Server
Log Monitoring Tool
You can use the BlackBerry Enterprise Server Log Monitoring Tool (LogMonitor.exe) to monitor the log files for a BlackBerry
Enterprise Server component for specific events or text strings, and to perform an action when the tool finds the events or
text strings. You can use the tool to monitor a specific log file, or to continuously monitor the log files that a component
creates each day.

For example, you can configure the tool to monitor the BlackBerry Dispatcher (DISP) log files for event ID 50108. In the
component log files, event IDs are enclosed in brackets ( [ ] ) at the beginning of log entries, using the following format:
"[50108] (08/18 15:56:55.723):{0xDB0} Dispatcher Database connection dropped". When the tool finds the event ID or
text string, it performs the specified action. For example, you can configure the tool to run a custom batch file to restart the
BlackBerry Dispatcher.

You can configure the tool to monitor the log files for one component at a time.

Specifying values and actions for the
BlackBerry Enterprise Server Log
Monitoring Tool
You can use the command prompt or an input text file to specify the events or text strings that you want the BlackBerry
Enterprise Server Log Monitoring Tool to find in log files, and the actions that you want the tool to perform when it finds the
events or text strings.

Specifying values and actions from the command
prompt
Using specific commands, you can specify a list of event IDs or text strings that you want the BlackBerry Enterprise Server
Log Monitoring Tool to find in a log file, and you can specify the actions that you want the tool to perform when it finds the
values.

7
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You run the tool using a series of parameters and corresponding values from the command prompt. You use the -events
parameter to specify event IDs or text strings, and the -action parameter to specify the action that you want the tool to
perform when it finds the event IDs or text strings. An event ID is a five-digit number or six-digit number. You can specify
multiple event IDs using a comma-separated ( , ) list. The tool treats each event individually with an assigned action for
each event.

Specifying values and actions in an input file
You can create an input text file to specify the event IDs or text strings that you want the BlackBerry Enterprise Server Log
Monitoring Tool to find in a log file, and the actions that you want the tool to perform when it finds the specified values. You
use the -input parameter to specify the input file when you run the tool from the command prompt.

The input file uses the following format:

action=<action>
<eventID>
<string>

You first specify the action that you want the tool to perform (for example, run a batch file), and then specify a list of the
event IDs or text strings that you want the tool to find. When the tool finds one of the specified event IDs or text strings, it
performs the action. When the tool finds an action line, the tool identifies it as the current action to perform when it finds
the event IDs or text strings that follow it. You can add multiple actions and associated event IDs and text strings to the
input file.

You specify actions in the input file using the following format: action=<action>. For example, if the action is to run a batch
file, you specify the name of the .bat file as the action: action=example.bat. You can specify any standard actions that the
Windows command prompt supports.

You specify event IDs or text strings as text values or regular expressions. The tool treats input lines that contain exactly five
digits or six digits as event IDs and searches for the event IDs. If you want the tool to monitor multiple event IDs, you must
use a comma-separated ( , ) list. The tool treats text strings as regular expressions that are not case-sensitive.

Example: Creating an input file that instructs the BlackBerry Enterprise
Server Log Monitoring Tool to restart the BlackBerry Dispatcher
The BlackBerry Enterprise Server administrator creates a batch file named restart.bat that contains the following
command:

net start "BlackBerry Dispatcher"

The administrator creates an input file named restart.txt with the following contents:

action=restart.bat
50099

The administrator runs the BlackBerry Enterprise Server Log Monitoring Tool using the following parameters:

LogMonitor.exe -L "C:\Program Files (x86)\Research In Motion\BlackBerry Device Service\Logs" -type DISP -input
restart.txt
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The tool monitors the BlackBerry Dispatcher log file and identifies the following log entry: [50099] (08/18
15:56:55.770):{0xDB0} BlackBerry Dispatcher Shutdown complete. Since the log entry includes the
event ID specified in the input.txt file, the tool performs the action that is specified in the input file. The tool runs the
restart.bat file, which restarts the BlackBerry Dispatcher.

Environmental variables that the BlackBerry
Enterprise Server Log Monitoring Tool uses
The BlackBerry Enterprise Server Log Monitoring Tool sets the following environmental variables before it performs any of
the actions that you specify:

Variable Description

LogMonitorEncoding This variable specifies the type of encoding that is used for the file. For example,
the value might be “ ” or UTF-8 encoded.

LogMonitorEvent This variable specifies the event ID in the log file name.

LogMonitorAction This variable specifies the action that the tool performs after it finds the
requested event ID or text string.

LogMonitorText This variable specifies the text string.

LogMonitorValue This variable specifies the value that the tool returns that matches an event ID or
text string.

You can use these variables when you specify the actions that you want the tool to perform. For example, you can use the
variables in a batch script (.bat file) that sends an email message when the tool finds a specific event ID. You can design
the script to use the LogMonitorEvent value in the subject line of the email message. For example, the script can send an
email message with the subject "40702".

Example: Accessing and displaying environmental variables on the screen

A batch script that accesses and displays environmental variables on the screen can include the
following lines:

@echo off
echo "LogMonitorEncoding=%LogMonitorEncoding%"
echo "LogMonitorEvent=%LogMonitorEvent%"
echo "LogMonitorAction=%LogMonitorAction%"
echo "LogMonitorText=%LogMonitorText%"
echo "LogMonitorValue=%LogMonitorValue%"
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Run the BlackBerry Enterprise Server Log
Monitoring Tool
1. On the computer that hosts the BlackBerry Enterprise Server Log Monitoring Tool, on the taskbar, click Start > All

Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Monitoring Tool.

2. In the command prompt window, type LogMonitor -L <file_path>, and the parameters that you want to use to run the
tool. See Parameters for the BlackBerry Enterprise Server Log Monitoring Tool.

Example: Monitoring a specific log file and running a batch script when the tool finds the event IDs

LogMonitor -L "C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\Logs
\COMP1_DISP_01_20111215_0001.txt" -action cmd.bat -events 50099,50108

Example: Monitoring a specific log file and using an input file to specify event IDs and the actions to
perform when the tool finds the event IDs

LogMonitor -L "C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\Logs
\COMP1_DISP_01_20111215_0001.txt" -input input.txt

Example: Monitoring the BlackBerry Dispatcher log files daily and creating a debug file when the tool
finds the event IDs

LogMonitor -L "C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\Logs" -instance
0001 -type DISP -events 50099,50108 -debug troubleshooting.txt

After you finish: If you want to stop the tool, press CTRL+C.

Parameters for the BlackBerry Enterprise Server Log
Monitoring Tool
The parameters listed in brackets ( [ ] ) are optional.

Parameter Description

[-action <action>] This parameter specifies the action or actions that you want the BlackBerry
Enterprise Server Log Monitoring Tool to perform when it finds the event IDs or
text strings that you specify using the -events parameter or an input file.
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Parameter Description

You can specify any standard actions that the Windows command prompt
supports. For example, you can type the name of an executable file or a batch
file that you want the tool to open when it finds a specific event ID. By default, if
you do not specify an action, the tool displays the output on the screen.

To stop the tool after it performs a specified action, precede the action with a
tilde (~), or use the tilde only.

[-all] This parameter specifies that the tool examines the entire contents of a log file,
not just the information that is written to the log file after you run the tool.

[-debug <file_name>] This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and also specifies the name of the debug file.

[-events <event_IDs>] This parameter specifies the event IDs or text strings that you want the tool to
find in the log file. You must use commas ( , ) to separate multiple event IDs. If a
text string contains spaces, enclose the string in quotation marks (" ").

[-input <file_name>] This parameter specifies the name of the input text file that you created. The
input file contains the event IDs and text strings that you want the tool to find,
and the actions that you want the tool to perform when it finds each value.

[-instance <instance>] Use this parameter when you use the -L parameter to specify the folder that
contains the log files, and the -type parameter to specify the type of component
log file.

This parameter specifies the instance number of the log file (the last number in
the name of a log file). The instance number indicates the order of the log files if
more than one daily log file is created for a BlackBerry Enterprise Server
component. When a log file reaches the maximum size, an additional daily log
file is created and the instance number in the file name is increased by one. By
default, the instance used by the tool is 0001.

-L <file_path> This parameter specifies the file path of a specific log file that you want the tool
to monitor, or the file path of the folder that contains the log files that you want
the tool to monitor. If the file path contains spaces, enclose the file path in
quotation marks.

If you specify the file path of a specific log file, the tool monitors the specified file
only. It does not continue to monitor the log files that are generated by the
BlackBerry Enterprise Server component on a daily basis.

If you specify the file path of a folder (for example, C:\Program Files
(x86)\Research In Motion\BlackBerry Enterprise Server\Logs ), the tool opens
the specified folder and examines the contents of the latest <yyyymmdd>
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Parameter Description

subfolder for new files that match the -type and -instance parameters that you
specify. The tool continues to monitor the log files that the BlackBerry Enterprise
Server component creates on a daily basis.

[-timeout <time>] This parameter specifies the length of time, in seconds, that the tool continues
to run after no new messages are written to the log file that the tool is
monitoring. By default, there is no timeout value.

[-type <pattern>] Use this parameter when you use the -L parameter to specify the folder that
contains the log files, and the -instance parameter to specify the instance
number of the log files that you want to monitor.

This parameter uses a string value to specify the BlackBerry Enterprise Server
component that you want the tool to monitor log files for. For example, to
monitor the log files for the BlackBerry Dispatcher, specify the component log
file identifier DISP. For a full list of the component identifiers for the BlackBerry
Enterprise Server log files, visit www.blackberry.com/go/serverdocs to read the
BlackBerry Enterprise Server Administration Guide.

[/?]

[-?]

[-help]

These parameters provide more information about the tool and the parameters
that you can use with the tool. No other parameters are required when you use
one of these parameters.

Examples: Running the BlackBerry
Enterprise Server Log Monitoring Tool
The last three steps in these examples simulate how a BlackBerry Enterprise Server component writes new log events to a
log file that is being monitored. These steps are not required in a production environment.

Example: Running the tool to create a separate file for each user account that contains the log
messages for the user account

When the BlackBerry Enterprise Server Log Monitoring Tool finds the specified text strings in the log.txt
file, the tool creates files named jpalmer@test.rim.net.txt and karlatetzel@test.rim.net.txt.
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1. Create a file named cmd.bat that contains the following text:

@echo off
echo %LogMonitorText% >>%LogMonitorValue%.txt

2. Create an input file named input.txt that contains the following string (regular expression) for the
tool to monitor:

?:\} \{([^\}]*)

3. Create a file named log.txt to store and append the log information.

4. At the command prompt, run the following command:

LogMonitor –L log.txt –input input.txt –action cmd.bat

5. Create a text file named SampleMessage.txt.

6. Copy the following lines to SampleMessages.txt:

[40702] (08/16 00:00:11):{0x12E8} {jpalmer@rim.test.net} Starting 
message rescan
[40703] (08/16 00:00:12):{0x12E8} {jpalmer@test.rim.net} Message 
rescan completed
[40702] (08/16 00:00:12):{0x12E8} {karlatetzel@test.rim.net} 
Starting message rescan
[40703] (08/16 00:00:12):{0x12E8} {karlatetzel@test.rim.net} 
Message rescan completed

7. To append the contents of SampleMessages.txt to log.txt, at the command prompt, type type
SampleMessages.txt >>log.txt.

Example: Running the tool so that when it finds events 40702 or 40703, it runs a cmd.bat file and
closes

When the BlackBerry Enterprise Server Log Monitoring Tool finds the log entries in the log.txt file, the
BlackBerry Enterprise Server Log Monitoring Tool completes the action in the cmd.bat file. For example,
if cmd.bat is the same file that you used in the first example, the BlackBerry Enterprise Server Log
Monitoring Tool creates files named 40702.txt and 40703.txt.

1. Create a file named cmd.bat.

2. Create a text file named log.txt to store and append the log information.

3. At the command prompt, run the following command:

LogMonitor –L log.txt –events 40702,40703 –action cmd.bat
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4. Create a file named SampleMessage.txt.

5. Copy the following log lines to SampleMessages.txt:

[40702] (08/16 00:00:11):{0x12E8} {jpalmer@rim.test.net} Starting 
message rescan
[40703] (08/16 00:00:12):{0x12E8} {jpalmer@rim.test.net} Message 
rescan completed
[40702] (08/16 00:00:12):{0x12E8} {karlatetzel@test.rim.net} 
Starting message rescan
[40703] (08/16 00:00:12):{0x12E8} {karlatetzel@test.rim.net} 
Message rescan completed

6. To append the contents of SampleMessages.txt to log.txt, at the command prompt, type type
SampleMessages.txt >>log.txt.

Administration Guide BlackBerry Enterprise Server Log Monitoring Tool

62



BlackBerry System
Requirements Tool
You can use the BlackBerry System Requirements Tool (BBCheck.exe) to verify whether a computer can run a BlackBerry
Enterprise Server component. You can also use the tool to help you troubleshoot an installation or configuration issue. For
example, if a changed permission prevents you from performing a task that you could previously complete, you can run the
tool to help identify and resolve the issue.

You can specify whether the tool runs preconfigured tests or a test configuration file that you create. Optionally, you can
run the tool from the command prompt.

By default, the tool creates an output file and a log file in the folder that you run the application from. You can specify a
different file location when you install the tool. The name of the output file is
BBCheck_<host_name>_<yyyymmdd>_<hhmmss>.txt, where <host_name> is the name of the computer that runs the
tool and <yyyymmdd>_<hhmmss> is the date and time that the tool created the file. The name of the log file is
BBCheck_Log_<yyyymmdd>_<hhmmss>.txt, where <yyyymmdd_hhmmss> is the date and time that the tool created the
file.

Tests that the BlackBerry System
Requirements Tool can run
Test Description

General Information Retrieves information about the current user, host name, and OS version.
Verifies permissions to log on as a service and log on locally

Verifies whether the current user is a member of local administrators

BES Information Retrieves information about the BlackBerry Enterprise Server, such as the
version number, installation path, and access node

Service Account Retrieves information about the BlackBerry Enterprise Server service account,
verifies whether the account has the required Send As permissions, and verifies
domain group memberships

8
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Test Description

Exchange Permissions Verifies whether the current account has the required permissions for a
Microsoft Exchange environment, including: Create Named Properties in the
Information Store, Send As, Receive As, and Administer Information Store

MAPI Subsystem Retrieves the version of the MAPI/CDO subsystem

GC Retrieves the global catalog server information of the GC that the current
workstation was assigned during the initialize boot sequence

Database Retrieves information about the database configuration on the computer

DB BES Instance Versions Retrieves the version information for all BlackBerry servers in the database

Java Retrieves information about the Java Runtime that is installed on the computer

.NET Framework Retrieves information about the version of the Microsoft .NET Framework that is
installed on the computer

MSMQ Retrieves information about the version of the MSMQ on the computer

Network Retrieves network-related information

SRP Connectivity Attempts to connect to the BlackBerry Infrastructure and reports the result

System Information Retrieves system and hardware information

System Hotfixes Retrieves a list of the hotfixes that have been installed for the operating system

Current Processes Retrieves a list of the processes that are currently running on the computer

Create a test configuration file
Using a text editor, you can create a test configuration file (.testconfig) that specifies the tests that you want the tool to run.
Note the following standards when you create the configuration file:

• To indicate a comment line that you want the tool to ignore, begin the line with a number sign (#). The tool ignores
blank lines and comment lines.

• Test names are case-sensitive. If a name includes embedded spaces, include only one space between the words.

1. Create a .txt file and open it in a text editor.

2. Type the comment line # BlackBerry System Requirements Tool Test Configuration.
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3. List the following tests, one test per line:

• General Information

• BES Information

• Service Account

• Exchange Permissions

• MAPI Subsystem

• GC

• Database

• DB BES Instance Versions

• Java

• .NET Framework

• MSMQ

• Network

• SRP Connectivity

• System Information

• System Hotfixes

• Current Processes

4. After each test name, specify one of the following values (do not include any spaces):

• If you want the tool to run the test, type =true. For example, System Information=true.

• If you do not want the tool to run the test, type =false. For example, System Information=false. If you do not
specify a value for a test, the default value is false.

5. Save and close the .txt file.

6. Rename the text file and replace the extension ".txt" with ".testconfig".

Example: Test configuration file

# BlackBerry System Requirements Tool Test Configuration
# a.testconfig
General Information=true
BES Information=true
Service Account=true
Exchange Permissions=true
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MAPI Subsystem=true
GC=true
Database=true
DB BES Instance Versions=true
Java=true
.NET Framework=true
MSMQ=true
Network=true
SRP Connectivity=true
System Information=true
System Hotfixes=true
Current Processes=true

Run the BlackBerry System Requirements
Tool
1. On the computer that hosts the BlackBerry System Requirements Tool, on the taskbar, click Start > All Programs >

BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry System Requirements Tool GUI.

2. In the Test Configuration section, perform one of the following actions:

• Select the tests that you want the tool to run.

• If you want to use a test configuration file (.testconfig) to specify the tests that you want the tool to run, click Load
from File. Navigate to and select the test configuration file. Click Open.

If you want to save a custom .testconfig file for later use based on the tests that you selected in the Test Configuration
section, click Save As.

3. In the System Requirements Collection section, click Collect System Data.

4. In the Status window, verify that the tests run successfully.

5. Perform one of the following actions:

• To open the output file, click View Data.

• To select a different file, or to open the log file, click Open Data Folder.

After you finish: By default, the log file and output file can be found in <drive>:\Documents and Settings\<user_name>
\Application Data\Research In Motion\AMT .
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Run the BlackBerry System Requirements
Tool from the command prompt
1. On the computer that hosts the BlackBerry System Requirements Tool, on the taskbar, click Start > All Programs >

BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry System Requirements Tool.

2. In the command prompt window, type BBCheckCmd and any of the following parameters (parameters in brackets
are optional):

Parameter Description

[-r <test_name>]

[-run <test_name>]

This parameter specifies the name of the test that you want to run. You can
specify a single test, or you can type -r all or -run all to run all available tests.
The test name is not case-sensitive when you use it as a parameter.

You can specify any of the following tests. If a test name contains an
embedded space, you must enclose the test name in quotation marks ( " " ),
and you can include only one space between any two words.

• "General Information"

• "BES Information"

• "Service Account"

• "Exchange Permissions"

• "MAPI Subsystem"

• GC

• Database

• "DB BES Instance Versions"

• Java

• ".NET Framework"

• MSMQ

• Network

• "SRP Connectivity"

• "System Information"

• "System Hotfixes"

• "Current Processes"
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Parameter Description

If you want to use a single command to run multiple tests, but you do not
want to run all of the tests, you can use a test confuration file (.testconfig)
and the -f <file_path>] parameter.

[-f <file_path>]

[-file <file_path>]

If you want to use a test configuration file (.testconfig) to specify the tests
that you want to run, use this parameter to specify the file path to
the .testconfig file and the name of the file. If the file path includes a space,
enclose the path in quotation marks ( " " ).

[-v <level>] This parameter specifies the level of detail that is written to the log files. The
options are TRACE, DEBUG, or INFO. The default log level is INFO.

Example: Running a single test

BBCheckCmd -r "General Information"

Example: Running all available tests

BBCheckCmd -r all

Example: Running the tests specified in a configuration file

BBCheckCmd -f "C:\Documents and Settings\jpalmer\Application Data\Research In Motion\AMT
\Custom.testconfig"

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type BBCheckCmd -? or BBCheckCmd -h or BBCheckCmd -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Example: Output file

Detection Report
[GENERAL]
Current User:    TEST\jpalmer
Host Name:    jpalmer-XP2
OS Version:    Microsoft Windows XP, Service Pack 3
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Log on as a service right:    Deny
Log on locally right:        Allow
Local Administrators member:    Yes

BES]
Platform:                Unknown
Version:                Unknown
Install Path:                Unknown
MAPI Profile:            Unknown
MAPI GC:                Unknown

[SERVICE_ACCOUNT]

BlackBerry Server Account:    Unknown
Active Directory 'Send As':    Allow
Domain Group Membership:
    ExchangeViewOnlyAdmins

[EXCHANGE_PERMISSIONS]

Exchange permission 'Create Named Properties in the information store' 
over Administrative Groups for group: Everyone

Administrative Group: CN=r1,CN=Administrative 
Groups,CN=RIM,CN=Microsoft 
Exchange,CN=Services,CN=Configuration,DC=core,DC=sqm,DC=testnet,DC=rim,
DC=net
Group: Everyone has allow

Administrative Group: CN=r2,CN=Administrative 
Groups,CN=RIM,CN=Microsoft 
Exchange,CN=Services,CN=Configuration,DC=core,DC=sqm,DC=testnet,DC=rim,
DC=net
Group: Everyone has allow

Exchange permissions 'Send As', 'Receive As', 'Administer Information 
Store' for account: core\jiadmin

Domain Name:                test.rim.net
GC Name:                Mixd01.test.rim.net
GC IP:                XX.XX.XXX.XX

[MAPI_SUBSYSTEM]

EXMAPI32.DLL:    Unable to find EXMAPI32.DLL version information!
MAPI32.DLL:    1.0.2536.0 (C:\WINDOWS\system32\mapi32.dll)
EMSMDB32.DLL:    Unable to find EMSMDB32.DLL version information!
CDO.DLL:    Unable to find CDO.DLL version information!

[GC]

Domain Name:    test.rim.net
GC Name:    server01.test.rim.net
GC IP:        xx.xx.xxx.xx

[DATABASE]
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Hostname:    Unknown
DB Name:    Unknown
Location:    Unknown
DB info via TSQL: unable to connect to database!

SQL Version:    Unable to find SQL version!
MSDE Version:    Unable to find MSDE version!
MDAC Version:    2.81.1117.0
MSADO15.DLL:    2.81.1128.0 (C:\Program Files\Common Files\system\ado
\msado15.dll)

[DB_BES_INSTANCE_VERSIONS]

[JAVA]

Version:    1.6
Path:    C:\Program Files\Java\jre6

MDS JVM Path:    Unknown

[DOT_NET_FRAMEWORK]

Version 1.0:             INSTALLED
Version 1.1 (1.1.4322):         INSTALLED
Version 2.0 (2.0.50727):     INSTALLED
Version 3.0 (3.0.0456.30):     MISSING

[MSMQ]

MSMQ Version:    Unknown

[NETWORK]

Local IP:        xx.xx.xx.xx
TCP/IP Providor:    xx.xx.xxxx.xxxx (C:\WINDOWS\System32\wsock32.dll)
Winsock2 File:        xx.xx.xx.xxxx (C:\WINDOWS\System32\mswsock.dll)

[SRP_CONNECTIVITY]

Host:    srp.test.blackberry.net
IP:    xxx.xxx.xx.xx

Status: Connection Successful

[SYSTEM_INFORMATION]

Processor:

Processor Identifier:    x86 Family 6 Model 15 Stepping 6
Processor Vendor:    GenuineIntel
Processor Name:        Intel(R) Core(TM)2 CPU          6400  @ 2.13GHz
Processor Speed:    2136 MHz
Number of CPUs:        2

Memory:
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Memory In Use:        58%
Total Memory:        1,047,724 KB
Memory Available:    435,140 KB
Memory Limit:        2,523,672 KB
Available Commit:    2,066,788 KB

Hard Drive:

Drive:    C:\, Free: 28,349,001 KB, Total: 74,348,269 KB

Time Info:

Uptime:        2 days 13 hours 37 minutes 37 seconds
Time Zone:    Eastern Daylight Time (GMT-05:00)

[SYSTEM_HOTFIXES]

B955839 - Update for Windows XP (KB955839)
KB958687 - Security Update for Windows XP (KB958687)
KB960714 - Security Update for Windows XP (KB960714)
KB960715 - Security Update for Windows XP (KB960715)
KB967715 - Update for Windows XP (KB967715)

[PROCESSES]

Number of Processes: 12

Process                            PID       Threads

System                             4         68
smss.exe                           832       2
csrss.exe                          896       13
winlogon.exe                       928       24
services.exe                       972       16
svchost.exe                        1408      60
sqlservr.exe                       1208      23
winlogon.exe                       1564      10
ccApp.exe                          1752      9
ctfmon.exe                         2356      1
MOM.exe                            3280      9
logon.scr                          3956      1
BBCheck.exe                        2076      4
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BlackBerry Domain
Administration History
Reporting Tool
You can use the BlackBerry Domain Administration History Reporting Tool (AdminHistory.exe) to audit and report on
changes to the ServerConfigHistory table in the BlackBerry Configuration Database. For example, the tool reports the date
and time that an administrator added user accounts or applied IT policy settings or security settings to user accounts.

The tool is designed for use only with BlackBerry Enterprise Server 4.1 SP7 and earlier.

The tool creates an output file that is named AdminHistory_Log_<yyyymmdd>_<hhmm>.csv, where <yyyymmdd> is the
year, month, and day, and <hhmm> is the hour and minute that the tool created the file.

Run the BlackBerry Domain Administration
History Reporting Tool
1. On the computer that hosts the BlackBerry Domain Administration History Reporting Tool, on the taskbar, click Start

> All Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and
Troubleshooting Tools > BlackBerry Domain Administration History Reporting Tool.

2. In the command prompt window, type AdminHistory and the following parameters:

Parameter Description

-db <database_name> Use this parameter if the BlackBerry Configuration Database is installed on a
Microsoft SQL Server database engine.

This parameter specifies the host name or IP address of the BlackBerry
Configuration Database.

-db2 -db2schema <schema> Use these parameters if the BlackBerry Configuration Database is installed on an
database engine. This configuration is supported in an IBM Lotus Domino
environment only.

Specify the schema name of the BlackBerry Configuration Database. By default,
the tool uses the schema name BESADMIN.

9
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Parameter Description

-n <database_server> This parameter specifies the host name, computer name, or IP address of the
server that hosts the BlackBerry Configuration Database.

By default, the tool uses the name localhost.

3. Type any of the following optional parameters:

Parameter Description

-date This parameter is used to specify the date range for the report.

If you specify this parameter, you must also specify the -f <from_date> and -t
<to_date> parameters.

-f <from_date> This parameter specifies the start date (from date) for the report, using the format
yyyymmdd. For example, 20120522.

If you specify this parameter, you must also specify the -date and -t <to_date>
parameters.

-t <to_date> This parameter specifies the end date (to date) for the report, using the format
yyyymmdd. For example, 20120525.

If you specify this parameter, you must also specify the -date and -f <from_date>
parameters.

-l <limit> This parameter specifies the maximum number of records to retrieve from the
BlackBerry Configuration Database. By default, the tool processes all of the
records in the ServerConfigHistory table.

If you do not remove the previous output file, the tool appends the new output file
to the previous file. The average limit is 1000 to 2000 lines.

-SQLAuth Use this parameter if you want the tool to use database authentication. By default,
the tool uses Windows authentication.

If you specify this parameter, you must also specify the -login
<database_login_name> and -password <database_password> parameters.

-login <database_login_name> If you want the tool to use database authentication, this parameter specifies the
login name that the tool uses.

If you specify this parameter, you must also specify the -SQLAuth and -password
<database_password> parameters.

-password
<database_password>

If you want the tool to use database authentication, this parameter specifies the
password that the tool uses.

If you specify this parameter, you must also specify the -SQLAuth and -login
<database_login_name> parameters.
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Parameter Description

-o <output_filename> This parameter specifies the name of the output file that the tool creates.

Example: Running the tool using Windows authentication

AdminHistory -db BESMgmt -n server01 -o output.csv -l 1000

Example: Running the tool to retrieve records for a specific date range

AdminHistory -db BESMgmt -n server01 -date -f 20120420 -t 20120425 -o output.csv

Example: Running the tool using Microsoft SQL Server authentication

AdminHistory -db BESMgmt -n server01 -SQLAuth -login “Julie Palmer” -password password1 -o
output.csv -l 1000

Example: Running the tool using IBM DB2 UDB authentication

AdminHistory -db BESMgmt -n server01 -db2 -db2schema besadmin -SQLAuth -login “Julie Palmer” -
password password1 -o output.csv -l 1000

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type AdminHistory -?.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Interpreting configuration changes that are
reported in the log file
Item Description

Time This column specifies the time of the configuration change.

Table This column specifies the table in the BlackBerry Configuration Database that
changed.
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Item Description

ServerName This column specifies the name of the BlackBerry Enterprise Server instance
that made the change to the BlackBerry Configuration Database.

DisplayName This column specifies the display name of the user account whose data
changed.

UserName This column specifies the name of the user account whose data changed.

Operation This column specifies the type of change.

Details This column provides a description of the change.

SecDisplayName This column specifies the name of the user account that made the change.

Example: Log file for a successful
connection to the BlackBerry Configuration
Database
[20000] (05/02 09:14:22:56.850):{0x34C} Attempting Database Connection...
[20000] (05/02 09:14:22:57.260):{0x34C} Database Connection Successful!
[20000] (05/02 09:14:22:57.260):{0x34C} Attempting To Create/Open Output CSV File...
[10000] (05/02 09:14:22:57.260):{0x34C} Performing SELECT On ServerConfigHistory 
Table...
[10000] (05/02 09:14:22:57.751):{0x34C} Retrieving the recordset size. This may 
take a few minutes...
[10000] (05/02 09:14:22:57.754):{0x34C} 876 Record Limit Requested By User.
[20000] (05/02 09:14:23:00.059):{0x34C} 876 Records Returned.
[20000] (05/02 09:14:23:00.059):{0x34C} 876 Total Entries Processed.
[20000] (05/02 09:14:23:00.059):{0x34C} CSV Write Operation Complete!
[20000] (05/02 09:14:23:00.059):{0x34C} File Location: C:\AdminHistory DEMO
\AdminHistory_1\20070502.csv
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Example: Log file for an unsuccessful
attempt to connect to the BlackBerry
Configuration Database
[20000] (05/02 13:10:30:36.850):{0x34C} Attempting Database Connection...
[20000] (05/02 13:11:38:57.453):{0x34C} Database Connection Failed!
[20000] (05/02 13:11:38:57.453):{0x34C} Database Error: COM Error 0x80004005 in 
ADOConnectionItem:ConnectToDB() - 
[Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access 
denied. - Unspecified error
[20000] (05/02 13:11:38:57.453):{0x34C} BlackBerry Domain Administration History 
Reporting Tool Terminating...
[20000] (05/02 13:11:3857.453):{0x34C} Attempting To Write Debug Log...
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BlackBerry Enterprise Server
Log Analysis Tool
The BlackBerry Enterprise Server Log Analysis Tool is an application that you can use to run the various log analysis tools
that are available in the BlackBerry Enterprise Server Resource Kit. You can configure and run the log analysis tools from
the BlackBerry Enterprise Server Log Analysis Tool or from the command prompt.

The BlackBerry Enterprise Server Log Analysis Tool contains the following log analysis tools that you can use to manage
and troubleshoot your BlackBerry Enterprise Server environment:

• BlackBerry Calendar Synchronization Reporting Tool

• BlackBerry Delayed Notifications Monitoring Tool

• BlackBerry Historical Statistics Tool

• BlackBerry MAPI and CDO Error Monitoring Tool

• BlackBerry MDS Services Data Monitoring Tool

• BlackBerry Message Flow Reporting Tool

• BlackBerry Thread Analyzer Tool

• BlackBerry Message Pending Delivery Tool

• BlackBerry Usage Monitoring Tool

• BlackBerry User Activity Reporting Tool

Prepare to run the log analysis tools
For more information about how to change the logging levels for BlackBerry Enterprise Server components, visit 
www.blackberry.com/go/serverdocs to read the BlackBerry Enterprise Server Administration Guide.

Before you begin:
• Verify that the versions of the log analysis tools are compatible with the version of the BlackBerry Enterprise Server in

your organization's environment.

• Verify that you installed the tools on a computer that does not host BlackBerry Enterprise Server components.

• Verify that the computer that you want to use to run the log analysis tools has a large volume of free disk space to
accommodate the size of the log files and the log analysis output files.

10
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1. Set the logging level to 4 for each of the following log files:

Tool Component log file name

BlackBerry Delayed Notifications Monitoring Tool (DelayedNotifications.exe) MAGT log file

BlackBerry Historical Statistics Tool (HistoricalStats.exe) DISP log file

BlackBerry MAPI and CDO Error Monitoring Tool (MapiCdoErrors.exe) MAGT log file

BlackBerry MDS Services Data Monitoring Tool (MDSPushvsPull.exe) MDAT log file

BlackBerry Message Flow Reporting Tool (Messageflow.exe) MAGT log file, DISP log file, and
ROUT log file

BlackBerry Message Pending Delivery Tool (Pending.exe) MAGT log file

BlackBerry Thread Analyzer Tool (NoResponseCheck.exe) All BlackBerry log files except the
MDAT log files; the logging levels do
not have to be set to 4

BlackBerry Usage Monitoring Tool (OutofCoverage.exe) DISP log file

BlackBerry User Activity Reporting Tool (AvailIndex.exe) MAGT log file

BlackBerry Calendar Synchronization Reporting Tool (CalSync.exe) MAGT log file

2. Copy the log files for the required BlackBerry Enterprise Server components to the computer that hosts the tool.

3. Record the log folder name and path. You must provide the location if it is different from the folder that contains the
log analysis tool.

Configure the messaging platform
1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All

Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. Click Settings > Messaging Platform.

3. Select the appropriate option.

4. Click OK.

5. Click File > Save Settings.
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Configure default log settings
1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All

Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. Click Settings > Log.

3. If necessary, in the Output Verbosity section, click Debug Log Level. Click the browse button beside the Debug
Output File field. Navigate to and select a debug output file.

4. If necessary, in the Log Identifiers section, type the log identifier information of the log files for the BlackBerry
Enterprise Server components.

5. Click OK.

6. Click File > Save Settings.

Configure the default input folder and
default output folder
1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All

Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. Click Settings > Default Folders.

3. Beside the Input Folder field, click the browse button. Navigate to and select the default folder for input files.

4. Beside the Output Folder field, click the browse button. Navigate to and select the default folder for output files.

5. Click OK.

6. Click File > Save Settings.
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BlackBerry Calendar
Synchronization Reporting Tool
In a BlackBerry Enterprise Server environment, you can use the BlackBerry Enterprise Trait Tool to turn on an automatic
calendar synchronization process. You can use the BlackBerry Calendar Synchronization Reporting Tool (CalSync.exe) in a
Microsoft Exchange or IBM Lotus Domino environment to retrieve data from a BlackBerry Messaging Agent (MAGT) log file
about the calendar synchronization process. You can use the data to troubleshoot calendar synchronization issues.

The tool reports the results of a query in files that are named CalParseServerSummary_<mmdd>.csv,
CalParseUserSummary_<mmdd>.csv, and CalParseUserDetails_<mmdd>.csv, where <mmdd> is the month and day. You
can also use the tool to compile the user details in multiple CalParseUserDetails_<mmdd>.csv files into a
CalDiffSummary_<start_mmdd>-<end_mmdd>.csv file.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry Calendar
Synchronization Reporting Tool using the
BlackBerry Enterprise Server Log Analysis
Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent (MAGT) log files to the computer that hosts the BlackBerry Calendar
Synchronization Reporting Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click Calendar Synchronization Reporting.
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3. Click Open Tool.

4. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry Messaging
Agent (MAGT) log files.
If multiple BlackBerry Messaging Agent (MAGT) log files exist in the input folder that you specify, the tool processes
the MAGT log file with the most recent date.

5. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output files
for the BlackBerry Calendar Synchronization Reporting Tool.

6. To configure the tool to analyze only log files that are located in a subfolder with the current date, click the Only
search for a subdirectory with today's date check box.

7. Click Run.

8. To view the results, click the Console tab.

Compare calendar synchronization information using
the BlackBerry Enterprise Server Log Analysis Tool
You can use the BlackBerry Calendar Synchronization Reporting Tool to compile the user details information in multiple
CalParseUserDetails_<mmdd>.csv files into a CalDiffSummary_<start_mmdd>-<end_mmdd>.csv file.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click Calendar Synchronization Reporting.

3. Click Open Tool.

4. Click the Diff tab.

5. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the
CalParseUserDetails_<mmdd>.csv files.

6. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the summary
output file.

7. Click Run.

8. To view the results, click the Console tab.
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Run the BlackBerry Calendar
Synchronization Reporting Tool from the
command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent (MAGT) log files to the computer that hosts the BlackBerry Calendar
Synchronization Reporting Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Calendar Synchronization Reporting Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Calendar Synchronization Reporting Tool.

2. In the command prompt window, type CalSync and the following parameters:

Parameter Description

-parse This parameter specifies that the tool analyzes the BlackBerry Messaging Agent
log files to extract data about the calendar synchronization process.

-p E[xchange]

-p D[omino]

This parameter specifies the messaging platform. Type -p E for Microsoft
Exchange, or -p D for IBM Lotus Domino.

3. Type any of the following optional parameters:

Parameter Description

-today This parameter specifies that the tool analyzes only log files that are located in a
subfolder with the current date.

-L <path> This parameter specifies the location of the log files to query if the files are not
located in the same folder as the tool. If the path contains spaces, enclose the
path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If the
path contains spaces, enclose the path in quotation marks ( " " ).

-agent <abbreviation> This parameter specifies the abbreviation for the BlackBerry Messaging Agent log
files. If you do not specify a name, the BlackBerry Calendar Synchronization
Reporting Tool uses MAGT.
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Parameter Description

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information on
the screen.

Example: Producing a detailed output file for the calendar synchronization information in a specified
log file

CalSync -parse -p E -debug detail.txt -L C:\BRK

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type CalSync -? or CalSync -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Compare calendar synchronization information from
the command prompt
You can use the BlackBerry Calendar Synchronization Reporting Tool to compile the user details information in multiple
CalParseUserDetails_<mmdd>.csv files into a CalDiffSummary_<start_mmdd>-<end_mmdd>.csv file.

1. On the computer that hosts the BlackBerry Calendar Synchronization Reporting Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Calendar Synchronization Reporting Tool.

2. In the command prompt window, type CalSync and the following parameters:

Parameter Description

-diff This parameter specifies that the tool reports the differences between two
detailed output files.

-p E[xchange]

-p D[omino]

This parameter specifies the messaging platform. Type -p E for Microsoft
Exchange, or -p D for IBM Lotus Domino.

3. Type any of the following optional parameters:
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Parameter Description

-today This parameter specifies that the tool analyzes only log files that are located in a
subfolder with the current date.

-L <path> This parameter specifies the location of the log files to query if the files are not
located in the same folder as the tool. If the path contains spaces, enclose the
path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If the
path contains spaces, enclose the path in quotation marks ( " " ).

-agent <abbreviation> This parameter specifies the abbreviation for the BlackBerry Messaging Agent log
files. If you do not specify a name, the BlackBerry Calendar Synchronization
Reporting Tool uses MAGT.

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information on
the screen.

Example: Compiling user details information from multiple CalParseUserDetails.csv files into a
CalDiffSummary.csv output file

CalSync -diff -p e -L C:\BRK

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type CalSync -? or CalSync -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .
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Results of the BlackBerry Calendar
Synchronization Reporting Tool query
Results in the CalParseServerSummary file
Column Description

BES This column specifies the name of the BlackBerry Enterprise Server.

Server This column specifies the messaging server that hosts the BlackBerry Enterprise
Server.

Missing on device This column specifies the number of calendar entries that exist on users'
computers but do not exist on BlackBerry devices.

Different This column specifies the number of calendar entries on users' computers that
are different from the calendar entries on devices.

Same This column specifies the number of calendar entries that are the same on
users' computers and on devices.

Missing on <messaging_server> This column specifies the number of calendar entries that exist on devices but
do not exist on users' computers.

Original Total Device This column specifies the number of calendar entries that were created on
devices.

Original Total <messaging_server> This column specifies the number of calendar entries that were created on
users' computers.

Net Total This column specifies the total number of calendar entries that are missing on
the messaging server and that were created on users' computers.

Results in the CalParseUserSummary file
Column Description

BES This column specifies the BlackBerry Enterprise Server that the user account is
associated with.

Server This column specifies the messaging server that hosts the user account.
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Column Description

User This column specifies the user account.

Missing on device This column specifies the number of calendar entries that exist on the user's
computer but do not exist on the device.

Different This column specifies the number of calendar entries on the user's computer
that are different from the calendar entries on the device.

Same This column specifies the number of calendar entries that are the same on the
user's computer and on the device.

Missing on <messaging_server> This column specifies the number of calendar entries that exist on the device
but do not exist on the user's computer.

Original Total Device This column specifies the number of calendar entries that the user created on
the device.

Original Total <messaging_server> This column specifies the number of calendar entries that the user created on
the user's computer.

Net Total This column specifies the total number of calendar entries that are missing on
the messaging server and that were created on the user's computer.

Results in the CalParseUserDetails file
Column Description

BES This column specifies the BlackBerry Enterprise Server that the user account is
associated with.

Server This column specifies the messaging server that the user account is associated
with.

User This column specifies the user account.

Type This column specifies whether the calendar entry on the user's computer is
different from the entry on the device. If necessary, this column also specifies
how the calendar entry is different on the user's computer or on the device.

RefID This column specifies the reference ID of the calendar entry on the user's
computer.

PRefID This column specifies the reference ID of the calendar entry on the device.

Time This column specifies the time that the message was written to the log file.
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Results in the CalDiffSummary file
Column Description

Day This column specifies the day that the log information was collected on for a
specific calendar entry.

BES This column specifies the BlackBerry Enterprise Server that the user account is
associated with.

Server This column specifies the messaging server that the user account is associated
with.

User This column specifies the user account.

Type This column specifies whether the calendar entry on the user's computer is
different from the entry on the device. If necessary, this column also specifies
how the calendar entry is different on the user's computer or on the device.

RefID This column specifies the reference ID of the calendar entry on the user's
computer.

PRefID This column specifies the reference ID of the calendar entry on the device.

Time This column specifies the time that the message was written to the log file.
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BlackBerry Delayed
Notifications Monitoring Tool
You can use the BlackBerry Delayed Notifications Monitoring Tool (DelayedNotifications.exe) to obtain an overview of the
performance of the BlackBerry Enterprise Server and the Microsoft Exchange Server.

The tool displays the results of a query in a file that is named DelayedNotifications_<mmdd>.<#>.csv, where <mmdd> is
the month and day, and <#> is the number of BlackBerry Messaging Agent restarts that the tool finds in the log files.

High counts of delayed notifications indicate that the Microsoft Exchange Server is no longer providing UDP notifications
for new messages promptly to the BlackBerry Enterprise Server.

If a user account is in a delayed-notification state, the BlackBerry Enterprise Server might not receive notifications for new
messages and calendar items from the Microsoft Exchange Server. The BlackBerry Enterprise Server is designed to use
rescans to detect messages and calendar items.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry Delayed Notifications
Monitoring Tool using the BlackBerry
Enterprise Server Log Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent (MAGT) log files to the computer that hosts the BlackBerry Delayed Notifications
Monitoring Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click Delayed Notifications Monitoring.

3. Click Open Tool.

12
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4. In the User Selection section, perform one of the following actions:

• To run the tool for all user accounts, click All.

• To run the tool for a specific user account, click Email Address. Type the SMTP email address of the user
account.

• To run the tool for user accounts that are listed in an email address file, click Email Address File. Beside the
Email Address File field, click the browse button. Navigate to the email address file.

5. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry Messaging
Agent (MAGT) log files.

6. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output
files.

7. Click Run.

8. To view the results, click the Console tab.

Run the BlackBerry Delayed Notifications
Monitoring Tool from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent (MAGT) log files to the computer that hosts the BlackBerry Delayed Notifications
Monitoring Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Delayed Notifications Monitoring Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Delayed Notifications Monitoring Tool.

2. In the command prompt window, type DelayedNotifications and the following parameters:

Parameter Description

-p E This parameter specifies that you use the tool in a Microsoft Exchange
environment.

-u <SMTP_address>

-u all

This parameter specifies the SMTP email address of the user account that
you want to monitor.

To monitor all user accounts, type -u all.

3. Type any of the following optional parameters:
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Parameter Description

-input <filename.txt> This parameter specifies the name of the file that contains the SMTP email
addresses of the user accounts that you want to monitor.

You use a carriage return to separate each entry in the file.

This parameter overrides the value that is specified with the -u parameter.

-L <path> This parameter specifies the location of the debug log files that you want to
query if they are not in the same folder as the tool. If the path contains
spaces, enclose the path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If
the path contains spaces, enclose the path in quotation marks ( " " ).

-agent <abbreviation> This parameter specifies the abbreviation for the BlackBerry Messaging
Agent log files. If you do not specify an abbreviation, by default, the
BlackBerry Delayed Notifications Monitoring Tool uses MAGT.

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information
on the screen.

Example: Identifying all user accounts in a file that are in a delayed-notification state

DelayedNotifications -p E -u all -input users.txt

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type DelayedNotifications -? or DelayedNotifications -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .
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Results of a BlackBerry Delayed
Notifications Monitoring Tool query
Column Description

Server This column specifies the Microsoft Exchange Server that hosts the user account.

Email Address This column specifies the email address of the BlackBerry device user.

DeviceID This column specifies the PIN of the device.

SRPid This column specifies the SRP identifier for the BlackBerry Enterprise Server.

MAPISession This column specifies the MAPI session that the delayed notification occurred in.

Start This column specifies the time that the delayed notification occurred.

Stop This column specifies the time that multiple occurrences of delayed notifications
completed. For a single occurrence, this time matches the start time.

Count This column specifies the number of times that a reported delay occurred.

Type This column specifies whether the delay affected the delivery of email messages or
calendar items.

File This column specifies the file name that contains this record.
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BlackBerry Historical Statistics
Tool
You can use the BlackBerry Historical Statistics Tool (HistoricalStats.exe) to obtain detailed statistical information for a
specific user account, or for all user accounts, for a single day. You can use this information to track usage trends for the
BlackBerry Enterprise Server and BlackBerry devices.

The tool displays the results of a query in a report file that is named HistoricalStats_<account>_<mmdd>.<#>.csv, where
<account> is the name of the user account, <mmdd> is the month and day, and <#> is the number of BlackBerry
Messaging Agent restarts that the tool finds in the log files.

If you query all user accounts, the report file is named HistoricalStats_<mmdd>.<#>.csv.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry Historical Statistics Tool
using the BlackBerry Enterprise Server Log
Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the log files for the BlackBerry Messaging Agent and BlackBerry Dispatcher to the computer that hosts the
BlackBerry Historical Statistics Tool and BlackBerry Enterprise Server Log Analysis Tool.

• If necessary, change the logging level to 4 for the following fields in the DISP log files: CICAL FROM (in bytes), CMIME
FROM (in bytes), and MDS FROM (in bytes).

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click Historical Statistics.

3. Click Open Tool.

13
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4. In the User Selection section, perform one of the following actions:

• To run the tool for all user accounts, click All.

• To run the tool for a specific user account, click Email Address. Type the SMTP email address of the user
account.

• To run the tool for user accounts that are listed in an email address file, click Email Address File. Beside the
Email Address File field, click the browse button. Navigate to the email address file.

5. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry Messaging
Agent (MAGT) log files and BlackBerry Dispatcher (DISP) log files.

6. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output files
for the BlackBerry Historical Statistics Tool.

7. To create one output file for each user account, select the One output file for each user check box.

8. Click Run.

9. To view the results, click the Console tab.

Run the BlackBerry Historical Statistics Tool
from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the log files for the BlackBerry Messaging Agent and BlackBerry Dispatcher to the computer that hosts the
BlackBerry Historical Statistics Tool and BlackBerry Enterprise Server Log Analysis Tool.

• If necessary, change the logging level to 4 for the following fields in the DISP log files: CICAL FROM (in bytes), CMIME
FROM (in bytes), and MDS FROM (in bytes).

1. On the computer that hosts the BlackBerry Historical Statistics Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Historical Statistics Tool.

2. In the command prompt window, type HistoricalStats and the following parameters:

Parameter Description

-p E[xchange]

-p D[omino]

-p G[roupWise]

This parameter specifies the messaging platform.
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Parameter Description

-u <account>

-u all

This parameter specifies the user account.

To query all user accounts in the log files, type -u all.

To query a specific user account, type the user name in one of the
following formats:

• Microsoft Exchange: SMTP email address (for example,
jpalmer@<domain>.net)

• IBM Lotus Domino: canonical name (for example, Julie Palmer/
Organization)

• Novell GroupWise: first name and last name (for example, Julie
Palmer)

3. Type any of the following optional parameters:

Parameter Description

-input <filename.txt> This parameter specifies the name of the file that contains the SMTP
email addresses of the user accounts that you want to monitor.

Use a carriage return to separate each entry in the file.

This parameter overrides the value that is specified with the -u
parameter.

-L <path> This parameter specifies the location of the debug log files that you
want to query if the files are not in the same folder as the tool. If the
path contains spaces, enclose the path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output
files. If the path contains spaces, enclose the path in quotation marks
( " " ).

-output user

-output all

This parameter specifies how to organize the data in output files.

To create one file for each user account, type -output user.

To create one file for all user accounts, type -output all. This is the
default value.

-agent <abbreviation> This parameter specifies the abbreviation for the BlackBerry
Messaging Agent log files. If you do not specify an abbreviation, the
BlackBerry Historical Statistics Tool uses MAGT.

-dispatcher <abbreviation> This parameter specifies the abbreviation for the BlackBerry
Dispatcher log files. If you do not specify a name, the tool uses DISP.
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Parameter Description

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output
file for debugging purposes, and it specifies the name of the
debugging file.

If you do not specify a file name, the tool displays the debugging
information on the screen.

Example: Querying historical statistics for a BlackBerry Enterprise Server for Microsoft Exchange

HistoricalStats -p E -u all -L C:\BRK -output all

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type HistoricalStats -? or HistoricalStats -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Results of a BlackBerry Historical Statistics
Tool query
Column Description

Server This column specifies the messaging server that hosts the user accounts.

This column applies to the BlackBerry Enterprise Server for Microsoft Exchange and
the BlackBerry Enterprise Server for IBM Lotus Domino only.

User This column specifies the name of the user account in one of the following formats:

• Microsoft Exchange: SMTP email address

• IBM Lotus Domino: canonical name

• Novell GroupWise: first name and last name

Email address This column specifies the SMTP email address of the user account.
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Column Description

This column applies only to the BlackBerry Enterprise Server for IBM Lotus Domino.

Display name This column specifies the display name of the user account.

DeviceID This column specifies the PIN of the device.

SRPID This column specifies the SRP identifier for the BlackBerry Enterprise Server that
hosts the user account.

Messages to This column specifies the number of messages that were sent to the device.

Messages from This column specifies the number of messages that were sent from the device.

If your organization's environment uses BlackBerry Enterprise Server for IBM Lotus
Domino, when a user replies to an email message, the original message is attached
and counted as a separate message. As a result, this field might display a higher
number of messages than expected.

replied to/forwarded from This column specifies the number of messages replied to or forwarded from the
device.

This value is a subset of the messages that were sent from the device.

Attachment requests This column specifies the number of attachment requests that were sent from the
device.

OTAFM TO This column specifies the number of wireless email reconciliation requests that were
sent to the device.

OTAFM FROM This column specifies the number of wireless email reconciliation requests that were
sent from the device.

CICAL TO (in bytes) This column specifies the number of bytes of wireless calendar data that were sent to
the device.

CICAL FROM (in bytes) This column specifies the number of bytes of wireless calendar data that were sent
from the device.

CMIME TO (in bytes) This column specifies the number of CMIME bytes that were sent to the device.

CMIME FROM (in bytes) This column specifies the number of CMIME bytes that were sent from the device.

MDS TO (in bytes) This column specifies the number of bytes of data that were sent to the device through
the BlackBerry MDS Connection Service.

You can find this statistic in the log file for the BlackBerry Dispatcher.
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Column Description

MDS FROM (in bytes) This column specifies the number of bytes of data that were sent from the device
through the BlackBerry MDS Connection Service.

You can find this statistic in the log file for the BlackBerry Dispatcher (DISP).

OTASYNC TO (in bytes) This column specifies the number of bytes of organizer data synchronization
information that were sent over the wireless network to the device.

You can find this statistic in the log file for the BlackBerry Dispatcher (DISP).

OTASYNC FROM (in bytes) This column specifies the number of bytes of organizer data synchronization
information that were sent over the wireless network from the device.

You can find this statistic in the log file for the BlackBerry Dispatcher (DISP).
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BlackBerry MAPI and CDO
Error Monitoring Tool
You can use the BlackBerry MAPI and CDO Error Monitoring Tool (MapiCdoErrors.exe) to troubleshoot MAPI and CDO
issues for the BlackBerry Enterprise Server for Microsoft Exchange.

The tool reports the events that are associated with BlackBerry Enterprise Server startup, versions, and user account
settings.

The tool reports the results of a query in a file that is named MapiCdoErrors_<mmdd>.<#>.csv, where <mmdd> is the
month and day, and <#> is the number of BlackBerry Messaging Agent restarts that the tool finds in the log files.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry MAPI and CDO Error
Monitoring Tool using the BlackBerry
Enterprise Server Log Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent log files to the computer that hosts the BlackBerry MAPI and CDO Error
Monitoring Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click MAPI and CDO Error Monitoring.

3. Click Open Tool.

4. In the User Selection section, perform one of the following actions:

• To run the tool for all user accounts, click All.

14
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• To run the tool for a specific user account, click Email Address. Type the SMTP email address of the user
account.

• To run the tool for user accounts that are listed in an email address file, click Email Address File. Beside the
Email Address File field, click the browse button. Navigate to the email address file.

5. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry Messaging
Agent (MAGT) log files.

6. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output
files.

7. If necessary, perform any of the following actions:

• To create one output file for each user account, select the One output file for each user check box.

• To create the output file in .txt file format, select the .txt output file format check box.

• To override the default events and process only the events that you specify, select the Override Default Events
check box.

• To display the list of default events monitored, select the List Default Events check box.

8. To specify the events that the tool monitors using an input file, click the browse button beside the Events File field.
Navigate to the input file.
The input file overrides the list of default events that the tool monitors. The tool does not check for duplicates or valid
events, but it verifies that the events are in numerical order.

9. To specify the events that the tool monitors, in the Events field, type the events. Use commas (,) to separate multiple
events.
By default, the tool monitors all events that are associated with BlackBerry Enterprise Server startup, versions, and
user account settings.

10. Click Run.

11. To view the results, click the Console tab.

Run the BlackBerry MAPI and CDO Error
Monitoring Tool from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent log files to the computer that hosts the BlackBerry MAPI and CDO Error
Monitoring Tool and BlackBerry Enterprise Server Log Analysis Tool.
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1. On the computer that hosts the BlackBerry MAPI and CDO Error Monitoring Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry MAPI and CDO Error Monitoring Tool.

2. In the command prompt window, type MapiCdoErrors and the following parameters:

Parameter Description

-p E This parameter specifies that you use the tool in a Microsoft Exchange
environment.

-u <SMTP_address>

-u all

This parameter specifies the SMTP email address of the user account that
you want to monitor.

To monitor all user accounts, type -u all.

3. Type any of the following optional parameters:

Parameter Description

-input <filename.txt> This parameter specifies the name of the file that contains the SMTP email
addresses of the user accounts that you want to monitor.

Use a carriage return to separate each entry in the file.

This parameter overrides the value that is specified with the -u parameter.

-events <“event_ids”> This parameter specifies the events that the tool monitors. You use commas
to separate the events in the list.

By default, the tool monitors all events that are associated with BlackBerry
Enterprise Server startup, versions, and user account settings.

-override This parameter is used with the -events parameter to specify that the tool
ignores the default events list and processes only specified events.

-eventsfile <filename.txt> This parameter specifies the name of the input file that contains the events
that the tool monitors for.

This parameter overrides the default list of events that the tool monitors. The
tool does not check for duplicates or valid events, but it verifies that the
events are in numerical order.

-output user

-output all

This parameter specifies how to organize the data in output files.

To create one file for each user account, type -output user.

To create one file for all user accounts, type -output all. This is the default
value.

-raw This parameter specifies that the tool creates an output .txt file instead of
a .csv file.
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Parameter Description

-list This parameter specifies that the tool displays the default list of monitored
events on the screen.

-L <path> This parameter specifies the location of the debug log files that you want to
query if the files are not in the same folder as the tool.

-OL <path> This parameter specifies the folder where the tool writes the output files.

-agent <acronym> This parameter specifies the abbreviation for the BlackBerry Messaging
Agent log files. If you do not specify an abbreviation, the tool uses MAGT.

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information
on the screen.

Example: Finding two events that might create MAPI and CDO errors

MapiCdoErrors -p E -input users.txt -L C:\logs -output all -events “20018,20055” -override -raw

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type MapiCdoErrors -? or MapiCdoErrors -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Results of a BlackBerry MAPI and CDO
Error Monitoring Tool query
Column Description

Server This column specifies the messaging server that hosts the user account.

Email Address This column specifies the SMTP email address of the BlackBerry device user.
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Column Description

DeviceID This column specifies the PIN of the device. If the PIN has changed, the last PIN
displays.

SRPid This column specifies the SRP identifier for the BlackBerry Enterprise Server instance
that hosts the user account.

Mailbox This column specifies the mailbox name of the device user.

Error This column specifies the log line for the captured error.

Administration Guide BlackBerry MAPI and CDO Error Monitoring Tool

102



BlackBerry MDS Services Data
Monitoring Tool
You can use the BlackBerry MDS Services Data Monitoring Tool (MDSPushvsPull.exe) to determine whether the
BlackBerry MDS Connection Service is processing more data by pushing applications to BlackBerry devices or by devices
pulling data.

The tool displays the result of the query in a file that is named MDSPushvsPull_<mmdd>.<#>.csv, where <mmdd> is the
month and day, and <#> is the number of BlackBerry MDS Connection Service restarts that the tool finds in the log files.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry MDS Services Data
Monitoring Tool using the BlackBerry
Enterprise Server Log Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry MDS Connection Service log files to the computer that hosts the BlackBerry MDS Services Data
Monitoring Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click MDS Services Data Monitoring.

3. Click Open Tool.

4. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry MDS
Connection Service (MDAT) log files.

15
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5. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output
files.

6. Select the types of events that you want the tool to monitor.

7. Click Run.

8. To view the results, click the Console tab.

Run the BlackBerry MDS Services Data
Monitoring Tool from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry MDS Connection Service log files to the computer that hosts the BlackBerry MDS Services Data
Monitoring Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry MDS Services Data Monitoring Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry MDS Services Data Monitoring Tool.

2. In the command prompt window, type MDSPushvsPull and the following parameters:

Parameter Description

-p E[xchange]

-p D[omino]

-p G[roupWise]

This parameter specifies the messaging platform.

3. Type any of the following optional parameters:

Parameter Description

-type pull

-type push

This parameter specifies whether the tool monitors push or pull events. If
you do not specify a type, the tool provides results for both types.

-L <path> This parameter specifies the location of the debug log files that you want to
query if the files are not in the same folder as the tool. If the path contains
spaces, enclose the path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If
the path contains spaces, enclose the path in quotation marks ( " " ).
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Parameter Description

-MDS <acronym> This parameter specifies the abbreviation for the BlackBerry MDS
Connection Service log files. If you do not specify an abbreviation, the tool
uses MDAT.

-debug <filename.txt> This parameter specifies that the BlackBerry MDS Services Data Monitoring
Tool creates a more detailed output file for debugging purposes, and it
specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information
on the screen.

Example: Obtaining information about events that are pushed to BlackBerry devices

MDSPushvsPull -p E -type push -L C:\BRK

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type MDSPushvsPull -? or MDSPushvsPull -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Results of a BlackBerry MDS Services Data
Monitoring Tool query
Column Description

Type This column specifies the type of request. The options are push or pull.

Source This column specifies one of the following sources for the request:

• Pull: PIN of the BlackBerry device that made the request

• Push: BlackBerry MDS Connection Service instance that made the request

Destination This column specifies one of the following destinations for the request:
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Column Description

• Pull: web site that the device requests

• Push: device or email address that is associated with the user account

Date This column specifies the date that the request was made.

Time This column specifies the time that the request was made.

Port This column specifies the port number that the request was made over.

Size This column specifies the size of the request, in bytes.
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BlackBerry Message Flow
Reporting Tool
You can use the BlackBerry Message Flow Reporting Tool (Messageflow.exe) to track the flow of messages through the
BlackBerry Enterprise Server. The tool can help you to troubleshoot message flow issues and can provide statistical data on
message flow trends.

The tool reports the results of a query in a file that is named MessageFlow_<date>.<#>.csv, unless you use the -multiday
parameter.

The date uses either the format <yyyymmdd or the format <mmdd>. The <#> is the number of BlackBerry Messaging
Agent restarts that the tool finds in the log files.

If you query a single user account or multiple user accounts using the -input parameter, the tool creates an individual file
for each user account that you queried.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry Message Flow
Reporting Tool using the BlackBerry
Enterprise Server Log Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the log files for the BlackBerry Messaging Agent, BlackBerry Dispatcher, and BlackBerry Router to the computer
that hosts the BlackBerry Message Flow Reporting Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click Message Flow Reporting.

3. Click Open Tool.
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4. In the User Selection section, perform one of the following actions:

• To run the tool for all user accounts, click All.

• To run the tool for a specific user account, click Email Address. Type the SMTP email address of the user
account.

• To run the tool for user accounts that are listed in an email address file, click Email Address File. Beside the
Email Address File field, click the browse button. Navigate to the email address file.

5. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry Messaging
Agent (MAGT) log files, BlackBerry Dispatcher (DISP) log files, and BlackBerry Router (ROUT) log files.

6. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output
files.

7. To create one output file for each user account, select the One output file for each user check box.

8. If necessary, select the Start Date option. Click a date in the drop-down list.

9. If necessary, select the End Date option. Click a date in the drop-down list.

10. Click Run.

11. To view the results, click the Console tab.

Run the BlackBerry Message Flow
Reporting Tool from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the log files for the BlackBerry Messaging Agent, BlackBerry Dispatcher, and BlackBerry Router to the computer
that hosts the BlackBerry Message Flow Reporting Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Message Flow Reporting Tool, on the taskbar, click Start > All Programs
> BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Message Flow Reporting Tool.

2. In the command prompt window, type MessageFlow and the following parameters:

Parameter Description

-p E[xchange]

-p D[omino]

-p G[roupWise]

This parameter specifies the messaging platform.
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Parameter Description

-u <account>

-u all

This parameter specifies the user account.

To query all user accounts in the log files, type -u all.

To query a specific user account, type the user name in one of the following
formats:

• Microsoft Exchange: SMTP email address (for example,
jpalmer@<domain>.net)

• IBM Lotus Domino: canonical name (for example, Julie Palmer/Organization)

• Novell GroupWise: first name and last name (for example, Julie Palmer)

3. Type any of the following optional parameters:

Parameter Description

-input <filename.txt> This parameter specifies the name of the file that contains the list of user
accounts that you want to monitor.

Use the appropriate format as described for the -u parameter.

Use a carriage return to separate each entry in the file.

This parameter overrides the value that is specified with the -u parameter.

-multiday <start_date>-
<end_date>

This parameter specifies the dates that the tool checks log files for.

To check message flow across multiple days, type a date value to specify the
subfolders in the log file that the tool checks. The tool checks subfolders from the
current date.

Use the format <yyyymmdd>-<yyyymmdd > for a date range or <yyyymmdd> for a
single date that is used as the start date.

When you use this parameter with two dates, the tool creates an output file that is
named MessageFlow_<user_name>_<start_date>-<end_date>.<#>.csv.

When you use this parameter with one date, the tool uses the date as the start
date and creates an output file that is named
MessageFlowEnding_<end_date>.<#>.csv, where the <end_date> is the last date
that was logged.

If you do not type a date value, the tool cannot check the subfolders.

-output user

-output all

This parameter specifies how to organize the data in output files.

To create one file for each user account, type -output user.

To create one file for all user accounts, type -output all. This is the default value.
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Parameter Description

-L <path> This parameter specifies the location of the debug log files that you want to query
if they are not in the same folder as the tool. If the path contains spaces, enclose
the path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If the
path contains spaces, enclose the path in quotation marks ( " " ).

-agent <abbreviation> This parameter specifies the abbreviation for the BlackBerry Messaging Agent log
files. If you do not specify an abbreviation, the BlackBerry Message Flow
Reporting Tool uses MAGT.

-dispatcher <abbreviation>] This parameter specifies the abbreviation for the BlackBerry Dispatcher log files.
If you do not specify a name, the tool uses DISP.

-router <abbreviation> This parameter specifies the abbreviation for the BlackBerry Router log files. If you
do not specify a name, the tool uses ROUT.

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information on
the screen.

Example: Querying all user accounts in a Microsoft Exchange environment using the log files that are
in a specified location

MessageFlow -p E -u all -L C:\logs

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type MessageFlow -? or MessageFlow -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .
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Results of a BlackBerry Message Flow
Reporting Tool query
Column Description

Server This column specifies the messaging server that hosts the user accounts.

This column applies to the BlackBerry Enterprise Server for Microsoft Exchange and
the BlackBerry Enterprise Server for IBM Lotus Domino only.

User This column specifies the name of the user account in one of the following formats:

• Microsoft Exchange: SMTP email address

• IBM Lotus Domino: canonical name

• Novell GroupWise: first name and last name

EntryID/NoteID This column specifies the identifier that tracks the message from its initial stages.

RefID This column specifies the unique identifier that is assigned to each message or
calendar appointment and that the BlackBerry Enterprise Server or the BlackBerry
device uses for tracking.

AGT Tag This column specifies the identifier that tracks the message between the BlackBerry
Messaging Agent and the BlackBerry Dispatcher.

The identifier is assigned by the BlackBerry Messaging Agent.

Disp Tag This column specifies the identifier that tracks the message from the BlackBerry
Dispatcher to the wireless network.

The identifer is assigned by the BlackBerry Dispatcher.

Total Time The total time, in minutes, between the time that the messaging server receives the
message and the time that the BlackBerry Enterprise Server completes the
processing.

The time displays as a negative value when the device sends a message.

Server Time This column specifies the amount of time that the BlackBerry Enterprise Server takes
to process a message and deliver it to the device.
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Column Description

Posted This column specifies the time that the messaging server posts the message to the
mail store.

Mail Del This column specifies the time that the messaging server indicates that the message
is delivered.

Queue 1 This column specifies the time that the BlackBerry Enterprise Server first recognizes
the message.

Queue out This column specifies the time that the message enters the second queue stage.

Sending This column specifies the time that the BlackBerry Messaging Agent sends the
message to the BlackBerry Dispatcher.

Disp Recv This column specifies the time that the BlackBerry Dispatcher receives the message.

Router Recv This column specifies the time that the BlackBerry Router receives the message.

Router Del This column specifies the time that the BlackBerry Router sends the message.

Disp Del This column specifies the time that the BlackBerry Dispatcher receives the delivery
notification message.

Agt Status This column specifies the status of whether the BlackBerry Messaging Agent receives
the delivery notification message.

Status time This column specifies the time of the message delivery.

Retry CNT This column specifies the number of times that the BlackBerry Enterprise Server tries
to send the message.

Discovery In a BlackBerry Enterprise Server for Microsoft Exchange environment, this column
specifies how the BlackBerry Enterprise Server discovers the message.

Path This column specifies the whether the message is sent over the wireless network or
over a serial connection.

Pending This column specifies the number of pending messages.
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BlackBerry Thread Analyzer
Tool
You can use the BlackBerry Thread Analyzer Tool (NoResponseCheck.exe) to monitor how well a BlackBerry Enterprise
Server instance is running, based on the number of nonresponsive threads.

If a BlackBerry Enterprise Server instance appears to have a number of nonresponsive threads, you can run the tool to
determine the status of the threads. The tool reports whether a thread is a false positive. A false positive thread is one that
reports as nonresponsive but continues to do work, performing a single task for a long time.

You can use the tool as an early indicator of the health of a BlackBerry Enterprise Server instance and its threads. Based on
the information that the tool provides, you can then explore the log files further.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry Thread Analyzer Tool
using the BlackBerry Enterprise Server Log
Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy any log files for the BlackBerry Enterprise Server components, except the log file for the BlackBerry MDS
Connection Service, to the computer that hosts the BlackBerry Thread Analyzer Tool and BlackBerry Enterprise Server
Log Analysis Tool

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click Thread Analyzer.

3. Click Open Tool.
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4. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the log files.

5. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output
files.

6. To configure the BlackBerry Thread Analyzer Tool to create a detailed output file for debugging purposes, in the
Debug Log Identifier field, type a name for the debug output file.

7. To prevent the BlackBerry Thread Analyzer Tool from checking for false positives, select the Skip False Positive
Checking check box.

8. Click Run.

9. To view the results, click the Console tab.

Run the BlackBerry Thread Analyzer Tool
from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy any log files for the BlackBerry Enterprise Server components, except the log file for the BlackBerry MDS
Connection Service, to the computer that hosts the BlackBerry Thread Analyzer Tool and BlackBerry Enterprise Server
Log Analysis Tool

1. On the computer that hosts the BlackBerry Thread Analyzer Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Thread Analyzer Tool.

2. In the command prompt window, type NoResponseCheck and the following parameter:

Parameter Description

-p E[xchange]

-p D[omino]

-p G[roupWise]

This parameter specifies the messaging platform.

3. Type any of the following optional parameters:

Parameter Description

-NoFP This parameter prevents the tool from checking for false positives.
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Parameter Description

-type <abbreviation> You can use this parameter to limit the tool to checking the log files for a specific
BlackBerry Enterprise Server component. Specify the abbreviation for the log files
that you want to analyze. For example, type MAGT to analyze the log files for the
BlackBerry Messaging Agent only.

For more information about the abbreviations used for different components, visit 
www.blackberry.com/go/serverdocs to read the BlackBerry Enterprise Server
Administration Guide.

-MDS <abbreviation> This parameter specifies the abbreviation for the BlackBerry MDS Connection
Service log files. If you do not specify an abbreviation, the tool uses MDAT.

You require this parameter to bypass any reference to the BlackBerry MDS
Connection Service log files in the log files for other BlackBerry Enterprise Server
components. If the tool finds a reference to the BlackBerry MDS Connection
Service log files, the tool stops running.

-L <path> This parameter specifies the location of the log files that you want to analyze if the
files are not in the same folder as the tool. If the path contains spaces, enclose the
path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If the
path contains spaces, enclose the path in quotation marks ( " " ).

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information on
the screen.

Example: Producing detailed output for the BlackBerry Enterprise Server for IBM Lotus Domino log
files

NoResponseCheck -p D -debug Detailed.txt -L C:\BRK\logs

Example: Analyzing the log files for the BlackBerry Messaging Agent only without checking for false
positives

NoResponseCheck -p E -NoFP -type MAGT -L C:\BRK\logs

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type NoResponseCheck -? or NoResponseCheck -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
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in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Results of a BlackBerry Thread Analyzer
Tool query
Column Description

ThreadID This column specifies the ID of a reporting thread.

Start Time This column specifies the time that the failure started.

End Time This column specifies the time that the failure ended.

If the field is empty, the thread did not recover.

Total Time This column specifies the total time of the failure, in minutes.

If the field is empty, the thread did not recover.

Wait Count This column specifies an increasing number that equals x multiplied by the health
check interval for the BlackBerry Enterprise Server, which is usually 10 minutes.

For example, if the wait count equals 2, the thread has been nonresponsive or slow for
20 minutes.

False Positive This column specifies the whether the tool reported a false positive (a slow thread
instead of a nonresponsive thread).

Activity This column specifies the last activity before the failure, the user account that is
associated with the failure, and the name of the BlackBerry Enterprise Server
instance.

File This column specifies the file name that contains the thread that is reported as
nonresponsive.

Last Activity This column specifies the entry for the failure in the log file.
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BlackBerry Message Pending
Delivery Tool
You can use the BlackBerry Message Pending Delivery Tool (Pending.exe) to detect an increase in the number of
messages in the mail queue.

The tool displays the results of a query in a file that is named Pending_<mmdd>.<#>.csv, where <mmdd> is the month and
day, and <#> is the number of BlackBerry Messaging Agent restarts that the tool detects in the log files.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry Message Pending
Delivery Tool using the BlackBerry
Enterprise Server Log Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent log files to the computer that hosts the BlackBerry Message Pending Delivery
Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click Message Pending Delivery.

3. Click Open Tool.

4. In the User Selection section, perform one of the following actions:

• To run the tool for all user accounts, click All.

• To run the tool for a specific user account, click Email Address. Type the SMTP email address of the user
account.

18
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• To run the tool for user accounts that are listed in an email address file, click Email Address File. Beside the
Email Address File field, click the browse button. Navigate to the email address file.

5. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry Messaging
Agent (MAGT) log files.

6. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output
files.

7. To create one output file for each user account, select the One output file for each user check box.

8. If necessary, in the Minimum Pending Messages field, type the minimum number of pending messages that you want
the tool to monitor.
The default value is 0.

9. To configure the tool to display the single highest pending count for each user account that is greater than the
minimum pending messages count that you specify, select the Show highest pending count check box.

10. If necessary, select the Start Time option. Specify a start time for the query.

11. If necessary, select the Stop Time option. Specify a stop time for the query.

12. Click Run.

13. To view the results, click the Console tab.

Run the BlackBerry Message Pending
Delivery Tool from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent log files to the computer that hosts the BlackBerry Message Pending Delivery
Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Message Pending Delivery Tool, on the taskbar, click Start > All Programs
> BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Message Pending Delivery Tool.

2. In the command prompt window, type Pending and the following parameters:

Parameter Description

-p E[xchange]

-p D[omino]

This parameter specifies the messaging platform.
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Parameter Description

-p G[roupWise]

-u <account>

-u all

This parameter specifies the user account.

To query all user accounts in the log files, type -u all.

To query a specific user account, type the user name in one of the following
formats:

• Microsoft Exchange: SMTP email address (for example,
jpalmer@<domain>.net)

• IBM Lotus Domino: canonical name (for example, Julie Palmer/Organization)

• Novell GroupWise: first name and last name (for example, Julie Palmer)

3. Type any of the following optional parameters:

Parameter Description

-input <filename.txt> This parameter specifies the name of the file that contains the list of user
accounts that you want to monitor.

Use the appropriate format as described for the -u parameter.

Use a carriage return to separate each entry in the file.

This parameter overrides the value that is specified with the -u parameter.

-pending <#> This parameter specifies the minimum number (#) of pending messages that the
tool tracks.

By default, the value is 0.

-onlyhigh This parameter specifies that the tool prints the single highest pending count for a
user account that is greater than the count you specify for -pending.

-output user

-output all

This parameter specifies how to organize the data in output files.

To create one file for each user account, type -output user.

To create one file for all user accounts, type -output all. This is the default value.

-time <start time>

-time <start-stop time>

This parameter specifies the starting time for the query or the interval for the
query.

For example, to process all log entries that are created after 16:00:00, type
pending -p E -u all -time 16:00:00.

To process log entries that are created between 16:00:00 and 17:00:00, type
pending -p E -u all -time 16:00:00-17:00:00.
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Parameter Description

-agent <abbreviation> This parameter specifies the abbreviation for the BlackBerry Messaging Agent log
files. If you do not specify a name, the tool uses MAGT.

-L <path> This parameter specifies the location of the debug log files that you want to query
if they are not in the same folder as the tool. If the path contains spaces, enclose
the path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If the
path contains spaces, enclose the path in quotation marks ( " " ).

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information on
the screen.

Example: Querying all user accounts for more than one pending message, and printing out
information for the user account with the highest pending count

Pending -p E -u all -output all -pending 1 -onlyhigh

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type Pending -? or Pending -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Results of a BlackBerry Message Pending
Delivery Tool query
Column Description

Server This columns specifies the messaging server that hosts the user account.
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Column Description

Common Name This columns specifies the canonical name of the user account (for IBM Lotus Domino
environments only).

Email Address This columns specifies the SMTP email address of the user account (for Microsoft
Exchange environments only).

DeviceID This columns specifies the PIN of the BlackBerry device.

If the PIN for the BlackBerry device changed, this is the last PIN.

SRPid This columns specifies the SRP identifier of the BlackBerry Enterprise Server.

Pending This columns specifies the number of pending messages that were detected.

Time This columns specifies the time that the pending count was detected.

High An asterisk ( * ) indicates that the value is the highest pending count for a user
account.
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BlackBerry Usage Monitoring
Tool
You can use the BlackBerry Usage Monitoring Tool (OutofCoverage.exe) to identify user accounts that have not sent or
received data packets for a period of time that you specify.

The tool displays the results of a query in a file that is named OutofCoverage_<mmdd>.<#>.csv, where <mmdd> is the
month and day, and <#> is the number of BlackBerry Dispatcher restarts that the tool finds in the log files.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry Usage Monitoring Tool
using the BlackBerry Enterprise Server Log
Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Dispatcher (DISP) log files to the computer that hosts the BlackBerry Usage Monitoring Tool and
BlackBerry Enterprise Server Log Analysis Tool. If you want the tool to process usage information over multiple days,
you must copy the log files for those days to the same folder.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click Usage Monitoring.

3. Click Open Tool.

4. In the User Selection section, perform one of the following actions:

• To run the tool for all user accounts, click All.

19

Administration Guide BlackBerry Usage Monitoring Tool

122



• To run the tool for a specific user account, click Email Address. Type the SMTP email address of the user
account.

• To run the tool for user accounts that are listed in an email address file, click Email Address File. Beside the
Email Address File field, click the browse button. Navigate to the email address file.

5. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry Dispatcher
(DISP) log files.

6. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output
files.

7. To create one output file for each user account, select the One output file for each user check box.

8. To specify how often the tool checks for gaps in BlackBerry device usage, select the Out of Coverage check box. In
the drop-down list, click the required number of minutes.

9. Click Run.

10. To view the results, click the Console tab.

Run the BlackBerry Usage Monitoring Tool
from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Dispatcher (DISP) log files to the computer that hosts the BlackBerry Usage Monitoring Tool and
BlackBerry Enterprise Server Log Analysis Tool. If you want the tool to process usage information over multiple days,
you must copy the log files for those days to the same folder.

1. On the computer that hosts the BlackBerry Usage Monitoring Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry Usage Monitoring Tool.

2. In the command prompt window, type OutofCoverage and the following parameters:

Parameter Description

-p E[xchange]

-p D[omino]

-p G[roupWise]

This parameter specifies the messaging platform.

-u <account> This parameter specifies the user account.
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Parameter Description

-u all To query all user accounts in the log files, type -u all.

To query a specific user account, type the user name in one of the following
formats:

• Microsoft Exchange: SMTP email address (for example,
jpalmer@<domain>.net)

• IBM Lotus Domino: canonical name (for example, Julie Palmer/
Organization)

• Novell GroupWise: first name and last name (for example, Julie Palmer)

-t <minutes> This parameter specifies the frequency, in minutes, that the tool checks for
gaps (between 10 and 1440 minutes).

3. Type any of the following optional parameters:

Parameter Description

-input <filename.txt> This parameter specifies the name of the file that contains the list of user
accounts that you want to monitor.

Use the appropriate format as described for the -u parameter.

Use a carriage return to separate each entry in the file.

This parameter overrides the value that is specified with the -u parameter.

-output user

-output all

This parameter specifies how to organize the data in output files.

To create one file for each user account, type -output user.

To create one file for all user accounts, type -output all. This is the default
value.

-dispatcher <abbreviation> This parameter specifies the abbreviation for the BlackBerry Dispatcher log
files.

If you do not specify a name, the tool uses DISP.

-L <path> This parameter specifies the location of the debug log files that you want to
query if they are not in the same folder as the tool. If the path contains
spaces, enclose the path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If
the path contains spaces, enclose the path in quotation marks ( " " ).

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debug file.
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Parameter Description

If you do not specify a file name, the tool displays the debug information on
the screen.

Example: Checking in specified log files whether a user account has not sent or received data packets
for 25 minutes

OutofCoverage -p E -u jpalmer@test.rim.net -t 25 -L C:\BRK\logs

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type OutofCoverage -? or OutofCoverage -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Results of a BlackBerry Usage Monitoring
Tool query
Column Description

Email address This column specifies the SMTP email address of the BlackBerry device user.

This column applies to the BlackBerry Enterprise Server for Microsoft Exchange and
the BlackBerry Enterprise Server for IBM Lotus Domino only.

Disp name This column specifies the display name of the user account.

DeviceID This column specifies the PIN of the device.

SRPid This column specifies the SRP identifier for the BlackBerry Enterprise Server.

Length This column specifies the length of the outage, in minutes (0.5 equals 30 seconds).

Start This column specifies the start time for the period of time that the device is outside of
a wireless coverage area.
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Column Description

Stop This column specifies the stop time for the period of time that the device is outside of
a wireless coverage area.

Multi-day This column appears only if you process log files from multiple days or from multiple
files from the same day.

An asterisk ( * ) indicates a multi-day gap.
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BlackBerry User Activity
Reporting Tool
You can use the BlackBerry User Activity Reporting Tool (AvailIndex.exe) to check statistics on rescan events for the
BlackBerry Enterprise Server for Microsoft Exchange.

The tool reports the results of a query in a file that is named AvailIndex_<mmdd>.<#>.csv, where <mmdd> is the month
and day, and <#> is the number of BlackBerry Messaging Agent restarts that the tool finds in the log file.

Related information
BlackBerry Enterprise Server Log Analysis Tool, 77

Run the BlackBerry User Activity Reporting
Tool using the BlackBerry Enterprise Server
Log Analysis Tool
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent (MAGT) log files to the computer that hosts the BlackBerry User Activity
Reporting Tool and BlackBerry Enterprise Server Log Analysis Tool.

1. On the computer that hosts the BlackBerry Enterprise Server Log Analysis Tool, on the taskbar, click Start > All
Programs > BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting
Tools > BlackBerry Enterprise Server Log Analysis Tool.

2. In the BlackBerry Enterprise Server Log Analysis Tool, on the Tools menu, click User Activity Reporting.

3. Click Open Tool.

4. Beside the Input Folder field, click the browse button. Navigate to the folder that contains the BlackBerry Messaging
Agent (MAGT) log files.

5. Beside the Output Folder field, click the browse button. Navigate to the folder where you want to save the output
files.
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6. Click Run.

7. To view the results, click the Console tab.

Run the BlackBerry User Activity Reporting
Tool from the command prompt
Before you begin:
• See Prepare to run the log analysis tools.

• Copy the BlackBerry Messaging Agent log files to the computer that hosts the BlackBerry User Activity Reporting Tool.

1. On the computer that hosts the BlackBerry User Activity Reporting Tool, on the taskbar, click Start > All Programs >
BlackBerry Enterprise Server Resource Kit > BlackBerry Analysis Monitoring and Troubleshooting Tools >
BlackBerry User Activity Reporting Tool.

2. In the command prompt window, type AvailIndex.

Parameter Description

-p E This parameter specifies that you are using the tool in a Microsoft Exchange
environment.

3. Type any of the following optional parameters:

Parameter Description

-agent <abbreviation> This parameter specifies the abbreviation for the BlackBerry Messaging Agent log
files. If you do not specify a name, the tool uses MAGT.

-L <path> This parameter specifies the location of the debug log files that you want to query
if they are not in the same folder as the tool. If the path contains spaces, enclose
the path in quotation marks ( " " ).

-OL <path> This parameter specifies the folder where the tool writes the output files. If the
path contains spaces, enclose the path in quotation marks ( " " ).

-debug <filename.txt> This parameter specifies that the tool creates a more detailed output file for
debugging purposes, and it specifies the name of the debugging file.

If you do not specify a file name, the tool displays the debugging information on
the screen.
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Example: Producing a detailed output file for the events in a specified log file

AvailIndex -p E -debug Details.txt -L C:\BRK\logs

After you finish:
• If you want to view the help information for the tool, including the list of available parameters, in the command window,

type AvailIndex -? or AvailIndex -help.

• If you configured the tool to use a UAC-compliant file path, the output file is located at <drive>:\Users\<user_name>
\AppData\Roaming\Research In Motion\AMT\ or <drive>:\Documents and Settings\user_name\Application Data
\Research In Motion\AMT\ . If you did not configure the tool to use a UAC-compliant file path, the output file is located
in a file path relative to the current working directory, for example, <drive>:\Program Files\Research In Motion
\BlackBerry Enterprise Server Resource Kit \BlackBerry AMT Tools .

Results of a BlackBerry User Activity
Reporting Tool query
Column Description

Server This column specifies the Microsoft Exchange server that hosts the user account
that is associated with the BlackBerry device.

Email Address This column specifies the SMTP email address of the BlackBerry device user
account.

Availability This column specifies the percentage of the total busy time divided by the total
log time of the device.

A higher percentage is a better result than a lower percentage.

Busy Time This column specifies the total time for all of the rescan events.

Outages (>15min) This column specifies the number of times that the BlackBerry Enterprise Server
performed a rescan that took longer than 15 minutes.

Longest Outage This column specifies the count, in seconds, for the longest rescan over 15
minutes.

Operation Count This column specifies the number of rescan events of all types that the
BlackBerry Enterprise Server performs.
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Column Description

Most Frequent Event This column specifies the most frequent type of rescan, and the number of
times it occurs.

Longest Event This column specifies the type of rescan with the longest time, and the duration
of the rescan in seconds.

MESSAGE_RESCAN count This column specifies the number of times that the MESSAGE_RESCAN event
occurs.

MESSAGE_RESCAN Total in seconds This column specifies the total time of MESSAGE_RESCAN events, in seconds.

CALENDAR_RESCAN count This column specifies the number of times that the CALENDAR_RESCAN event
occurs.

CALENDAR_RESCAN Total in seconds This column specifies the total time of CALENDAR_RESCAN events, in seconds.

MESSAGE_DELETED_RESCAN count This column specifies the number of times that the
MESSAGE_DELETED_RESCAN event occurs.

MESSAGE_DELETED_RESCAN Total in
seconds

This column specifies the total time of MESSAGE_DELETED_RESCAN events, in
seconds.

MESSAGE_MOVED_RESCAN count This column specifies the number of times that the
MESSAGE_MOVED_RESCAN event occurs.

MESSAGE_MOVED_RESCAN Total in
seconds

This column specifies the total time of MESSAGE_MOVED_RESCAN events, in
seconds.

MESSAGE_STATUS_RESCAN count This column specifies the number of times that the
MESSAGE_STATUS_RESCAN event occurs.

MESSAGE_STATUS_RESCAN Total in
seconds

This column specifies the total time of MESSAGE_STATUS_RESCAN events, in
seconds.

RELOAD_FOLDERS count This column specifies the number of times that the RELOAD_FOLDERS event
occurs.

RELOAD_FOLDERS Total in seconds This column specifies the total time of RELOAD_FOLDERS events, in seconds.

GENERATE_FOLDER_LIST count This column specifies the number of times that the GENERATE_FOLDER_LIST
event occurs.

GENERATE_FOLDER_LIST Total in
seconds

This column specifies the total time of GENERATE_FOLDER_LIST events, in
seconds.
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Column Description

PIM_ADDRESSBOOK_RESCAN count This column specifies the number of times that the
PIM_ADDRESSBOOK_RESCAN event occurs.

PIM_ADDRESSBOOK_RESCAN Total
in seconds

This column specifies the total time of PIM_ADDRESSBOOK_RESCAN events, in
seconds.

PIM_MEMO_RESCAN count This column specifies the number of times that the PIM_MEMO_RESCAN event
occurs.

PIM_MEMO_RESCAN Total in seconds This column specifies the total time of PIM_MEMO_RESCAN events, in seconds.

PIM_TASK_RESCAN count This column specifies the number of times that the PIM_TASK_RESCAN event
occurs.

PIM_TASK_RESCAN Total in seconds This column specifies the total time of PIM_TASK_RESCAN events, in seconds.

CALENDAR_SLOWSYNC count This column specifies the number of times that the CALENDAR_SLOWSYNC
event occurs.

CALENDAR_SLOWSYNC Total in
seconds

This column specifies the total time of CALENDAR_SLOWSYNC events, in
seconds.

EMAIL_RECONCILIATION count This column specifies the number of times that the EMAIL_RECONCILIATION
event occurs.

EMAIL_RECONCILIATION Total in
seconds

This column specifies the total time of EMAIL_RECONCILIATION events, in
seconds.

Log total in seconds This column specifies the total number of seconds between the first and the last
message in the log file.
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Port information for the
BlackBerry Enterprise Server
Resource Kit tools

Port information for tools that connect to
the BlackBerry Configuration Database
Tool Connection type Default port number

BlackBerry Application Reporting Tool TCP 1433

BlackBerry Domain Administration History Reporting Tool TCP 1433

BlackBerry Enterprise Transporter TCP 1433

BlackBerry IT Policy Import and Export Tool TCP 1433

BlackBerry Message Receipt Confirmation Tool TCP 1433
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Port information for tools that connect to
the BlackBerry Administration Service,
BlackBerry Administration API, and
BlackBerry Web Services
Tool Connection type Default port number

BlackBerry Enterprise Server User Administration Tool TCP • BlackBerry Enterprise
Server: 443

• BlackBerry Enterprise
Server Express: 8443

BlackBerry Enterprise Transporter TCP • BlackBerry Enterprise
Server: 443

• BlackBerry Enterprise
Server Express: 8443

BlackBerry Directory Sync Tool TCP • BlackBerry Enterprise
Server: 443

• BlackBerry Enterprise
Server Express: 8443
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Port information for the BlackBerry
Message Receipt Confirmation Tool
Action Connection type Default port number

Sends messages MAPI 125

Port information for the BlackBerry System
Log Monitoring and Reporting Tool
Action Connection type Default port number

Listens for packets UDP 514

Sends messages over SMTP TCP 25
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Glossary

BlackBerry Domain A BlackBerry Domain consists of the BlackBerry Configuration Database with its users and any
BlackBerry Enterprise Server instances that connect to it.

BlackBerry MDS BlackBerry Mobile Data System

CDO Collaboration Data Object

CMIME Compressed Multipurpose Internet Mail Extension

.csv comma-separated values

IBM DB2 UDB IBM DB2 Universal Database

IP Internet Protocol

IP address An Internet Protocol (IP) address is an identification number that each computer or mobile
device uses when it sends or receives information over a network, such as the Internet. This
identification number identifies the specific computer or mobile device on the network.

MAPI Messaging Application Programming Interface

MDAC Microsoft® Data Access Components

MDM domain An MDM domain consists of a BlackBerry Mobile Fusion database and any BlackBerry Mobile
Fusion services or components that are associated with it. An MDM domain can refer to any of
the following environments:

• BlackBerry Enterprise Server domain: A BlackBerry Configuration Database and any
BlackBerry Enterprise Server components that are associated with it

• BlackBerry Enterprise Server Express domain: A BlackBerry Configuration Database and any
BlackBerry Enterprise Server Express components that are associated with it

• BlackBerry Device Service domain: A BlackBerry Configuration Database and any
BlackBerry Device Service components that are associated with it

• Universal Device Service domain: A Management Database and any Universal Device
Service components that are associated with it

messaging server A messaging server sends and processes messages and provides collaboration services, such as
updating and communicating calendar and address book information.

MSDE Microsoft SQL Server Desktop Engine
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MSMQ Microsoft® Message Queuing

PIM personal information management

PIN personal identification number

SMTP Simple Mail Transfer Protocol

SQL Structured Query Language

SRP Server Routing Protocol

Triple DES Triple Data Encryption Standard

UAC User Account Control

UCS Universal Content Stream

UTF-8 8-bit UCS/Unicode Transformation Format

Administration Guide Glossary

136



Legal notice
©2012 Research In Motion Limited. All rights reserved. BlackBerry®, RIM®, Research In Motion®, and related trademarks,
names, and logos are the property of Research In Motion Limited and are registered and/or used in the U.S. and countries
around the world.

IBM, DB2, DB2 Universal Database, Domino, and Lotus are trademarks of International Business Machines Corporation.
Java is a trademark of Oracle and/or its affiliates. Microsoft, Active Directory, Internet Explorer, SQL Server, and Windows
are trademarks of Microsoft Corporation. Novell and GroupWise are trademarks of Novell, Inc. All other trademarks are the
property of their respective owners.

This documentation including all documentation incorporated by reference herein such as documentation provided or
made available at www.blackberry.com/go/docs is provided or made accessible "AS IS" and "AS AVAILABLE" and without
condition, endorsement, guarantee, representation, or warranty of any kind by Research In Motion Limited and its affiliated
companies ("RIM") and RIM assumes no responsibility for any typographical, technical, or other inaccuracies, errors, or
omissions in this documentation. In order to protect RIM proprietary and confidential information and/or trade secrets, this
documentation may describe some aspects of RIM technology in generalized terms. RIM reserves the right to periodically
change information that is contained in this documentation; however, RIM makes no commitment to provide any such
changes, updates, enhancements, or other additions to this documentation to you in a timely manner or at all.

This documentation might contain references to third-party sources of information, hardware or software, products or
services including components and content such as content protected by copyright and/or third-party websites
(collectively the "Third Party Products and Services"). RIM does not control, and is not responsible for, any Third Party
Products and Services including, without limitation the content, accuracy, copyright compliance, compatibility,
performance, trustworthiness, legality, decency, links, or any other aspect of Third Party Products and Services. The
inclusion of a reference to Third Party Products and Services in this documentation does not imply endorsement by RIM of
the Third Party Products and Services or the third party in any way.

EXCEPT TO THE EXTENT SPECIFICALLY PROHIBITED BY APPLICABLE LAW IN YOUR JURISDICTION, ALL CONDITIONS,
ENDORSEMENTS, GUARANTEES, REPRESENTATIONS, OR WARRANTIES OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING WITHOUT LIMITATION, ANY CONDITIONS, ENDORSEMENTS, GUARANTEES, REPRESENTATIONS OR
WARRANTIES OF DURABILITY, FITNESS FOR A PARTICULAR PURPOSE OR USE, MERCHANTABILITY, MERCHANTABLE
QUALITY, NON-INFRINGEMENT, SATISFACTORY QUALITY, OR TITLE, OR ARISING FROM A STATUTE OR CUSTOM OR A
COURSE OF DEALING OR USAGE OF TRADE, OR RELATED TO THE DOCUMENTATION OR ITS USE, OR PERFORMANCE
OR NON-PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR ANY THIRD PARTY PRODUCTS AND SERVICES
REFERENCED HEREIN, ARE HEREBY EXCLUDED. YOU MAY ALSO HAVE OTHER RIGHTS THAT VARY BY STATE OR
PROVINCE. SOME JURISDICTIONS MAY NOT ALLOW THE EXCLUSION OR LIMITATION OF IMPLIED WARRANTIES AND
CONDITIONS. TO THE EXTENT PERMITTED BY LAW, ANY IMPLIED WARRANTIES OR CONDITIONS RELATING TO THE
DOCUMENTATION TO THE EXTENT THEY CANNOT BE EXCLUDED AS SET OUT ABOVE, BUT CAN BE LIMITED, ARE
HEREBY LIMITED TO NINETY (90) DAYS FROM THE DATE YOU FIRST ACQUIRED THE DOCUMENTATION OR THE ITEM
THAT IS THE SUBJECT OF THE CLAIM.
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TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, IN NO EVENT SHALL RIM BE
LIABLE FOR ANY TYPE OF DAMAGES RELATED TO THIS DOCUMENTATION OR ITS USE, OR PERFORMANCE OR NON-
PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR ANY THIRD PARTY PRODUCTS AND SERVICES
REFERENCED HEREIN INCLUDING WITHOUT LIMITATION ANY OF THE FOLLOWING DAMAGES: DIRECT,
CONSEQUENTIAL, EXEMPLARY, INCIDENTAL, INDIRECT, SPECIAL, PUNITIVE, OR AGGRAVATED DAMAGES, DAMAGES
FOR LOSS OF PROFITS OR REVENUES, FAILURE TO REALIZE ANY EXPECTED SAVINGS, BUSINESS INTERRUPTION,
LOSS OF BUSINESS INFORMATION, LOSS OF BUSINESS OPPORTUNITY, OR CORRUPTION OR LOSS OF DATA,
FAILURES TO TRANSMIT OR RECEIVE ANY DATA, PROBLEMS ASSOCIATED WITH ANY APPLICATIONS USED IN
CONJUNCTION WITH RIM PRODUCTS OR SERVICES, DOWNTIME COSTS, LOSS OF THE USE OF RIM PRODUCTS OR
SERVICES OR ANY PORTION THEREOF OR OF ANY AIRTIME SERVICES, COST OF SUBSTITUTE GOODS, COSTS OF
COVER, FACILITIES OR SERVICES, COST OF CAPITAL, OR OTHER SIMILAR PECUNIARY LOSSES, WHETHER OR NOT
SUCH DAMAGES WERE FORESEEN OR UNFORESEEN, AND EVEN IF RIM HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, RIM SHALL HAVE NO OTHER
OBLIGATION, DUTY, OR LIABILITY WHATSOEVER IN CONTRACT, TORT, OR OTHERWISE TO YOU INCLUDING ANY
LIABILITY FOR NEGLIGENCE OR STRICT LIABILITY.

THE LIMITATIONS, EXCLUSIONS, AND DISCLAIMERS HEREIN SHALL APPLY: (A) IRRESPECTIVE OF THE NATURE OF
THE CAUSE OF ACTION, DEMAND, OR ACTION BY YOU INCLUDING BUT NOT LIMITED TO BREACH OF CONTRACT,
NEGLIGENCE, TORT, STRICT LIABILITY OR ANY OTHER LEGAL THEORY AND SHALL SURVIVE A FUNDAMENTAL
BREACH OR BREACHES OR THE FAILURE OF THE ESSENTIAL PURPOSE OF THIS AGREEMENT OR OF ANY REMEDY
CONTAINED HEREIN; AND (B) TO RIM AND ITS AFFILIATED COMPANIES, THEIR SUCCESSORS, ASSIGNS, AGENTS,
SUPPLIERS (INCLUDING AIRTIME SERVICE PROVIDERS), AUTHORIZED RIM DISTRIBUTORS (ALSO INCLUDING AIRTIME
SERVICE PROVIDERS) AND THEIR RESPECTIVE DIRECTORS, EMPLOYEES, AND INDEPENDENT CONTRACTORS.

IN ADDITION TO THE LIMITATIONS AND EXCLUSIONS SET OUT ABOVE, IN NO EVENT SHALL ANY DIRECTOR,
EMPLOYEE, AGENT, DISTRIBUTOR, SUPPLIER, INDEPENDENT CONTRACTOR OF RIM OR ANY AFFILIATES OF RIM
HAVE ANY LIABILITY ARISING FROM OR RELATED TO THE DOCUMENTATION.

Prior to subscribing for, installing, or using any Third Party Products and Services, it is your responsibility to ensure that
your airtime service provider has agreed to support all of their features. Some airtime service providers might not offer
Internet browsing functionality with a subscription to the BlackBerry® Internet Service. Check with your service provider for
availability, roaming arrangements, service plans and features. Installation or use of Third Party Products and Services with
RIM's products and services may require one or more patent, trademark, copyright, or other licenses in order to avoid
infringement or violation of third party rights. You are solely responsible for determining whether to use Third Party
Products and Services and if any third party licenses are required to do so. If required you are responsible for acquiring
them. You should not install or use Third Party Products and Services until all necessary licenses have been acquired. Any
Third Party Products and Services that are provided with RIM's products and services are provided as a convenience to you
and are provided "AS IS" with no express or implied conditions, endorsements, guarantees, representations, or warranties
of any kind by RIM and RIM assumes no liability whatsoever, in relation thereto. Your use of Third Party Products and
Services shall be governed by and subject to you agreeing to the terms of separate licenses and other agreements
applicable thereto with third parties, except to the extent expressly covered by a license or other agreement with RIM.

Certain features outlined in this documentation require a minimum version of BlackBerry Enterprise Server, BlackBerry
Desktop Software, and/or BlackBerry Device Software.
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The terms of use of any RIM product or service are set out in a separate license or other agreement with RIM applicable
thereto. NOTHING IN THIS DOCUMENTATION IS INTENDED TO SUPERSEDE ANY EXPRESS WRITTEN AGREEMENTS OR
WARRANTIES PROVIDED BY RIM FOR PORTIONS OF ANY RIM PRODUCT OR SERVICE OTHER THAN THIS
DOCUMENTATION.

Research In Motion Limited
295 Phillip Street
Waterloo, ON N2L 3W8
Canada

Research In Motion UK Limited
200 Bath Road
Slough, Berkshire SL1 3XE
United Kingdom

Published in Canada
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