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Getting started
The BlackBerry AtHoc management system uses the IIM add-on module with Giant Voice (GV) outdoor warning
devices to enable wide-area Mass Notification System (MNS) broadcasts. Giant Voice features can broadcast
critical information using voice messages, wave files,musical tones, or text-to-speech (TTS) conversion. American
Signal GV supports outdoor Public Address (PA) systems that have large amplified speakers. Typically, speakers
are set on poles in an array that covers a specified area with enough acoustic sound to override the ambient noise
with emergency notifications.

After the BlackBerry AtHoc management system is integrated with an American Signal Giant Voice System,
operators can disseminate emergency alerts to the siren system from the BlackBerry AtHoc management
console. Alert messages can be delivered using Key functions programmed in the American Signal hardware or
software, text-to-speech, or pre-recorded audio files to dynamically selected targets. Targeting choices are All
Poles simultaneously, individual Zones of poles, and Poles.
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Product requirements
This section describes the hardware and software requirements to install and configure the American Signal Giant
Voice system.

Hardware requirements
• 080-0105D CLIII motherboard
• 095-0074 daughter board with 080-0206A serial chip
• Two 080-0131 bulkhead serial boards

Software requirements
• BlackBerry AtHoc release 6.1.8.85 or newer.
• IP Integration Module capnode_obf.jar 5/8/2013 or newer.

You must also update the following files that are not specific to American Signal Giant Voice systems:

• IIM Management (Agent) Configuration.
• C:\Program Files\capnode\AlertTemplate\SirenCentralStatusTemplate.xml

• C:\Program Files\capnode\myid.property

• C:\Program Files\capnode\title.property
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Configure the American Signal Giant Voice – V2 device
on the BlackBerry AtHoc application server
Log in to the BlackBerry AtHoc management console and check the Delivery Gateways section to verify that the
American Signal and XML Feed device gateways have been installed. If they are installed, skip this section. If not,
complete the following steps to install the American Signal Giant Voice – V2 device gateway on the BlackBerry
AtHoc application server:

1. Log in to the BlackBerry AtHoc application server as an administrator.
2. Locate and run the following file: <IWSAlerts Install Path>\ServerObjects\tools

\AtHoc.Applications.Tools.InstallPackage.exe

3. On the Configure Device Support window, select American Signal Giant Voice – V2 and XML Feed.
4. Click Enable.
5. On the Installation Complete pop-up screen, click OK.
6. Click Close.

 | Configure the American Signal Giant Voice – V2 device on the BlackBerry AtHoc application server | 7



Configure the American Signal delivery gateway
Configure the American Signal gateway in the Settings section of the BlackBerry AtHoc management system to
enable the BlackBerry AtHoc alerts system to publish alerts through American Signal.

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. In the navigation bar, click .
3. In the Devices section, click American Signal Giant Voice V2.
4. On the American Signal Giant Voice - V2 page, click Copy default settings.
5. In the General Settings section, for the Convert Line Breaks option, select Yes.
6. In the CAP Parameter Defaults section, update the Sender field to BlackBerry AtHoc Alerts.
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7. Click Save.
8. In the navigation bar, click .
9. In the Devices section, click Xml Feed.
10.On the Xml Feed page, click Copy default settings.
11.In the Feed Source section, select Delivery Gateway ID.
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12.Click Save.

Enable the American Signal Giant Voice device
Choose and configure the delivery gateways that deliver messages to American Signal Giant Voice devices. If
more than one delivery gateway is configured, the system attempts to deliver messages to devices in the "Device
Group order" listed in the American Signal Giant Voice page until delivery is successful. If no delivery gateways are
configured, the device is considered disabled.

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. In the navigation bar, click .
3. In the Devices section, click Devices.
4. On the Devices page, click the Mass Devices tab.
5. Click American Signal Giant Voice-V2.
6. On the American Signal Giant Voice - V2 page, click Edit.
7. In the Delivery Gateways section, click Add a Delivery Gateway > American Signal Giant Voice-V2.
8. In the American Signal Giant Voice-V2 row, click .
9. On the Configure Gateway window, check for XML code in the Configuration XML field. If the XML statements

are not provided, copy and paste the following code into the text field:

<Configuration>
   <CapParams>
        <GVSystemType>ASCV2</GVSystemType>
        <AllMode>1</AllMode>
        <ZoneMode>1</ZoneMode>
        <PoleMode>1</PoleMode>
        <KeyMode>1</KeyMode>
        <UnusedMode>0</UnusedMode>
        <DefaultAllCall>FFFF</DefaultAllCall>
    <DefaultKeyActivationCode>0</DefaultKeyActiationCode>
      <NoPARequired>0</NoPARequired>
    <PARequired>1</PARequired>
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    <PAWav>1</PAWav>
    <PacketMode>0</PacketMode>
    <IsCancelable>false</IsCancelable>
    <ContentSource>GiantVoice</ContentSource>
  </CapParams>
</Configuration>

10.Click Submit.
11.Click Save.
12.Click More Actions > Enable.

The status line at the top of the screen updates and indicates that the device is enabled.

Enable the Xml Feed device
1. In the navigation bar, click .
2. In the Devices section, click Devices.
3. On the Devices page, click the Mass Devices tab.
4. Click Xml Feed.
5. On the Xml Feed page, click Edit.
6. In the Delivery Gateways section, click Add a Delivery Gateway  > Xml Feed.
7. In the Xml Feed row, click .
8. On the Configure Gateway window, check for XML code in the Configuration XML field. If the XML statements

are not provided, copy and paste the following code into the text field:

<Configuration><DeviceType>FEED</DeviceType></Configuration>

9. Click Submit.
10.Click Save.

Note:  The Xml Feed device must be configured but does not need to be enabled to use the American Signal Giant
Voice device.

Create custom attributes
To set up mass communication users,you must create targets (Poles, Zones, All Poles) and key end users. Key
end users require the configuration of custom attributes to work properly.

If the ATHOC-GV-TYPE and ATHOC-GV-KEYS custom user attributes already exist, skip this section.

Create the ATHOC-GV-TYPE attribute
The ATHOC-GV-TYPE custom user attribute is a non-mandatory, single-select list with no default value.

1. Log in to BlackBerry AtHoc management system as an administrator.
2. In the navigation bar, click Users > User Attributes.
3. On the User Attributes page, click New > Single-select Picklist.
4. On the New Attribute page, in the Basic section, enter ATHOC-GV-TYPE in the Name and Common

Name fields.
5. In the Values section, click Add value.
6. In the Value field, type Key, Pole, or Zone.
7. Optionally, select the default check box for the value you want to keep as a default and click Save.
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8. Click Save.

Create the ATHOC-GV-KEYS attribute
The ATHOC-GV-KEYS custom user attribute is a non-mandatory memo text field with an XML payload.

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. In the navigation bar, click Users > User Attributes.
3. On the User Attributes page, click New > Memo.
4. On the New Attribute page, in the Basic section, enter ATHOC-GV-KEY in the Name and Common Name fields.
5. Click Save.

Set up mass device endpoint (targets)
To create a speaker pole, zone, or an all-poles user, an operator should perform the normal Mass Device Endpoint
creation flow. User should give the endpoint a functionally descriptive name, so that it is recognizable in End User
Manager and Report windows as a mass-communication device target entity.

The list of RTUs in the Giant Voice system in the PC run the CompuLert™ software. The file that contains the list
of RTUs in the C:\WINAPPS\ASC2\Data folder is a .sir file, which can be opened using Notepad.

The American Signal Giant Voice poles are targeted using a three hexadecimal character string. One or more of
the characters can be replaced with a * to represent a wild card in that position which selects all addresses which
share the same remaining characters. This method of grouping poles into zones is performed by addressing the
poles so that wild cards can be used in a group or zone address.

Examples

• The address A01 targets only the pole with the address A01.
• The address *01 targets all addresses that end in 01. For example, A01 and B01.
• The address A** targets all addresses that start with A. For example, A01, A02, and A10.
• The address *** targets all poles.

Create mass device zone and pole endpoints
All ASCv2 target users are defined as Poles in the ATHOC-GV-TYPE attribute and start with P in the American
Signal Giant Voice – V2 device attribute.To create a new mass device endpoint for each zone and pole, complete
the following steps:

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. In the navigation bar, click  .
3. In the Devices section, click Mass Devices Endpoints.
4. In the Mass Device Endpoints window, click New.
5. Select American Signal Giant Voice - V2 from the list.
6. In the Configuration section, select the Pole option for Giant Voice type.
7. In the Address field, enter P,***,10, where 10 is always the hexadecimal RTU function number of the Public

Address function.

Note:  The addresses are case sensitive and must not contain spaces.
8. Click Save.

Note:  If required, repeat steps 3 to 8 to create mass communication users for any other desired American Signal
Giant Voice-V2 Pole or Zone target users.
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Create a mass device key endpoint
To create the object that displays the list of keys associated with American Signal Giant Voice system,complete
the following tasks:

• Create the ATHOC-GV-KEYS attribute XML configuration.
• Perform the normal Mass Device Endpoint creation flow.

Create the ATHOC-GV-KEYS attribute XML configuration

This section describes how to create the key user ATHOC-GV-KEYS attribute configuration.

American Signal CompuLert™ .cfg file

On the American Signal CompuLert™ standalone computer, browse to C:\WINAPPS\ASC2\Data and open the
appropriate .cfg file with Notepad.

The following example has bold text to show the important sections:

Customer X Electronic Control Configuration - rev 6.00 03/04/13
PORTS
"C:\", "COM1:2400,N,8,2", 31, 0
"", 0, 1,1,1,1,1,1,1,1,1
SWITCHES
"01", "MDY", 0, 0, 0, 0, 0 0
Map1 Rep Cen Mon Cyc RePoll MetDly Multipoll
COMMANDS
At Dly Description Command (10) - Command Delay
1, 7, "Auto Poll w/Report ", 682,
2, "Auto Reset Status ", 67
3, 2, "Auto Sil-Test w/Rep ", 66
4, 2, " ", 0
5, 2, "Auto Weekly Test ", 33
6, 2, "Auto Reveille/Colors", 34
7, 2, "Auto Retreat/Anthem ", 35
8, 2, "Auto Taps ", 36
9, 2, "Auto Call to Arms ", 53
10, 2, " ", 0
11, 2, " ", 0
12, 2, " ", 0
13, 2, " ", 0
14, 2, " ", 0
15, 2, " ", 0
16, 2, " ", 0
17, 2, " ", 0
18, 2, " ", 0
19, 2, " ", 0
20, 2, " ", 0
21, 2, " ", 0
22, 2, " ", 0
23, 2, " ", 0
24, 2, " ", 0
25, 2, " ", 0
26, 2, " - - Abort - - ", 61
27, 7, "USTAT Auto Re-Poll ", 54
28, 5, "Auto Weather Data ", 70
 1, "AL FF FF FF Alert "
2, "AT FF FF FF Attack "
3, "HI FF FF FF Hi\Lo "
4, "HO FF FF FF Air-Horn
5, "FI FF FF FF Fire "
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6, "GR FF FF FF Growl "
7, "HA FF FF FF Hazard "
8, "CH FF FF FF Chime "
9, "SC FF FF FF Scream "
10, "WA FF FF FF Wail "
11, "XA FF FF FF Pgm-A "
12, "XB FF FF FF Pgm-B "
13, "XC FF FF FF Pgm-C "
14, "XD FF FF FF Pgm-D "
15, "XE FF FF FF Pgm-E "16, "XF FF FF FF Pgm-F "
17, "PA FF FF FF Live PA "
 18, "SI FF FF FF Test "
19, "RO FF FF FF Rotate "
20, "SH FF FF FF Seek Home"
21, "ST FF FF FF Strobe "
22, "AR FF FF FF Arm "
23, "ME 01 FF FF Message "
24, "CS FF FF FF Slo-Cancel"
25, "RS FF FF FF Reset Status"
26, "PO FF FF FF Poll "
 27, "RE FF FF FF Re-Sync "
28, "RB FF FF FF Remote-Rst"
29, "WP 00 FF FF Write-Pgm "
30, "RP 00 FF FF Macro-Central"
31, "DM F0 FF FF Dump-Mem "
 32, "CA FF FF FF Cancel "
33, "ME 01 FF FF Weekly Test"
34, "ME 02 FF FF Reveille/Colors"
35, "ME 03 FF FF Retreat/National Anthem"
36, "ME 04 FF FF Taps
37, "ME 05 FF FF Lightning Warning"
38, "ME 06 FF FF Lightning Warning Terminated"
39, "ME 07 FF FF Heat Advisory"
40, "ME 08 FF FF Tornado Warning"
41, "ME 09 FF FF All Clear"
42, "ME 0A FF FF Hurricane Condition Five"
43, "ME 0B FF FF Hurricane Condition Four"
44, "ME 0C FF FF Hurricane Condition Three"
45, "ME 0D FF FF Hurricane Condition Two"
46, "ME 0E FF FF Hurricane Condition One"
47, "ME 0F FF FF Tornado Exercise"
48, "ME 10 FF FF All Clear Exercise"
49, "ME 11 FF FF Alarm Yellow Exercise"
50, "ME 12 FF FF Alarm Red Mopp 4 Exercise"
51, "ME 13 FF FF Alarm Red Ground Attack MOPP 2 Exercise"
52, "ME 14 FF FF Alarm Red Ground Attack MOPP 4 Exercise"
53, "ME 15 FF FF Call to Arms"
54, "PO FF FF FF USTAT Poll"
55, "CA FF FF FF -Test Mark"
56, "M1 Cancel (M1)"
57, "M2 ?? "
58, "M3 ?? "
59, "M4 ?? "
60, "M5 ?? "
61, "M6 ?? "
62, "M7 ?? "
63, "M8 ?? "
64, "M9 ?? "
65, "M10 ?? "
66, "M11 Silent Test w/Report (M16)"
67, "M12 Reset Status (M17)"
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68, "M13 Poll w/Report (M18)"
69, "M14 Test Poll (M19)"
70, "WE Request Weather Data"
71, "LI Show Last Weather"
72, "PR Remove Weather Boxes"
73, "PR Print Weather Data"
74, "DIS Pending Trouble Report"
75, "UR Trouble Report by Date"
76, "SS Silent Test Report"
77, "SS Daily Poll Status Report"
78, "SS Siren Activation Report"
79, "SS AC Test Report"
80, "SS DC Test Report"
MENUS
0, 0, 32, Cancel
0, 1, 55, ------
0, 2, 37, Lightning Warning
0, 3, 38, Lightning Warning Terminated
0, 4, 39, Heat Advisory
0, 5, 40, Tornado Warning
0, 6, 41, All Clear
0, 7, 55, ------
0, 8, 34, Reveille/Colors
0, 9, 35, Retreat/National Anthem
0,10, 36, Taps
0,11, 53, Call to Arms
0,12, 55, ------
0,13, 42, Hurricane Condition Five
0,14, 43, Hurricane Condition Four
0,15, 44, Hurricane Condition Three
0,16, 45, Hurricane Condition Two
0,17, 46, Hurricane Condition One
0,18, 55, ------
0,19, 47, Tornado Exercise
0,20, 48, All Clear Exercise
0,21, 55, ------
0,22, 49, Alarm Yellow Exercise
0,23, 50, Alarm Red Mopp 4 Exercise
0,24, 51, Alarm Red ground Attack Exercise
0,25, 52, Alarm Black Exercise
0,26, 55, -----
0,27, 33, Weekly Test
0,28, 55, ------
0,29, 17, Live PA
2, 0, 32, Cancel
2, 1, 55, ------
2, 2, 26, Poll
2, 3, 67, Reset Status
2, 4, 18, Silent Test
2, 5, 55, ----------
2, 6, 68, Poll w/Report
2, 7, 55, ----------
2, 8, 66, Silent Test w/Report
3, 8, 55, ----------
3, 9, 75, Trouble Report
0,99, 99, End of List
MACROS
Cancel
56, 1,32, 0, "???"
Silent Test w/Report
66, 1,67, 0, "???"
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66, 2,18,16, "???"
66, 3,69, 0, "???"
66, 4,18,16, "%%%"
66, 5,55, 0, "%%%"
66, 6,26, 0, "%%%"
66, 7,76, 0, "???"
Reset Status
67, 1,25, 0, "???"
67, 2,25, 0, "???"
Poll w/Report
68, 1,26, 0, "???"
68, 2,26, 0, "%%%"
68, 3,77, 0, "???"
Poll After Run
69, 1,55, 0, "???"
69, 2,26, 0, "???"
69, 3,55, 0, "%%%"
69, 4,26, 0, "%%%"
99
REPEATERS
163.4625Hz(Tx) 163.4625MHz(Rx) None=PL
0
=====================================================================-
===========|Last Response| Poll | Activate | System Test |Low
Sir |-------------|-------|--------------------|--------------|Comm
Door AC
Loc | Time Date |OK Fail| OK Pwr Par Loc Com | OK Pwr Par |Batt
Open
 Fai============================================================================xxx
 12:34:56 03-23 x x x x x x x x x x xx x24 28 33 36 40 44 48 54 58 63 67 71
 ------|---------|---------|---------|---------|---------|-------xxxx-|---------|
MSG pos err
Text
1, 24, 0," RF-OK"
2, 77, 2," AC_Fail"
3, 67, 5," Low_Comm_Batt"
4, 71, 2," Door_Open"
5, 0, 0," Sync_Error"
6, 0, 0,""
7, 33, 0," Activate_OK"
8, 33, 0," Activate_No_Rotate"
9, 36, 5," Activate_No_Power"
10, 40, 2," Activate_Partial"
11, 54, 0," Test_OK"
12, 54, 0," Test_No_Rotate"
13, 58, 5," Test_No_Power"
14, 0, 0," RTU_Restart"
15, 28, 5," No_Response_from_Poll"
16, 63, 2," Test_Partial"
17, 0, 0," Low_Main_Batt"
18, 0, 0," AC_Disable"
19, 48, 5," Activate_Comm"
20, 44, 5," Activate_Local"
4, 3, 2,14, 5,-4,-2,-1, 0, 0, 0, 0, 0, 0, 0, 0 ' (-Bit)(+Msg)
(+200inv)6, 7, 8, 9,20,11,12,13, 6,10,10, 9,20,16,16,13,15,19 ' Run StatusXlate
0,0,0,0,0,0,0,0, 0,0,0,0,0,0,0,0, 0,0,0,0,0,0,0,0 ' Cen/Aux/Sgn
bits
STATUS BOX
Byte BitText Fail Text
0, 0, "-------------------"
6, 0, " Siren Status of ", "Fail", "Unknown"
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0, 0, "-------------------"
7, 0, " Poll Date:", "Not Polled", "Date:"
1, 8, " RF Comm:", "OK ", "Sync Err ", ""
1, 64, " Comm Bat:", "OK ", "Low ", ""
1,128, " Doors:", "Closed", "Open ", ""
1, 32, " AC Power:", "OK ", "Fail ", ""
4, 0, " Amps:", "OK ", "", ""
3, 0, " Siren:", "IDLE ", "", ""
5, 3, "Act Status:", "-none-", "", ""
0, 94, "---------------------", "Rep", "CEN-"
6, 0, " Repeater Status - ", "Fail", "Unknown"
0, 0, "---------------------"
7, 0, " Date/Time:", "Never Polled", ""
1, 8, " Feedback:", "OK ", "Sync Err "
1, 64, " Battery:", "OK ", "Low "
1, 32, " Mains:", "OK ", "Fail "
2, 16, " Output:", "OK ", "Fault "
2,204, " Repeater:", "Active", "Disabled "
0, 98, "---------------------", "Cen", "CEN-"
6, 0, " Central Status - ", "Fail", "Unknown"
0, 0, "---------------------"
7, 0, " Date/Time:", "Never Polled", ""
1, 8, " Feedback:", "OK ", "Sync Err "
1, 64, " Battery:", "OK ", "Low "
1, 32, " Mains:", "OK ", "Fail "
2, 2, " J103-4:", "OK ", "Error "
2, 4, " J103-5:", "OK ", "Error "
2, 8, " J103-6:", "OK ", "Error "
2, 16, " J103-7:", "OK ", "Error "
0, 99, "---------------------"TRANSLATE 0123456789ABCDT* 0123456789ABCDE*
 0123456789ABCDR* NO
ANALOG #siren, #Ch , 1'st Ch siren
0, 5, 9, "AAA"

The definition for each attribute is as follows:

Attribute name Description

Id Corresponds to the address of the key within the Giant Voice system.
This addressing scheme varies by Giant Voice vendor.

messgaeIdRef References the <message> object to be displayed as a warning in the
Targeting screen in the Management System during the publishing cycle.

targetingRule Used to establish correct targeting behavior for the key. Possible values
are:

• TargetingNotAllowed
• TargetingAllowed
• TargetingRequired

name The name of the Giant Voice key that is displayed in the publishing flow.

description The description of the Giant Voice key that is displayed in the publishing
flow. If there are more than 5 keys, this will not be displayed.
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Note:  Id numbers do not need to be sequential. Changing the order in the XML,changes the order in which Id
numbers are listed in the publishing flow but has no effect on the command number being sent to the RTUs.

Note:  In American Signal Giant Voice, the id addressing consists of 5 pipe-separated (|)hexadecimal bytes.
The first byte corresponds to the hexadecimal equivalent of the decimal number(minus 1) shown in the yellow
highlighted section above where id = DHC(command10-1). The highest RTU command number that can be
addressed this way is Cancel, #32 in the list or 1FH.

Example 1: Alert (AL) is #1 in the list and converts to 00; (1-1)=010=00H.

Example 2: Cancel (CA) is #32 in the list and converts to 1F; (32-1)=3110=1FH.

Id #17 (hexadecimal #10), Public Address, is skipped as Public Address functions are handled as an RTU function
through the All Poles, Pole, and Zone target user device address instead of through a function key.

The second and subsequent bytes correspond to various attributes of the key.

Example: Message number or times for a tone to cycle.

Command numbers above #32 (1FH), shown in the blue highlighted section, need to have some additional
handling before they can be added to the Key Id list.

Example: Command 33 calls on function ME with a hex specifier of 01 for message #1 for the recording, “Weekly
Test”: 35, "ME 03 FF FF Retreat/National Anthem"

In the following example,“ME” occurs within the lower-range of functions: 23, "ME 01 FF FF Message"

The base message function is 2310=16H. The translation of function 3310 into function 2310 is: 23, "ME 03
FF FF Retreat/National Anthem"

Which translates into: Id = “16:03:FF:FF:FF”

Note:  For American Signal Giant Voice Keys, the messageIdRef parameter is always MSGTARGETING-REQUIRED
and the targetingRule parameter is always TargetingRequired.

Note:  The key name and description parameters cannot contain spaces or any of the following characters:

' ! $ % ^ ( ) = { } , ; : ? " < > |

This sample XML shows how the basic functions from the .cfg file above are listed for use in the Key user and
maps to the .cfg file shown above. You can copy the content below into Notepad and modify it to match your
Function Keys.

<giantVoiceSetting>
<messages>
<message id = "MSG-TARGETING-NOT-ALLOWED">The Giant Voice Key you
have selected on the previous page does not allow 
additional selection of Giant Voice poles or zones. You may still 
target users for other devices, but Giant Voice targeting will be ignored.
</message>
<message id = "MSG-TARGETING-ALLOWED">The Giant Voice Key you have selected on
 the previous page already has Giant Voice poles and zones targeted, but you can
 override them by targeting different zones in the Targeting area just below. 
</message>
<message id = "MSG-TARGETING-REQUIRED">The Giant Voice Key you have selected on
 the previous page does not have any targeting information built-in, and will
 require you to target at least one Giant Voice pole or zone below.</message>
</messages>
<keys>
<key
id = "1F|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
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targetingRule = "TargetingRequired">
<name>CANCEL</name>
<description>CANCEL</description>
</key>
<key
id = "11|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>SILENT TEST</name>
 <description>SILENT TEST</description>
 </key>
<key
id = "16|05|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>LIGHTNING WARNING MESSAGE</name>
<description>LIGHTNING WARNING MESSAGE</description>
</key>
</key>
<key
id = "16|06|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>LIGHTNING WARNING TERMINATED MESSAGE</name>
<description>LIGHTNING WARNING TERMINATED MESSAGE</description>
</key>
<key
id = "16|07|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>HEAT ADVISORY MESSAGE</name>
<description>HEAT ADVISORY MESSAGE</description>
</key>
<key
id = "16|08|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>TORNADO WARNING MESSAGE</name>
<description>TORNADO WARNING MESSAGE</description>
</key>
<key
id = "16|09|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>ALL CLEAR MESSAGE</name>
<description>ALL CLEAR MESSAGE</description>
</key>
<key
id = "16|02|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingNotAllowed">
<name>REVEILLE - COLORS BUGLE</name>
<description>REVEILLE - COLORS BUGLE</description>
></key>
<key
id = "16|03|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
25
Chapter 5: VPS Component Configuration (.85)
targetingRule = "TargetingRequired">
<name>RETREAT BUGLE - NATIONAL ANTHEM</name>
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<description>RETREAT BUGLE - NATIONAL ANTHEM</description>
</key>
<key
id = "16|04|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>TAPS BUGLE</name>
<description>TAPS BUGLE</description>
</key>
<key
id = "16|15|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>CALL TO ARMS BUGLE</name>
<description>CALL TO ARMS BUGLE</description>
</key>
<key
id = "16|0A|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>HURRICANE CONDITION FIVE</name>
<description>HURRICANE CONDITION FIVE</description>
</key>
<key
id = "16|0B|FF|FF|FF"
messageIdRef = "MSG-TARGETING-NOT-ALLOWED"
targetingRule = "TargetingRequired">
<name>HURRICANE CONDITION FOUR</name>
<description>HURRICANE CONDITION FOUR</description>
</key>
><key
id = "16|0C|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>HURRICANE CONDITION THREE</name>
<description>HURRICANE CONDITION THREE</description>
</key>
<key
id = "16|0D|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>HURRICANE CONDITION TWO</name>
<description>HURRICANE CONDITION TWO</description>
</key>
<key
id = "16|0E|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>HURRICANE CONDITION ONE</name>
<description>HURRICANE CONDITION ONE</description>
</key>
<key
id = "16|0F|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>EXERCISE TORNADO MESSAGE</name>
<description>EXERCISE TORNADO MESSAGE</description>
</key>
<key
id = "16|10|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
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targetingRule = "TargetingRequired">
<name>EXERCISE ALL CLEAR MESSAGE</name>
<description>EXERCISE ALL CLEAR MESSAGE</description>
</key>
<key
id = "16|11|FF|FF|FF"
>messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>EXERCISE ALARM YELLOW MESSAGE</name>
<description>EXERCISE ALARM YELLOW MESSAGE</description>
</key>
<key
id = "16|12|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>EXERCISE ALARM RED MOPP 4 MESSAGE</name>
<description>EXERCISE ALARM RED MOPP 4 MESSAGE</description>
</key>
<key
id = "16|13|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>EXERCISE ALARM RED GROUND ATTACK MOPP 2 MESSAGE</name>
<description>EXERCISE ALARM RED GROUND ATTACK MOPP 2 MESSAGE</-
description>
</key>
<key
id = "16|14|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>EXERCISE ALARM RED GROUND ATTACK MOPP 4 MESSAGE</name>
<description>EXERCISE ALARM RED GROUND ATTACK MOPP 4 MESSAGE</-
description>
</key>
<key
id = "16|01|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>WEEKLY TEST MESSAGE</name>
<description>WEEKLY TEST MESSAGE</description>
</key>
<key
id = "00|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>ALERT TONE 3 MINUTES</name>
<description>ALERT TONE</description>
</key>
<key
id = "01|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>ATTACK TONE 3 MINUTES</name>
<description>ATTACK TONE 3 MINUTES</description>
</key>
<key
id = "02|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>HI-LO TONE 3 MINUTES</name>
<description>HI-LO TONE</description>
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</key>
<key
id = "03|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>AIR HORN TONE 3 MINUTES</name>
<description>AIR HORN TONE</description>
</key>
<key
id = "04|07|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>FIRE TONE 3 MINUTES</name>
<description>FIRE TONE</description>
</key>
<key
id = "06|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>HAZARD TONE 3 MINUTES</name>
<description>HAZARD TONE</description>
</key>
<key
id = "07|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>CHIME TONE 10 SECONDS</name>
<description>CHIME TONE</description>
</key>
<key
id = "08|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>SCREAM TONE 3 MINUTES</name>
<description>SCREAM TONE</description>
</key>
<key
id = "09|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>WHOOP TONE 3 MINUTES</name>
<description>WHOOP TONE</description>
</key>
<key
id = "17|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>SLOW CANCEL</name>
<description>SLOW CANCEL</description>
</key>
<key
id = "18|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>RESET STATUS</name>
<description>RESET STATUS</description>
</key>
<key
id = "1B|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
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<name>REBOOT</name>
<description>REBOOT</description>
</key>
</keys>
</giantVoiceSetting>

Macros

For more information about how to set up a file in the IIM and the key attributes, see Configure the
SirenCommandMap.txt file.

Create a key mass device endpoint

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. In the navigation bar, click  .
3. In the Devices section, click Mass Device Endpoints.
4. Click New > American Signal Giant Voice - V2.
5. On the New Mass Device Endpoint screen, in the Configuration section, select Key for Giant Voice Type to

create a new endpoint for the key selection.
6. Copy the Key XML configuration into the Giant Voice Key field.
7. In the Address field, enter K.

Create and publish an American Signal Giant Voice alert template
Prerequisites:

• Before you start sending test alerts through American Signal Giant Voice, consider the impact it has on
everyone within hearing distance of the poles you are using during the test.

• AtHoc management server and is not connected to the Giant Voice equipment.AtHoc management server and
is not connected to the Giant Voice equipment.

• Consult with your POC as to the acceptable content of the test alert. For example,the word "test" should appear
at, or very near to, the start of the broadcast message.

• Although the initial use of this template is to test the data creation process, this template can be used during
the audio tuning phase after the IIM and Giant Voice hardware are connected.

• To confirm that the American Signal Giant Voice device is installed correctly on the BlackBerry AtHoc
management system, create a template.

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. Click Alerts > Alert Templates.
3. Click New
4. On the New Template screen, in the Alert Template section, in the Alert Template section, enter a template

name and description.
5. Select a folder from the Folder list.
6. Select Available for quick publish.
7. In the Content section, enter the title and content of the alert.
8. In the Mass Devices section, select American Signal Giant Voice-V2 and then select one or more mass alert

endpoints from the list.
9. Click Options.
10.On the Mass Devices Options screen, select Text to Speech and Alert Body or Custom text.
11.Click Apply.
12.In the Schedule section, change the Alert Duration to 15 minutes.
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13.Click Save.
14.Click  .
15.On the Home page, in the Quick Publish section, find the alert template you just created.
16.Click Review and Publish.
17.Click Publish.

Verify the published alert
1. Open a browser and navigate to the following URL: https://<Domain Name>/syndication/

cap_amsig_v2<organization-id>/capindex

Where <;url> is the base URL of the BlackBerry AtHoc management system and <organization-id> is the 7 or 8-
digit organization ID.

2. Copy the content in the <URL> field into another browser. The capIndex XML format must be similar to the
content in the following image:

3. Verify the <addresses> and <code> match with the following format. The alert XML format must be similar to
the content in the following image:
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4. If any of the formatting does not match, review the American Signal Giant Voice Gateway XML content and
Mass Communication Users’ American Signal Giant Voice device addressing. Errors in these sections are the
most common reason for malformed Alert XML fields.
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Configure IIM IP connectivity
This section describes the steps to configure the IP Integration Module (IIM) to communicate with the BlackBerry
AtHoc American Signal device.

Prerequisites

Ensure that the following packages are installed and configured before performing any tasks:

• Latest American Signal Giant Voice - V2 BlackBerry AtHoc device package
• Latest American Signal IIM Capnode package
• Latest IIM Agent 1.1.0 package

To work as part of the BlackBerry AtHoc system, IIM must be able to communicate with the BlackBerry AtHoc
server to download the CAP packets.

The initial configuration data you need to collect are:

• The BlackBerry AtHoc Alerts system base URL
• The BlackBerry AtHoc Alerts organization ID
• Customer’s proxy server and port information

To find this information, use a local computer to log in to your local instance of the BlackBerry AtHoc
management console. The URL can be a base “https” address used to access a specific system. You can obtain
the URL of the system from the local system administrator or from the Blackberry Customer Support team.
Launch the BlackBerry AtHoc management console. The URL from the “https” to the last character before the
third forward slash (/) is the “base URL” of the system.

The organization ID is a 7 or 8-digit numerical identifier of the specific system of that customer. To obtain this
organization ID, log in to the BlackBerry AtHoc management system for the customer. Once logged in, you can
find the system’s organization ID at the top right of the Home Page of the system.

Navigate to the settings page of the browser and determine if you are using any type of Proxy server for routing
internet traffic. For example, if the browser you are using is Internet Explorer, go to the LAN settings, in IE,
select Tools > Internet Options. On the Internet Options screen, click the Connections tab. At the bottom of the
window, click LAN settings.

In the Proxy Server section, click Advanced. The Proxy Settings screen displays the Proxy Server Address.

Record the proxy server address and the port number. You can now close these settings windows and exit
Internet Explorer.

Note:  It is also possible that your Internet Explorer instance may not use proxy servers. If this is the case, when
you click the LAN settings button, no proxy server is used for internet traffic on this network.

Configure the system_private.config file
To configure the system_private.config file, complete the following steps:

1. Open Microsoft Notepad as an administrator.
2. Click File > Open.
3. Navigate to C:\Program Files\capnode and change the file selection from “Text Documents (*.txt)” to “All

Files (*.*)”.
4. Select the system_private.config file.
5. Click Open.
6. Verify the following items in the system_private.config file:

 | Configure IIM IP connectivity | 26



a. The indexURL variable should be formatted similar to the following image.
b. The base URL should be followed by “/syndication/”, then the device gateway protocol ID (for example,

CAP_AMSIG_V2 for an American Signal Giant Voice system), the organization ID number, followed by "/
capindex".

c. The “#” at the beginning of a line in the system_private.config file is used to comment out an unused
line. The “#” should be removed from a line to use the variable.

7. Enter the proxy server and proxy port information you collected earlier in the proxyServer and proxyPort
parameters. If the settings on the computer that you tested with is set for “Automatic” in the proxy settings, the
settings for those two lines display as follows:

• proxyServer=none
• proxyPort=8080

8. Update the CapPostingTarget variables to reflect the correct URL using the same base URL as in
the indexURL variable.

9. The American Signal COM Port settings displayed in the following image are default values and should not be
changed. 

10.Change the encoder.SirenCentralEncoder.ASCV.Translate variable to match the section bolded
in Create a mass device key endpoint.

11.Change the encoder.SirenCentralEncoder.ASCV2.CentralNumber variable to match the CSC960
address listed in Swap the CSC960 encoder.

12.Click File > Save.
13.Close the system_private.config file.
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Swap the CSC960 encoder
In most cases, the legacy CSC960 encoder has only one serial port and an older CompuLert III motherboard (CLIII
MB) that does not support integration with BlackBerry AtHoc and a new CSC960 unit with compliant hardware has
been provided for integration. Before removing the old CSC960 from service, use the CompuLert software to read
out the CSC960 program and save it as an archive for diagnostic purposes.

Save the CSC960 program as an archive
1. Log in to IIM.
2. Click Configure > Diagnostics.
3. Click File > Read Remote.
4. Click File > Save Remote Data.
5. Enter an RTU/CEN number and a description or select from the list.
6. Click Save.
7. Click File > Close Window.

Swap from a legacy CSC960 to new CSC960
1. Open the .REM file saved at C:\WINAPPS\ASC2\Data\REM with Notepad or with the CompuLert

Diagnostic application.
2. Exit the CompuLert software and restart it.
3. Observe and note down the Central number, displayed on the screen when the software starts.
4. Turn off the associated radio and legacy CSC960 and disconnect them from power.
5. Swap all of the cables from the old CSC960 to the new CSC960.
6. Restore power to both the radio and new CSC960.
7. Exit the CompuLert software and restart it.
8. Observe the Central number that comes up on the screen.

Note:  It should match the number that was shown for the old unit.
9. Optionally, if they do not match, use the CompuLert Diagnostic tool to update the Central address in the new

unit.

Rename the CSC960 program
1. Log into IIM.
2. Click Configure > Diagnostics.
3. Click File > Read Remote.
4. Click File > Save Remote Data.
5. Enter an RTU/CEN number and a description or select from list.
6. Click Save.
7. Click File > Open Program.
8. Select the new unit name.
9. Click Open.
10.Find and change the Central Address field to match the original unit.
11.Click File > Save Program.
12.Select the new unit name.
13.Click Save.
14.Click Program > Program ALL.
15.Enter the Central Address.
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16.Click Program.
17.Click File > Close Window.
18.Exit the CompuLert software and restart it.
19.Observe the Central number that comes up on the screen.

Restart the CapCon service
1. Navigate to the IIM system.
2. Go to Start > Run > Services.
3. Launch an instance of the Services Manager application. There should be a quick-launch icon in the taskbar of

the desktop.
4. Scroll down to the IIM CapCon Service.
5. Right-click CapCon Services row and select either Restart or Stop.
6. Right-click the CapCon Service row and select either Restart or Stop and then start the CapCon service.

Verify the CapCon system activity console (GUI)
1. Log in to the IIM console as an administrator. The CapCon Console loads automatically.

Note:  The data in the CapCon System Activity console polls at the rate set by
the delayBetweenRXpolls variable in the system_private.config file. The default is 7 seconds. A
message indicates the total number of items in the index. The index number is the number of active alerts on
the BlackBerry AtHoc system at that time.

2. Verify that the IIM console does not show any new errors.

3. Verify that the console icon in the task tray appears green, indicating that the connectivity between the IIM and
the BlackBerry AtHoc Alerts system is good.
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Configure the SirenCoordinates.txt file
The American Signal Giant Voice- V2 IIM has a feature that increases the efficiency of the number of
transmissions required to activate the sirens. This efficiency engine compares the selected Mass Communication
user’s device addresses against a list of all of the sirens in the system and determines how to best group them
using the wildcard character whenever possible.

To operate this correctly, the C:/Program Files/capnode/SirenCoordinates.txt file needs to be
populated with the list of siren addresses. Edit the file with Notepad so that there is one address per line.

The list of RTUs in the Giant Voice system are in the PC running the CompuLert software. The file that contains
the list of RTUs is a .sir file in the C:\WINAPPS\ASC2\Data folder and can be opened using Notepad. After the
list is created, save the file and restart the CapCon service to apply the changes.

Configure the SirenCommandMap.txt file
The American Signal Giant Voice - V2 IIM has a feature that allows macro sets of Keys to be created, either to fill
a new request or use existing macros as a template. This command map enables the creation of more complex
siren content with multiple recordings or interrupted tones with pauses in between each step. These macros can
then be added to the Giant Voice Key User ATHOC-GV-KEYS attribute configuration list, starting with hexadecimal
#31.

Templates for existing macro functions in the American Signal CompuLert™ software configuration file (.cfg) are
found in the C:/WINAPPS/ASC2/data folder. Any existing macros with polling functions cannot be replicated as
the polling and re-polling steps are not activated by the IIM. To operate this correctly, the C:/Program Files/
capnode/SirenCommandMap.txt file must be populated with a list of siren addresses.

Edit the file with Notepad so that there is one macro per line as shown:

31=^^^,01:FF:FF:FF:FF 33000 ^^^,17:FF:FF:FF:FF 3000 
^^^,07:FF:FF:FF:FF 13000 3C=T04,08:FF:FF:FF:FF 18000
T04,17:FF:FF:FF:FF 3000 T04,09:FF:FF:FF:FF 13000 T04,1F:FF:FF:FF:FF 10

In the example above, macro #31 initiates an Attack tone, delays for approximately 33 seconds, sends a cancel
tone, delays for approximately 3 seconds, sends a Chime tone and then delays for approximately 13 seconds.

Once the macro list has been made, save the file and restart the CapCon service to apply the changes.

To add the macros to the ATHOC-GV-KEYS configuration, append a key section as follows:

<key
id = "31|FF|FF|FF|FF"
messageIdRef = "MSG-TARGETING-REQUIRED"
targetingRule = "TargetingRequired">
<name>Attack and Chime Tone Test</name>
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<description>Attack and Chime Tone Test</description>
</key>

The string “^^^” indicates that the user-selected target address(es) should be used. Alternately, a fixed 3-character
address can be used to target a fixed address.

If a fixed address is used, the messageIdRef and targetingRule parameters should be changed to “MSG-
TARGET-NOT-ALLOWED” and “TargetingNotAllowed” in the key section.

Example:

<key id = "3C|FF|FF|FF|FF" messageIdRef = "MSG-TARGETING-NOT-ALLOWED"
targetingRule = "TargetingNotAllowed"><name>Scream Chime Wail Test to Pole T04
 Only</name><description>Scream Chime Wail Test to Pole T04 Only</description>
</key>

Troubleshooting
If the CapCon System Activity console indicates anything other than a total number of items in the index and a
number, or if the CapCon System Errors/Exceptions/Warnings console has content in red, this indicates that the
configuration has not been executed correctly.

1. If the BlackBerry AtHoc management system, for example, https://<domain-name>/client/default.asp is
available on Internet Explorer on a local workstation, then the indexURL should also be available. Enter the
indexURL in the browser. For example, https://<domain-name>-syndication/cap_amsig_v2/2060799/capindex.

2. If there are items in the feed, an XML similar to the following image should be displayed:

<capIndex xmlns="http://www.incident.com/cap_index/1.0">
    <title>Current CAP Messages</title>
    <updated>2015-10-01T14:09:39.2519688-07:00</updated>
    -<item xmlns="http://www.incident.com/cap_index/1.0">
        <id>B8205FAC-CF2C-4B2D-A3D2-D012D04F3785</id>
        <identifier>B8205FAC-CF2C-4B2D-A3D2-D012D04F3785
        </identifier>
        <sender>AtHoc Admin</sender>
        <status>System</status>
        <msgType>Alert</msgType>
        <firstEffective>2015-10-01T14:09:10.71</firstEffective>
        <lastExpires>2015-10-01T14:24:10.71</lastExpires>
        <url>https://<Domain Name>/Syndication/CAP_AMSIG_V2_    
        2060799/CapIim
        /1012642</url>
        <bounds />
        <format>http://<Domain Name>/cap/1.1</format>
    </item>
</capIndex>

3. If connectivity is still not good, try commenting out the proxyServer and proxyPort variables.
4. If an HTTP or HTTPS error is displayed instead of XML, this may indicate a firewall or certificate issue or a

configuration problem with the BlackBerry AtHoc server syndication folder or subfolders.
5. Check the indexURL and proxy settings in the system_private.config file for any misspellings. If any line

have been misspelled, repeat the configuration steps.
6. Check the capnodelog file for errors. Open Windows Explorer by right-clicking on the IIM Start button and

navigate to C:/Program Files/capnode/capnodelogs and open the capnode.log file with Notepad.
Browse the file to find the time that the indexURL was changed and the CapCon service restarted.
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7. Contact BlackBerry AtHoc technical support. Be prepared to provide
the system_private.config and capnode.log files and screen shots of the console screen and the
BlackBerry AtHoc management console pages.

Create and publish a pre-test alert template
Prerequisite

• Before you start sending test alerts through American Signal Giant Voice, consider the impact on everyone
within hearing distance of the poles you are using during the test.

• Consult with your POC about the acceptable content, user targeting, and device selection of the pre-test
notification.

To create a template that targets end users using the Desktop Popup, email, and messages to other devices to
inform them of a Giant Voice System test, complete the following steps:

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. Click Alerts > Alert Templates.
3. Click New.
4. On the New Template screen, in the Alert Template section, enter a template name and description.
5. Select a folder from the Folder list. Select Test if available.
6. Select Available for quick publish.
7. Select Informational from the Severity list.
8. Select Other from the Type list.
9. In the Content section, enter an alert title. The alert title can be the same as the template name.
10.In the Alert Body field, enter the text to be read by the text-to-speech. The body should contain the details of

the testing with information such as the time testing will start and finish and any actions that should be taken
as a result.

11.In the Target Users section, select the appropriate targeting group, individual users, or query to send the pre-
test notification to.

12.Click Select Personal Devices and then select Desktop App and Email-Personal.
13.In the Personal Devices section, click Options.
14.In the Personal Device Options screen, select App Template and App Audio.
15.Click Apply.
16.In the Schedule section, change the Alert Duration to the expected duration of the testing.
17.Click Save.
18.Click   to return to the Home page.
19.In the Quick Publish section, find the Giant Voice System Test Notification template and click Review and

Publish.
20.Review the settings and selections.
21.Click Publish.
22.To verify that the alert was published correctly, observe the receipt of Desktop Popup or email messages on

the POC workstation.

Verify the serial communication
If the system has been configured with a Key User containing Cancel All or Quiet Test commands, these keys can
be used to test the serial interconnection without generating any sound through the Giant Voice System.

1. Log in to the BlackBerry AtHoc management system as an administrator.
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2. On the Home page, in the Quick Publish section, search for Giant Voice System Test and then click Edit.
3. In the Mass Devices section, select American Signal Giant Voice - V2.
4. In the Mass Devices section, click Options.
5. On the Mass Devices Options screen, select Giant Voice Key.
6. Click Apply.
7. In the Schedule section, change the Alert Duration to 15 minutes.
8. Click Review and Publish.
9. Click Publish.
10.Observe the operations of the following:

• In the IIM console window: The number of items in index increases and it starts processing the alert.
• The CompuLert™ software transmits the Activation Function or Hot Key selected in the BlackBerry AtHoc

management system.
• Associated Giant Voice poles emits no sound because of the command sent.

11.If unexpected results are found, do the following

a. Double-check the CompuLert.cfg file.
b. Verify that the Key User ATHOC-GV-KEYS attribute configuration file is constructed correctly.

12.If activation fails, double-check the serial cable connections, IIM Com Port settings, and system
private.config file serial configuration variables.
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BlackBerry AtHoc Customer Support Portal
BlackBerry AtHoc customers can obtain more information about BlackBerry AtHoc products or get answers to
questions about their BlackBerry AtHoc systems through the Customer Support Portal:

https://support.athoc.com

The BlackBerry AtHoc Customer Support Portal also provides support via computer-based training, operator
checklists, best practice resources, reference manuals, and user guides.
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Documentation feedback
The BlackBerry AtHoc documentation team strives to provide accurate, useful, and up-to-date
technical documentation. If you have any feedback or comments about AtHoc documentation, email
athocdocfeedback@blackberry.com. Please include the name and version number of the document in your email.

To view additional BlackBerry AtHoc documentation, visit https://docs.blackberry.com/en/id-comm-collab/
blackberry-athoc. To view the BlackBerry AtHoc Quick Action Guides, see https://docs.blackberry.com/en/id-
comm-collab/blackberry-athoc/Quick-action-guides/latest.

For more information about BlackBerry AtHoc products or if you need answers to questions about your BlackBerry
AtHoc system, visit the Customer Support Portal at https://support.athoc.com.
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Legal notice
 ©2020 BlackBerry Limited. Trademarks, including but not limited to BLACKBERRY, BBM, BES, EMBLEM Design,
ATHOC, CYLANCE and SECUSMART are the trademarks or registered trademarks of BlackBerry Limited, its
subsidiaries and/or affiliates, used under license, and the exclusive rights to such trademarks are expressly
reserved. All other trademarks are the property of their respective owners. 

 This documentation including all documentation incorporated by reference herein such as documentation
provided or made available on the BlackBerry website provided or made accessible "AS IS" and "AS AVAILABLE"
and without condition, endorsement, guarantee, representation, or warranty of any kind by BlackBerry Limited and
its affiliated companies ("BlackBerry") and BlackBerry assumes no responsibility for any typographical, technical,
or other inaccuracies, errors, or omissions in this documentation. In order to protect BlackBerry proprietary and
confidential information and/or trade secrets, this documentation may describe some aspects of BlackBerry
technology in generalized terms. BlackBerry reserves the right to periodically change information that is contained
in this documentation; however, BlackBerry makes no commitment to provide any such changes, updates,
enhancements, or other additions to this documentation to you in a timely manner or at all. 

This documentation might contain references to third-party sources of information, hardware or software,
products or services including components and content such as content protected by copyright and/or third-
party websites (collectively the "Third Party Products and Services"). BlackBerry does not control, and is not
responsible for, any Third Party Products and Services including, without limitation the content, accuracy,
copyright compliance, compatibility, performance, trustworthiness, legality, decency, links, or any other aspect
of Third Party Products and Services. The inclusion of a reference to Third Party Products and Services in this
documentation does not imply endorsement by BlackBerry of the Third Party Products and Services or the third
party in any way.

EXCEPT TO THE EXTENT SPECIFICALLY PROHIBITED BY APPLICABLE LAW IN YOUR JURISDICTION, ALL
CONDITIONS, ENDORSEMENTS, GUARANTEES, REPRESENTATIONS, OR WARRANTIES OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING WITHOUT LIMITATION, ANY CONDITIONS, ENDORSEMENTS, GUARANTEES,
REPRESENTATIONS OR WARRANTIES OF DURABILITY, FITNESS FOR A PARTICULAR PURPOSE OR USE,
MERCHANTABILITY, MERCHANTABLE QUALITY, NON-INFRINGEMENT, SATISFACTORY QUALITY, OR TITLE, OR
ARISING FROM A STATUTE OR CUSTOM OR A COURSE OF DEALING OR USAGE OF TRADE, OR RELATED TO THE
DOCUMENTATION OR ITS USE, OR PERFORMANCE OR NON-PERFORMANCE OF ANY SOFTWARE, HARDWARE,
SERVICE, OR ANY THIRD PARTY PRODUCTS AND SERVICES REFERENCED HEREIN, ARE HEREBY EXCLUDED.
YOU MAY ALSO HAVE OTHER RIGHTS THAT VARY BY STATE OR PROVINCE. SOME JURISDICTIONS MAY
NOT ALLOW THE EXCLUSION OR LIMITATION OF IMPLIED WARRANTIES AND CONDITIONS. TO THE EXTENT
PERMITTED BY LAW, ANY IMPLIED WARRANTIES OR CONDITIONS RELATING TO THE DOCUMENTATION TO
THE EXTENT THEY CANNOT BE EXCLUDED AS SET OUT ABOVE, BUT CAN BE LIMITED, ARE HEREBY LIMITED TO
NINETY (90) DAYS FROM THE DATE YOU FIRST ACQUIRED THE DOCUMENTATION OR THE ITEM THAT IS THE
SUBJECT OF THE CLAIM.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, IN NO EVENT SHALL
BLACKBERRY BE LIABLE FOR ANY TYPE OF DAMAGES RELATED TO THIS DOCUMENTATION OR ITS USE,
OR PERFORMANCE OR NON-PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR ANY THIRD
PARTY PRODUCTS AND SERVICES REFERENCED HEREIN INCLUDING WITHOUT LIMITATION ANY OF THE
FOLLOWING DAMAGES: DIRECT, CONSEQUENTIAL, EXEMPLARY, INCIDENTAL, INDIRECT, SPECIAL, PUNITIVE,
OR AGGRAVATED DAMAGES, DAMAGES FOR LOSS OF PROFITS OR REVENUES, FAILURE TO REALIZE ANY
EXPECTED SAVINGS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, LOSS OF BUSINESS
OPPORTUNITY, OR CORRUPTION OR LOSS OF DATA, FAILURES TO TRANSMIT OR RECEIVE ANY DATA,
PROBLEMS ASSOCIATED WITH ANY APPLICATIONS USED IN CONJUNCTION WITH BLACKBERRY PRODUCTS OR
SERVICES, DOWNTIME COSTS, LOSS OF THE USE OF BLACKBERRY PRODUCTS OR SERVICES OR ANY PORTION
THEREOF OR OF ANY AIRTIME SERVICES, COST OF SUBSTITUTE GOODS, COSTS OF COVER, FACILITIES OR
SERVICES, COST OF CAPITAL, OR OTHER SIMILAR PECUNIARY LOSSES, WHETHER OR NOT SUCH DAMAGES
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WERE FORESEEN OR UNFORESEEN, AND EVEN IF BLACKBERRY HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, BLACKBERRY SHALL
HAVE NO OTHER OBLIGATION, DUTY, OR LIABILITY WHATSOEVER IN CONTRACT, TORT, OR OTHERWISE TO
YOU INCLUDING ANY LIABILITY FOR NEGLIGENCE OR STRICT LIABILITY.

THE LIMITATIONS, EXCLUSIONS, AND DISCLAIMERS HEREIN SHALL APPLY: (A) IRRESPECTIVE OF THE NATURE
OF THE CAUSE OF ACTION, DEMAND, OR ACTION BY YOU INCLUDING BUT NOT LIMITED TO BREACH OF
CONTRACT, NEGLIGENCE, TORT, STRICT LIABILITY OR ANY OTHER LEGAL THEORY AND SHALL SURVIVE A
FUNDAMENTAL BREACH OR BREACHES OR THE FAILURE OF THE ESSENTIAL PURPOSE OF THIS AGREEMENT
OR OF ANY REMEDY CONTAINED HEREIN; AND (B) TO BLACKBERRY AND ITS AFFILIATED COMPANIES, THEIR
SUCCESSORS, ASSIGNS, AGENTS, SUPPLIERS (INCLUDING AIRTIME SERVICE PROVIDERS), AUTHORIZED
BLACKBERRY DISTRIBUTORS (ALSO INCLUDING AIRTIME SERVICE PROVIDERS) AND THEIR RESPECTIVE
DIRECTORS, EMPLOYEES, AND INDEPENDENT CONTRACTORS.

IN ADDITION TO THE LIMITATIONS AND EXCLUSIONS SET OUT ABOVE, IN NO EVENT SHALL ANY DIRECTOR,
EMPLOYEE, AGENT, DISTRIBUTOR, SUPPLIER, INDEPENDENT CONTRACTOR OF BLACKBERRY OR ANY
AFFILIATES OF BLACKBERRY HAVE ANY LIABILITY ARISING FROM OR RELATED TO THE DOCUMENTATION.

Prior to subscribing for, installing, or using any Third Party Products and Services, it is your responsibility to
ensure that your airtime service provider has agreed to support all of their features. Some airtime service
providers might not offer Internet browsing functionality with a subscription to the BlackBerry® Internet Service.
Check with your service provider for availability, roaming arrangements, service plans and features. Installation
or use of Third Party Products and Services with BlackBerry's products and services may require one or more
patent, trademark, copyright, or other licenses in order to avoid infringement or violation of third party rights. You
are solely responsible for determining whether to use Third Party Products and Services and if any third party
licenses are required to do so. If required you are responsible for acquiring them. You should not install or use
Third Party Products and Services until all necessary licenses have been acquired. Any Third Party Products and
Services that are provided with BlackBerry's products and services are provided as a convenience to you and are
provided "AS IS" with no express or implied conditions, endorsements, guarantees, representations, or warranties
of any kind by BlackBerry and BlackBerry assumes no liability whatsoever, in relation thereto. Your use of Third
Party Products and Services shall be governed by and subject to you agreeing to the terms of separate licenses
and other agreements applicable thereto with third parties, except to the extent expressly covered by a license or
other agreement with BlackBerry.

The terms of use of any BlackBerry product or service are set out in a separate license or other agreement with
BlackBerry applicable thereto. NOTHING IN THIS DOCUMENTATION IS INTENDED TO SUPERSEDE ANY EXPRESS
WRITTEN AGREEMENTS OR WARRANTIES PROVIDED BY BLACKBERRY FOR PORTIONS OF ANY BLACKBERRY
PRODUCT OR SERVICE OTHER THAN THIS DOCUMENTATION.

BlackBerry Enterprise Software incorporates certain third-party software. The license and copyright information
associated with this software is available at http://worldwide.blackberry.com/legal/thirdpartysoftware.jsp.

BlackBerry Limited
2200 University Avenue East
Waterloo, Ontario
Canada N2K 0A7

BlackBerry UK Limited
Ground Floor, The Pearce Building, West Street,
Maidenhead, Berkshire SL6 1RL
United Kingdom

Published in Canada
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